Announcement

Collapse
No announcement yet.

Directional light making terrain dark

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Directional light making terrain dark

    I'm not sure if this is the right place to ask this but when I add a directional light over my terrain and build the lighting, everything turns dark. Anyone know a way to fix that?

    #2
    Originally posted by mudcrab View Post
    I'm not sure if this is the right place to ask this but when I add a directional light over my terrain and build the lighting, everything turns dark. Anyone know a way to fix that?
    The whole terrian or just patches? Have you set it to full-quality-build when building the lights?

    Comment


      #3
      Originally posted by azurescorch View Post
      The whole terrian or just patches? Have you set it to full-quality-build when building the lights?
      It's all of the terrain as if there's no lighting, and I have tried a full build.

      Comment


        #4
        Did you make your map in additive mode?
        Do you have a skydome static mesh already in place? If yes go to its properties and set bShadowCast=False.

        Comment


          #5
          Originally posted by Sly. View Post
          Do you have a skydome static mesh already in place? If yes go to its properties and set bShadowCast=False.
          turn off accept lights too

          Comment


            #6
            Originally posted by Sly. View Post
            Did you make your map in additive mode?
            Do you have a skydome static mesh already in place? If yes go to its properties and set bShadowCast=False.
            I've expanded all the categories for the Skydome properties but I don't see an option for that. Am I looking in the wrong properties window?

            Comment


              #7
              In Unreal Engine 1 and 2 you could find this option in the Display section. I think in UE3 it is in the same section as in UE1 and UE2.

              (It would take forever to check this right now, I have a pretty slow PC for today's standards and the editor needs minutes to open and I don't have the time right now. Sorry Still I can run the game on a bit higher than just mid details, strange lol)

              PS: If you have further questions about the UT3Ed and issues with something you might want to post other questions about the editor in the "Level Editing, Modelling & Skinning" section. Usually this is the place to post such things. You can find it in the "Mod Requests/Idea Sharing" section

              Comment


                #8
                Originally posted by Sly. View Post
                In Unreal Engine 1 and 2 you could find this option in the Display section. I think in UE3 it is in the same section as in UE1 and UE2.

                (It would take forever to check this right now, I have a pretty slow PC for today's standards and the editor needs minutes to open and I don't have the time right now. Sorry Still I can run the game on a bit higher than just mid details, strange lol)

                PS: If you have further questions about the UT3Ed and issues with something you might want to post other questions about the editor in the "Level Editing, Modelling & Skinning" section. Usually this is the place to post such things. You can find it in the "Mod Requests/Idea Sharing" section
                I don't see anything there in the display section, aside from "bhidden" and drawscale, but thanks. I will try that.

                Comment


                  #9
                  it's under StaticMeshActor -> StaticMeshComponent -> Lighting

                  bAcceptLights and bCastShadow should be unchecked

                  Comment

                  Working...
                  X