Announcement

Collapse
No announcement yet.

Help, how to fix low fps in windows 7?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    Does running on compatibility mode help?

    I'm curious, since I have Windows 7, as well, and I'm wondering if my low FPS can be blamed on Windows 7 instead of my 2.1 Ghz CPU.

    Comment


      #47
      Nope, i tried everything: disabled dx10 used -onethread, turned off aero,xp compatibility nothing helps.
      The vista-win7 is pure rubbish for gaming, and xp will always be faster 20 percent as long as they support it with drivers.
      Period.

      Comment


        #48
        I use win 7 X64 and get better performance in win7 than with XP 32 bit and X64.

        Since hardware varies so much on PC's not everyone will get the same performance even when using the same OS version etc.

        Comment


          #49
          Originally posted by CVROY View Post
          I use win 7 X64 and get better performance in win7 than with XP 32 bit and X64.

          Since hardware varies so much on PC's not everyone will get the same performance even when using the same OS version etc.
          Yes i agree on that(forgot to put that in my earlier post). From my observation, people that have dual and quad core, mostly reported these problems. I havent found a single I5/I7 user that had issues on win 7 with framerate.(probably because those processors are alot faster than dual core)
          Another thing i noticed is that -onethread switch actually worked in vista64 bit,(i got same framerates like in XP) however that is not the case in win 7 32 bit.
          I havent tried on win 7 64bit though.

          EDIT:
          Forgot to ask you, which hardware you got?(CPU, GPU,ram etc)

          Comment


            #50
            Sorry for the double post, but after fiddling with win 7 i actually found what is the problem!!
            Finally!
            Ok, now lets get back to topic:
            Go to power options(it is probably s et to balanced)
            Then go to "change plan settings"
            "Turn of display" set to Never
            "Put the computer to sleep" set to Never
            Go to "change advanced power settings"
            Expand "Hard disk" and set "Turn of harddisk" to Never
            Expand "Desktop background settings and put "Slide show" to Never
            Expand "Wireless adapter settings and set "Power saving Mode" to "Maximum performance
            Expand "PCI express" and Linkstate Power Management" and set it to "off"
            In Procesor Power management set "Minimum processor state to 100%,(was on 25%) "system cooling policy" to "passive" and "Maximum processor state" to 100%(probably already set)

            And i get exactly the same framerates like in XP 32."Minimum processor state set to 25% was the main reason i was getting low framerates.
            Hope this will help people which have sluggish performance on win 7.

            Comment


              #51
              Originally posted by Designer0101 View Post
              Sorry for the double post, but after fiddling with win 7 i actually found what is the problem!!
              Finally!
              Ok, now lets get back to topic:
              Go to power options(it is probably s et to balanced)
              Then go to "change plan settings"
              "Turn of display" set to Never
              "Put the computer to sleep" set to Never
              Go to "change advanced power settings"
              Expand "Hard disk" and set "Turn of harddisk" to Never
              Expand "Desktop background settings and put "Slide show" to Never
              Expand "Wireless adapter settings and set "Power saving Mode" to "Maximum performance
              Expand "PCI express" and Linkstate Power Management" and set it to "off"
              In Procesor Power management set "Minimum processor state to 100%,(was on 25%) "system cooling policy" to "passive" and "Maximum processor state" to 100%(probably already set)

              And i get exactly the same framerates like in XP 32."Minimum processor state set to 25% was the main reason i was getting low framerates.
              Hope this will help people which have sluggish performance on win 7.
              Wow, good find! I'm gonna test it in a bit.

              But seriously? Setting Processor to 100% minimum, and switch cooling to passive?

              Won't that overheat my laptop?

              Comment


                #52
                I also have a couple of more tweaks that might help.

                In Control Panel> System> System Properties>Advanced> Performance Settings> Advanced, Change the Virtual Memory Paging size to 2560 MB. (Warning: only do this if you have 2 GB of RAM, since I don't know what this does with computers with low RAM.)

                Also, check your BIOS settings and make sure they match your computer. (There are guides on this online).

                Comment


                  #53
                  The truth is if you Only play UT3 the best set up is XP 32bit with 2gb memory.

                  I understand the dilemma, it's a real problem with tech moving on and >2gb ram rigs mean running 64 bit OSes is becoming the norm ,plus DX11 games are obv. restricted to the newer OSes. I've tested both 32bit Xp and 64 bit OSes and the difference -not in peak but lowest and average framerates on Deck was substantial : around 60fps difference in places on that map.

                  Then there are the (better security at a price) network stack issues in the newer OSes. Of course Epic could probably patch away most of the issues, but it looks unlikely -the UDK is getting 64bit treatment tho for obvious reasons, so who knows.

                  The power management tweaks above might help, but the result is a processor that doesn't down clock when under utilised or idling like just viewing these web pages and there is the resultant heat/power concern. Unless there is a problem these power saving tools are pretty responsive to apps anyway in my experience.

                  Comment


                    #54
                    Designer101 kind of has a point, I changed those settings the day I installed windows 7 and than forget about them. Never had performance issues with UT3.

                    But other people might skip it and if the PC come pre-installed with windows7 the techie might of changed it to power saving etc.

                    Would explain to some degree the performance issues people is having.

                    Comment


                      #55
                      In Procesor Power management set "Minimum processor state to 100%,(was on 25%) "system cooling policy" to "passive" and "Maximum processor state" to 100%(probably already set)
                      I don't see this option under there. I only see 'System Cooling Policy'.

                      Comment


                        #56
                        Originally posted by BlueCloud View Post
                        I don't see this option under there. I only see 'System Cooling Policy'.
                        You have to hit the plus sign to expand the menu.

                        However, I wouldn't switch it to passive until someone confirms that it won't make your computer melt.

                        Comment


                          #57
                          Rather stick to just High Performance

                          Comment


                            #58
                            Originally posted by Designer0101 View Post

                            EDIT:
                            Forgot to ask you, which hardware you got?(CPU, GPU,ram etc)
                            I am using an E6850 conroe CPU, 9800 GT with 1 GIG ram PCIexpress. win 7 X64 with 8 GIGS RAM. I also use the BFG ageia physx pci card with UT3.

                            Comment


                              #59
                              I haven't noticed any change in the performance i get in 3ds max with the high performance plan, it's not the same as xp.

                              Comment


                                #60
                                I changed my Windows 7 settings to Performance and Ut3 works much better... if I wanted all the visuals..i just enable it..
                                i.e Computer->Properties->Advanced Settings->Performance->Adjust for best performance

                                Comment

                                Working...
                                X