Announcement

Collapse
No announcement yet.

Help, how to fix low fps in windows 7?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Help, how to fix low fps in windows 7?

    Hey guys so when i was running ut3 on windows xp 32 bits it all ran fine and all giving me some impressive 133fps in a specific area i use as benchmark reference... now since ive installed windows 7 64bits i can barely get 90fps... i know this might sound like im exagerating but the truth is in intensive areas it gets way below 60fps which is real problem... here are my specs:
    Asus P5QL Pro
    Intel Core 2 Duo E8400 @3.85ghz (stable and max temp 58ÂșC under stress)
    Ati HD 4870 512mb
    4GB DDr2 1066mhz Corsair Dominator Xms2
    Sound card: Creative Audigy 2 ZS
    Windows 7 ultimate 64bits.
    Ati Tray Tools is beying used instead of ATI CCC
    Norton 360v3

    When playing the cpu load is always 100%
    Anyone got any clue about this issue? its rly worrying me as im considering reinstalling back windows xp and i do not want that because it will mean i wasted all this time installing win 7 for nothing...
    Thanks in advance!

    #2
    Thread updated with sound card, ATi Tray Tools and Antivirus

    Comment


      #3
      Norton 360...
      Symantec's security tools are notorious for protecting systems by rendering them unusable.

      Then again, Win7 enables UT3 to use DirectX 10, I think. This would allow the game to use anti-aliasing and post-processing at the same time, while this combination wasn't really available under XP's DirectX 9.

      Comment


        #4
        I doubt it has anything to do with Win 7 but it could be Norton 360.

        To check that right click on the tray icon and disable Auto Protect (temporarily) and run the game to see if that helps with your FPS problem.
        Make sure you re-enable auto protect once your done!

        Comment


          #5
          also add this to your shortcut "-onethread" or something like that, there is a large amount of threads about the -onethread...i didnt get any fps boost from it though...well maybe because im still on xp32...

          but with that setup you mention.. you should be able to run the game with 200 fps steady in 1680x1050 res, i have similar setup though my gfx card is 8800gtx , and my E8400 aint oc'ed as much aswell, i oc'ed mine to 3.400 ghz..
          and ofc my eye candy aint maxed, i disabled/tweaked most of the annoying eye candy

          Comment


            #6
            This is a long read, but more then worth the time for the bump you will get from the tweaks listed in the guide:
            http://www.tweakguides.com/UT3_1.html

            They take the time to explain what each tweak is doing, hence why it's so long.

            Focus on turning off FPS smoothing and mouse smoothing first. Also might want to set DirectX 10 off, not much gained in the IQ department but a lot of lost performance.

            Are you seeing hitching at all or just a general overall slowdown?

            Comment


              #7
              Originally posted by Wormbo View Post
              Norton 360...
              Symantec's security tools are notorious for protecting systems by rendering them unusable.

              Then again, Win7 enables UT3 to use DirectX 10, I think. This would allow the game to use anti-aliasing and post-processing at the same time, while this combination wasn't really available under XP's DirectX 9.
              im using it in with -dx9 command in the shortcut option
              tried norton 360 auto protect off same result.

              Comment


                #8
                Originally posted by Tm'BronsoN View Post
                also add this to your shortcut "-onethread" or something like that, there is a large amount of threads about the -onethread...i didnt get any fps boost from it though...well maybe because im still on xp32...

                but with that setup you mention.. you should be able to run the game with 200 fps steady in 1680x1050 res, i have similar setup though my gfx card is 8800gtx , and my E8400 aint oc'ed as much aswell, i oc'ed mine to 3.400 ghz..
                and ofc my eye candy aint maxed, i disabled/tweaked most of the annoying eye candy
                with -onethread activated i actually get less fps than before lol

                Comment


                  #9
                  Hi looks like we have almost same problems.
                  i have q9550 oc'ed to 3.8ghz ati 4870x2 and 2x2gb geil oc'ed to 900mhz.
                  Under windows 7 64bit i have fps drops all the time on maps like shangrila,deck,sanctuary and ofc warfare maps.
                  Tryed everything and its still same,-onethread shortcut doesnt help at all in my case.
                  I run game with maxed settings in 1680x1050 and aa is off in ccc.
                  Maybe its game,engine problem im not sure but id like to know how to fix this problem if its possible.
                  Cheers

                  Comment


                    #10
                    if windows 7 crappy performance keeps like this im seriously considering to install windows xp 64 bits (the 32bits was the one i used to get 133fps but i got 4gb of ram so thats why im gonna go for the 64bits)...

                    Comment


                      #11
                      anyone else got any ideas? tried all even tweaking performance is still the same, infact im sure its something to do with the cpu simply because if i increase res from 1280*720 to 1920*1080 i only get 1 fps drop...

                      Comment


                        #12
                        Not sure this will help, but when I moved from a Dual Core to a Quad Core, I noticed a big difference in performance in UT3. Cores would not be maxed out all the time, and no more slowdowns. Pretty sure I had a higher minimum frame rate as well. Other than that not sure what to recommend - it sounds like a CPU limitation in the new OS because scaling your res up or down does not gain you many FPS.

                        Comment


                          #13
                          Originally posted by Masaai_Warrior View Post
                          Not sure this will help, but when I moved from a Dual Core to a Quad Core, I noticed a big difference in performance in UT3. Cores would not be maxed out all the time, and no more slowdowns. Pretty sure I had a higher minimum frame rate as well. Other than that not sure what to recommend - it sounds like a CPU limitation in the new OS because scaling your res up or down does not gain you many FPS.
                          yes but i doubt its the cpu fault, that would mean other games to get a performance impact of 40% too which none other gets...

                          Comment


                            #14
                            Originally posted by The Ancient Keeper View Post
                            yes but i doubt its the cpu fault, that would mean other games to get a performance impact of 40% too which none other gets...
                            If it's bothering you that much , why not just dual boot or load XP onto another drive?

                            UT3 is very much a DX9/32bit XP era game. Sadly it was never big enough for Nvidia and MS to be really concerned about. Just look how long it took to get properly functioning Nvidia drivers.

                            Epic's last major patch was some time ago now, and unless they surprise everyone, it doesn't look like there'll be any more patches.

                            Comment


                              #15
                              u know whats funny? i was one of the rare guys who paid the 50€ price for this game... i bought ut2k4 for 40€ and was happy and still am happy with it for years... i believe ut2k4 community even now is still bigger than ut3 community... the only downside is those gameservers.net guys killed our redirection support and left me and my ut2k4 server with no redirection option anymore...

                              Still even now i enjoy ut2k4 more than ut3 but i would rly like to resolve this issue as i use ut3 to play sometimes aswell.

                              Comment

                              Working...
                              X