The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Servers not showing in my browser tonight.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Servers not showing in my browser tonight.

    I can hardly get 3-4 servers , shown in the browser , in any gametype(when i have "show empty servers" i get 10 more but after every refresh i get randomly less or a bit more.

    In my favs the servers are marked with ping 9999 but if i try to join , i can with no probs (sad thing is i have in favs only 2-3 servers this days n they arent my favs anymore).

    Its a rare prob for me. I had it like 3-4 times since ut3 was out. Asked in irc n noone else seems to have it tonight. All the other times it wasn't just me.

    My net is the usual in every other aspect.

    Could be country relevant? I play from Greece .

    Its strange.

    Edit : tried the history in the browser n i had 10 or so servers with 9999 ping n 0 players or bots . Tried to join n i can. Wtf?

  • #2
    OMG i changed my router today. I tried the old one n all the servers show up.

    Any ideas why it happens ?


    • #3
      I'm on the west coast and I'm getting nothing but severs above 200 ping. I usually have a quite a few choices under 100 including Epic Greed and the chicago and atlanta vipermax servers.


      • #4
        you should try running the game as Administrator. Right click icon and click "run as Administrator"


        • #5
          My problem is that with my old router i can see the servers in the browser but with the new one i can't . I had 4 routers used with ut3 so far n i never had this problem.


          • #6
            Sounds like the same problem I had, but was not related to the router at all.

            I have to play with full admin privledges for all the servers to show up. I have to right click the UT3 desktop icon and then uncheck the run with limited access box. You also need to delete all the servers from favorites with the 9999 ping for them to show up corectly again. .I do not know exactly why, but that was the fix epic advertised for this. Some sort of epic-gamespy glitch I think. Works for me, even if it's a pain in the arse to do.


            • #7
              The strage thing is that all the other routers i used never had this prob. I use the old one atm n i see all the servers.

              Could be something that i need to change in the router settings ?

              Ill try the admin solution tomorrow when ill have some time.

              Thanxx for the help guys.