Announcement

Collapse
No announcement yet.

Hosting a game: nerving "Portforwarding-DMZ-Host_game_isn't_possible"-Message

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by Aemi View Post
    You should buy a router. Rauters are pretty unreliable seeing as how they don't exist.
    When he wrote that our answers are much, much, much appreciated he wasn't referring to you. You are a waste of internet space.

    Leave a comment:


  • replied
    Originally posted by fireball View Post
    I like to host games, not dedicated, I play too.

    But everytime I get this nerving message (I am sure you guys know this message too).

    About half of all people tell me, that they are NOT ABLE TO CONNECT to my game.
    While the other half seem to have no connecting problems.
    - Strange, isn't it?

    As a test I
    - FORWARDED ALL THE PORTS TO MY PC (CALLED A DMZ, right?)
    - DISABLED THE WINDOWS FIREWALL
    - BOUGHT A NEW RAUTER (because somebody said it can be the rauter itself)

    Well, still the same problem!

    Is there a very special RAUTER I have to buy?
    Or what exactly I have to do so that EVERYBODY! can connect to my hosted games?



    Your answers are much, much, much appreciated
    You should buy a router. Rauters are pretty unreliable seeing as how they don't exist.

    Leave a comment:


  • replied
    can host, get the message anyway. Running my own STUN seems to lead to other problems, IIRC.

    Leave a comment:


  • replied
    That message is part of a broken feature. No kidding, huh...

    To turn that annoying message off, Open the UTEngine.ini file. Located in C:\%username%\Documents\My Games\Unreal Tournament 3\UTGame. In Win XP it is in the "My Documents" folder. And as long as you are not using the -nohomedir switch (by default you are not).

    Search for "StunServerAddress" without the quotes.

    There will be 2 lines for this.

    Edit both lines to read StunServerAddress=UT3

    Save and close the file.

    I have seen some say you need the Stunserver app. If you just edit the ini as above, you do not need the Stunserver app.

    As long as you have the ports open on your firewall/router, you should no longer get that annoying message and can host/join games.

    I have my ini edited as such and run MapMixer. Friends can join my hosted games every time. (They can join whether I have MapMixer running or not. MapMixer, best UT2004/UT3 mod ever...)

    As far as firewall ports go, there was an old thread on here somewhere that the OP said he got these from Midway support. They are all UDP ports, no TCP ports needed and these are what I use.

    The UDP ports are: 3783, 6500, 6515, 6667, 7777, 13139, 27900, 28900, 29900, 29901

    Hope this helps...

    One other thing. In your router, if there is a setting for "NAT Endpoint Filtering", make sure it is set to "Endpoint Independent" for both TCP and UDP Endpoint Filtering.

    Leave a comment:


  • replied
    As I said, I have an external firewall which doesn't let _anything_ in to my gaming PC unless the connection has been established FROM the lan TO the remote host OR the traffic is on any of those three ports. Set that up and you should be fine. I can guarantee pf won't let anything through that I haven't specifically told it to.

    Leave a comment:


  • replied
    I've tried setting up ports and all sorts. It still wouldn't work so I simply gave up, wasn't worth the time it was taking. I only tried as I wanting to duel with a newbie friend in private. We ended up having to use Hamachi to emulate a Lan connection instead.

    Leave a comment:


  • replied
    You should also have a choice that says I do not host matches.

    Here is an article called "How To Configure Your Router for Gaming"

    http://www.extremetech.com/article2/...2348946,00.asp

    Something to remember, do not use two routers in series because it will never work.

    Leave a comment:


  • replied
    rdr on $ext_if proto udp from any to any port 13000 -> 192.168.0.40 port 13000
    rdr on $ext_if proto udp from any to any port 7777 -> 192.168.0.40 port 7777
    rdr on $ext_if proto udp from any to any port 6500 -> 192.168.0.40 port 6500

    I set these rules in my firewall (i.e. forward UDP ports 6500, 7777 and 13000) and then I can host games. The game still gives me that stupid error message, but it means nothing as people can join.

    Leave a comment:


  • replied
    i just kick everyone off my wifi, and remove the router from the whole scenario. problem solved.

    never tried the other 'workarounds'

    Leave a comment:


  • Hosting a game: nerving "Portforwarding-DMZ-Host_game_isn't_possible"-Message

    I like to host games, not dedicated, I play too.

    But everytime I get this nerving message (I am sure you guys know this message too).

    About half of all people tell me, that they are NOT ABLE TO CONNECT to my game.
    While the other half seem to have no connecting problems.
    - Strange, isn't it?

    As a test I
    - FORWARDED ALL THE PORTS TO MY PC (CALLED A DMZ, right?)
    - DISABLED THE WINDOWS FIREWALL
    - BOUGHT A NEW RAUTER (because somebody said it can be the rauter itself)

    Well, still the same problem!

    Is there a very special RAUTER I have to buy?
    Or what exactly I have to do so that EVERYBODY! can connect to my hosted games?



    Your answers are much, much, much appreciated
Working...
X