Announcement

Collapse
No announcement yet.

Hm... Excessive Shot Lag with Weapons?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    Stinger primary is hitscan, secondary, as you obviously see, is not.

    Comment


      #47
      Indeeeed *smokes a pipe* (not really)

      Comment


        #48
        The hit boxes in UT3 have been reduced in size from UT2K4. This makes all hitscan weapons harder to hit with and was done to balance out the dominance of hitscan weapons. In UT2K4, why would you use anything but shock?

        Comment


          #49
          Originally posted by CaptainSnarf View Post
          The hit boxes in UT3 have been reduced in size from UT2K4. This makes all hitscan weapons harder to hit with and was done to balance out the dominance of hitscan weapons. In UT2K4, why would you use anything but shock?
          In UT3 why would you use something else than rocket launcher and stinger?

          Comment


            #50
            I agree, but i feel this may be down to ping as much as anything, i can really tell the difference in a 40 ping game and 100 ping game, nothing else changes except my shots fire off that split second slower, for me its noticable and frsutrating, this is on the ps3 btw

            Comment


              #51
              There are lots of differences between shooting shock in 2k4 and UT3. First of all, the mouse movement. Whatever settings I tweak, I still can't move the mouse like in 2k4. Secondly, the hitboxes seem to have been reduced in size a lot. And thirdly, lag and the feeling of lag, is much worse in UT3, especially on warfare servers where there's lot of CPU load, and I am told that UT3 can't make good use of more than one core/processor on the server side. Lastly, the shock beam in UT3 is quite thick and blocks your line of sight for the next shot unlike the clean thin laser in 2k4.

              Comment


                #52
                Edit: Ohh lol... TLDR Version- out of potential GPU, CPU, Monitor, Mice, and Network Connection issues, I believe that a gross input/output disparity between hosts and clients is the major cause for online lag in UT3.

                Here's my non-technical, detailed report on this issue as it pertains to me in the order of "research", specs/settings, and conclusions:

                Intro: This thread discussion motivated me to determine if my online aim/hit rate wasn't "great" because of some type of lag or my aim just isn't as true as I would hope it to be. To cite an example, I usually hit a player at whatever distance with my third or fourth shock primary and then I seem to be more accurate :/. That would be without any excessively random movements or dodge jumping from me or my target and sometimes even with those complications.

                Test & Results: Now, I tried a game of Torlan online with 32 Godlike bots (since I'm only an average player on a DM/TDM map and I only play WAR now). I noted a drastic improvement with my accuracy across the distance spectrum, with special attention paid to Shock primary hits. I decided to try out the Sniper Rifle and I hardly, if at all, had to lead into my shots to produce a hit (or headshot o.O), which contrasts starkly with my online Sniping performace. Granted, bots are hardly substitutes for real players where movement is concerned, but I intentially limitted my results to simple movements & tracking only. Also, while my test was very brief, it was very conclusive. As a side note, I recall my Flak shots being less precise offline than online, which I can only conclude is a result of having adapted to online lag.

                Graphics/FPS: As for my settings and specs and stuff, I have turned off all of UT3's direct FPS limitters and junk. I have a 75Hz LCD monitor, and Stat FPS says that I currently get ~100 FPS on main menu, which may dip as low to ~35-40 in-game under intense circumstances (offline and online, I believe).
                Mouse: My mouse (I think--currently not at home) is a Logitech MX300 or MX310 and my in-game mouse sensitivity setting is at 2200 (works well enough for me). I don't know if I have SetPoint installed, but I can't find it in the uninstall menu or with the Search function so I'm guessing not. I have also turned off the mouse acceleration and smoothing.
                Online Gamplay Observations: Lately, I have only played EpicServer2 (FYI, 32 player server) WAR, whose ping has risen for me since the patch by like 70-130--perhaps as a result of more/new players--from 30-130 :/... HOWEVER! EpicServer2 seems to have drastically reduced in godawful lag spikes (for me) from not often to quite rarely. Unfortunately as a whole, my quality of gameplay on EpicServer2 as measured by "input to in-game reponse" has had a more than marginal decrease regardless of player count, and yet that input response remains much more consistantly playable than pre-patch.
                Internet Connection + Ping: My internet connection is High Speed cable, behind a router, which is hands down the fastest option for average homeowners in my not-so-immediate vicinity. Nonetheless, I get too few servers with pings under 100, and I believe that Taffy's Beer Drinkers and Hell Raisers TDM server and UMG's WAR server(s) consistantly have the best pings at ~40 and ~60 respectively (as measured by the server browser).

                Conclusions: Having said all that:
                -I don't feel that my lag is caused by anything GPU (eVGA 8800GTS 320MB) or CPU (Q6600 G0) related since they are good enough for UT3 and only give me issues when I overclock them too high.
                -I can't fathom why my monitor might be at fault when gameplay is much more seemless offline than online.
                -I really don't know enough about mice to conclude if mine is fail or not... are there any ways to test my mouse without getting a new/different one?
                -Finally, I have a sneaking suspicion that the source of mine and many other players' lag is the difference between client-side and server-side umm... whatchamacallit! XD Of everything discussed in this thread, that just seems to be the most plausible and simple cause for most feelings of lag.

                Peace, raep face, and gg. ^_^

                ~ctr

                Comment


                  #53
                  ^ Another TL;DR version: All my stuff r0x0rz j00 b0x0rz and it still lagz ffs.

                  Comment


                    #54
                    I have the same issue. If I use the sniper and stand still I can hit my target with my crossair, as soon as I start moving the shot actually goes eleswhere, try strafing and firing the shock rifle at the same time...

                    The U3 engine just have a poor netcode, stuff like that shouldnt happen on ~30ping servers. It was even worse on xboxlive with games like gears and vegas were you could tell who was the host because he had twice as much kill as everyone.

                    Comment


                      #55
                      I hope most of you are playing on the latest patched 2.0 servers with build 3797 when you are making these comments.

                      Things like sniper lag seems to have been fixed for me and things in general feel a hell of a lot smoother on the new servers. Or maybe it's just UTComp3v4.1, since I only play on those servers now.

                      I still hate flak primary though. I also hate that it's harder to do hammer jumps (compared to ut2k4) as you'd need to point directly to the ground and jump/release at exactly the right time. I'd pretty much fail the first time if I was in a rush.

                      Comment


                        #56
                        I wouldn't make a thread like this if I was playing with a 60hz monitor and a 56k connection and version 1.0 and a dell mouse on 200 ping servers. I seriously think some people just don't notice it.

                        Comment


                          #57
                          Guys,

                          You need to go back and read my reply on Page 2.

                          Why?

                          Because I have been playing this game as long as anyone in UT, since DAY 1. Do I know everything? Prolly Not. Know anyone who has been playing that long?

                          You can listen to all the bull**** you want in regards to playing this game, but if you truly want help, you can come to IRC (Internet Relay Chat) at:

                          irc.gameradius.net - Channel: #War-Mongers

                          and talk to me and other experienced UT players who know how to set this game up.

                          Please note, as I mentioned in my earlier reply. UT3 is an intensive PC game. It is not a flashback to UT2004, don't compare it. You must have decent equipment to play UT3.

                          Comment


                            #58
                            *Points to post 56*

                            Comment


                              #59
                              Originally posted by B0T0X View Post
                              *Points to post 56*
                              Your coment is ****, i can feel the lag in instant action and about the hardware, i have no lag in ut2004, so is not the mouse or the monitor.

                              Comment


                                #60
                                Yeah I notice lag after my shots.

                                Well maybe because every server I play on except 2 I get a 160+ ping. But when I hop down to those 2 servers where I get 90 ping it seems perfect to me, lol.

                                I've always played FPS games with lag, a lot of them over 130 ping too, I guess I've just gotten use to compensating and timing the lag so it doesn't really bother me too much anymore.

                                So when I play single player and low ping I don't really see that lag you are talking about. Perhaps my frame of reference of lag is skewered.

                                - Psilonex/MimiCakes

                                Comment

                                Working...
                                X