Announcement

Collapse
No announcement yet.

New Nvidia Drivers Fixes UT3 Crashes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    New Nvidia Drivers Fixes UT3 Crashes

    NVIIDIA has released new beta drivers that fix the crashing issues recently seen in UT3.

    XP 32-bit - http://www.nvidia.com/object/winxp_182.05_beta.html
    XP 64-bit - http://www.nvidia.com/object/winxp64_182.05_beta.html
    Vista 32-bit - http://www.nvidia.com/object/winvist...2.05_beta.html
    Vista 64-bit - http://www.nvidia.com/object/winvist...2.05_beta.html

    Now go play more UT3!

    #2
    I know I'm a ******, but are there going to be any Windows 7 beta fixes.

    Comment


      #3
      Install Vista drivers on Win7, it doesn't really matter.

      Comment


        #4
        Is there any way to save all the custom game settings from the nvidia control panel before upgrading the driver.?

        Comment


          #5
          For those of us using laptops, LaptopVideo2Go to the rescue: http://www.laptopvideo2go.com/forum/...?showforum=143

          Comment


            #6
            Originally posted by ThaMarine View Post
            I know I'm a ******, but are there going to be any Windows 7 beta fixes.
            It's becoming pretty obvious windoze 7 is just a fixed and modified version of vista, so the vista drivers should work fine for you.

            Comment


              #7
              For all those people that were blaming the game, LOL noobs told you it was driver issue, there was a bug in an Nvidia DLL. Portal crash is now fixed, now you can all go back to 100%, that is if you don't mind using beta drivers. WHQL will be not far off!

              Comment


                #8
                Beta works good here on UT3 and better 3DMark06 scores too. Looking forward to the WHQL version as long as they don't break whats working!

                Comment


                  #9
                  Originally posted by oldkawman1 View Post
                  It's becoming pretty obvious windoze 7 is just a fixed and modified version of vista, so the vista drivers should work fine for you.
                  Actually, I don't have Windows 7. I'm just asking because I'm buying a new PC soon and I'm going to install W7 on it.

                  Comment


                    #10
                    My ut3 still gets stuck (for 2-3 seconds) when using any driver higher than 178.24. It doesn't crash with portals but that 2-3 second delay in the middle of the games makes me crazy. I even set my screen percentage to %98 (which helps a bit) but none of the new drivers solved that problem (including 182.05 and 185.20 alpha)

                    Comment


                      #11
                      Are your sure its a driver issue? U have Vista? Latest Vista Driver? Temperatures et cetera...

                      read Ultrons sticky?

                      Comment


                        #12
                        I'm on XP and no other game (or with older drivers, UT3 itself) has this problem. I got 2.4 c2d, 2gb ram, and 512 mb 8800 gt. Game runs pretty smooth with full detail in 1280x1024 (even 1600x1200 on some maps) However, as i said, it gets stuck with 18x drivers.

                        The problem isn't specific to a map or any skin/model i use (i tried with at least 30 maps, stock or custom made). It's not about temperature also, when i roll back to older driver game runs without any problem, so i'm pretty sure it's the drivers...

                        Comment


                          #13
                          hmm I have just one last idea: Maybe deactivating the physix support may help you (NV-Side)?

                          Hopefully other guys will help you.

                          Comment


                            #14
                            Ah yes, deactivating physx from nvidia control panel worked. thank you

                            Comment


                              #15
                              Originally posted by Fliperaci View Post
                              hmm I have just one last idea: Maybe deactivating the physix support may help you (NV-Side)?

                              Hopefully other guys will help you.

                              Thanks for the post but I'm going to stick with the ones that work for me right now and wait till these go into full release. Then I'll give them a try.

                              BTW I had issues with my 8800GTS at 1680/1050 (my LCDs current native resolution) then I moved over to a new top of the line GTX-260 SC from EVGA and they were gone. I know that may not be an option for you but I would suggest doing as the above poster said and turning off UT3s hardware physics or make sure that you have that on if your GPU supports it.

                              IMHO the 8800GTS/GTX line of GPUs don't run Phys X as well as the newer GTX line of cards. (I can even run the newest versions of the drivers on Crysis Warhead, and Far Cry without any problems right now but UT3 is gone if I do that.)

                              So I'm going to wait till these hit full release and then install them onto my now fixed PC!

                              Comment

                              Working...
                              X