Announcement

Collapse
No announcement yet.

Mutator problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Mutator problem

    When I set the speed mutator that comes with the game it works, but when I exit the game and load it again, the mutator is no longer enabled. In UT200, mutators stayed there. Is this normal? Is there any way I can set up my game so that the mutators I want enabled are always activated and not having to select them every time I want to play (offline play I mean).

    #2
    Yeah they don't automatically stick anymore.

    You can go into your UTGame.ini file, locate the section for the map you want to play (say, "[DM-Defiance UTUIDataProvider_MapInfo]")

    Below that line you'll see a line that reads, like, "MapName=DM-Defiance"

    You can append a mutator specification to this line. Something like:

    "MapName=DM-Defiance?mutator=<classname of the mutator you want>"

    I don't know if there's a way to alter this to pass settings to the mutator. Maybe you'd need to set defaults where you want them in the mutator's .ini or something.

    Comment


      #3
      I've tried that but it doesn't work. The mutator I'm trying to set up is BattleMod. I'd also like to use the weapon respawn mutator.

      This is the ini of the mutator:

      [BattleMOD UTUIDataProvider_Mutator]
      ClassName=BattleMOD.BattleMOD
      FriendlyName=BattleMOD
      Description=BattleMOD allows you to confiure UT3 in many ways
      GroupNames=BattleMOD
      UIConfigScene=
      bStandaloneOnly=False
      bRemoveOn360=False
      bRemoveOnPC=False
      bRemoveOnPS3=False

      [BattleMOD.BattleMOD]
      CfgCheckConfig=DO NOT REMOVE THIS!
      CfgGameSpeedMultiplier=1.300000
      CfgWeaponSpeedMultiplier=1.200000
      CfgWeaponSwitchSpeedMultiplier=1.000000
      CfgHoverVehicleSpeedMultiplier=1.100000
      CfgWalkingSpeedMultiplier=1.200000
      CfgHealthMultiplier=1.500000
      CfgJumpMultiplier=1.750000
      CfgbMaxAmmo=True

      Comment


        #4
        The classname you'd want to use is battlemod.battlemod

        Are you trying to do this with a standard map or a custom map?

        Because I only ever did this before with the standard maps, and I've just noticed that indeed it ain't working for me with this one custom map. That's annoying. No idea why, sorry.

        It might be possible to do it by running ut3.exe with command line parameters. That would be troublesome. It's normally done when you're running a server. There's some web based command line generators out there to
        play with, if you want to try that.

        http://forums.epicgames.com/showthread.php?t=589276

        Comment


          #5
          Played around with this some more this morning, found out my problem was a couple things. First, the mutator I wanted to use was one I'd compiled as unpublished at first, then moved it over to published. But there was still a script file for it over in the unpublished section, and this was apparently causing some kind of confusion where the custom map was concerned. At least that's what the log file said. No idea why this wasn't an issue with standard maps.

          Anyway, erased the unpublished file and it still didn't work. But that, I found out today, was because I'd moved the custom map's ini file from the maps directory to the utgame/config directory (where all the other ini files are (because I had the crazy idea that maybe the mutator parameter would work if I put the file there)). Or anyway, I thought I moved it there. Actually, when the game loaded the map it looked in the map directory for the ini file, and when it didn't find it there, it thoughtfully created one there for it, and used that one. The one it created didn't have the mutator parameter in it of course, so the mutator didn't load.

          You're probably having some such snafu. Everthing has to be just so.

          Comment

          Working...
          X