Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Final definitive fix for mouse acceleration / smoothing / precision in UT3

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Final definitive fix for mouse acceleration / smoothing / precision in UT3

    I meant to make this post a lot earlier, but here it is now! You need to do extensive tweaking to your UTInput.ini in order to disable mouse acceleration in UT3. UTInput.ini is located in My Docs\My Games\Unreal Tournament 3\UTGame\Config

    Find the following lines and replace them with mine. Keep in mind I only use 800 DPI most of the time so your sensitivity may differ.

    Code:
    bEnableMouseSmoothing=False
    DoubleClickTime=0.250000
    MouseSensitivity=8.000000
    
    Bindings=(Name="MouseX",Command="Count bXAxis | Axis aMouseX",Control=False,Shift=False,Alt=False)
    Bindings=(Name="MouseY",Command="Count bYAxis | Axis aMouseY",Control=False,Shift=False,Alt=False)
    
    Bindings=(Name="LookUp",Command="Axis aLookUp Speed=+25.0 AbsoluteAxis=100",Control=False,Shift=False,Alt=False)
    Bindings=(Name="LookDown",Command="Axis aLookUp Speed=-25.0 AbsoluteAxis=100",Control=False,Shift=False,Alt=False)
    
    Bindings=(Name="GBA_TurnLeft",Command="Axis aBaseX Speed=-200.0 AbsoluteAxis=100",Control=False,Shift=False,Alt=False)
    Bindings=(Name="GBA_TurnRight",Command="Axis aBaseX  Speed=+200.0 AbsoluteAxis=100",Control=False,Shift=False,Alt=False)
    You'll also want to disable mouse acceleration in windows -- control panel -> mouse -> pointer options. Make sure the speed slider is set to the 6th notch, and enhance pointer precision is unticked. Once that's done, use the CPL mousefix to enhance the built-in Windows accel curve for precision -- http://www.gotfrag.com/portal/files/82/ Then, reboot & start playing!

    You'll notice a tremendous improvement in how steady & reliable the aim is in UT3. The ratio of distance traveled on the mousepad to distance traveled on the screen is no longer variable, and because there aren't any fancy calculations on smoothing or an accel curve it can cure input lag. If you've played FPS in the past w/ accel on it can take a bit of getting used to, but trust me it's worth it =)

    I know this has been posted earlier, but the code was buried in the thread and you couldn't just copy it out b/c it didn't use code tags and got all garbled. Hope you guys get some use out of it!

  • #2
    And ofcourse dont forget to disable mouse acceleration in ut3 aswell (windows acceleration doesn't affect ingame acceleration)

    My Documents/My Games/Unreal Tournament 3/UTGame/Config/UTInput.ini

    [UTGame.UTConsoleP_layer_Input]
    bViewAccelerationEnabled=FALSE

    Comment


    • #3
      i play with ingame setting of 700 and my mx518 set to 2000 most of the time with the option of using the onboard buttons to reduce the dpi for accuracy. i assume i would need to play with the sensitivity setting in the ini and the speed values?

      Comment


      • #4
        Yeah you can play with the speed values if you need finer tuning on the sensitivity.

        Comment


        • #5
          good thread horizon, but I doubt anyone would want to modify their windows settings just for UT3.

          link to 1st thread:

          http://forums.epicgames.com/showthre...e+acceleration

          Comment


          • #6
            uh... these are the default INI binding settings...

            Comment


            • #7
              *rofl*

              Surrounded by too many trees to see the forest

              Comment


              • #8
                so is this thread official fail or not?

                Comment


                • #9
                  dont know its debatable though.

                  becouse i dont understand the problem in the 1st place!

                  i never noticed any diverence between the distance traveled on screen vs my mouse on the mouse pad

                  Comment


                  • #10
                    Originally posted by Esteem View Post
                    uh... these are the default INI binding settings...
                    No they're not...

                    Unless somehow mine somehow got changed already without my knowledge?

                    Comment


                    • #11
                      It's identical to what's already in my ini, except for all the Control=False,Shift=False,Alt=False bits, but those are all false by default, so explicitly setting them to false will do nothing.

                      Comment


                      • #12
                        so whats in your INI file?

                        i'm gonna try this tomorrow. i realy cant belive its makes that big a diverence if it can only be edited wth an INI file.

                        but i have to say, some times it does feel like there is an delay between aiming shooting and hitting. it just does'nt match

                        Comment


                        • #13
                          Originally posted by Taboen View Post
                          And ofcourse dont forget to disable mouse acceleration in ut3 aswell (windows acceleration doesn't affect ingame acceleration)

                          My Documents/My Games/Unreal Tournament 3/UTGame/Config/UTInput.ini

                          [UTGame.UTConsoleP_layer_Input]
                          bViewAccelerationEnabled=FALSE
                          is this all i have to do to turn off mouse acaleration or do i have to copy the entire fist post?

                          Comment


                          • #14
                            Originally posted by Esteem View Post
                            uh... these are the default INI binding settings...
                            They were the default settings for me as well. The link DeathmooN provided shows different values.

                            Comment


                            • #15
                              Originally posted by HorizonX View Post
                              I meant to make this post a lot earlier, but here it is now! You need to do extensive tweaking to your UTInput.ini in order to disable mouse acceleration in UT3. UTInput.ini is located in My Docs\My Games\Unreal Tournament 3\UTGame\Config

                              Find the following lines and replace them with mine. Keep in mind I only use 800 DPI most of the time so your sensitivity may differ.

                              Code:
                              bEnableMouseSmoothing=False
                              DoubleClickTime=0.250000
                              MouseSensitivity=8.000000
                              
                              Bindings=(Name="MouseX",Command="Count bXAxis | Axis aMouseX",Control=False,Shift=False,Alt=False)
                              Bindings=(Name="MouseY",Command="Count bYAxis | Axis aMouseY",Control=False,Shift=False,Alt=False)
                              
                              Bindings=(Name="LookUp",Command="Axis aLookUp Speed=+25.0 AbsoluteAxis=100",Control=False,Shift=False,Alt=False)
                              Bindings=(Name="LookDown",Command="Axis aLookUp Speed=-25.0 AbsoluteAxis=100",Control=False,Shift=False,Alt=False)
                              
                              Bindings=(Name="GBA_TurnLeft",Command="Axis aBaseX Speed=-200.0 AbsoluteAxis=100",Control=False,Shift=False,Alt=False)
                              Bindings=(Name="GBA_TurnRight",Command="Axis aBaseX  Speed=+200.0 AbsoluteAxis=100",Control=False,Shift=False,Alt=False)
                              You'll also want to disable mouse acceleration in windows -- control panel -> mouse -> pointer options. Make sure the speed slider is set to the 6th notch, and enhance pointer precision is unticked. Once that's done, use the CPL mousefix to enhance the built-in Windows accel curve for precision -- http://www.gotfrag.com/portal/files/82/ Then, reboot & start playing!

                              You'll notice a tremendous improvement in how steady & reliable the aim is in UT3. The ratio of distance traveled on the mousepad to distance traveled on the screen is no longer variable, and because there aren't any fancy calculations on smoothing or an accel curve it can cure input lag. If you've played FPS in the past w/ accel on it can take a bit of getting used to, but trust me it's worth it =)

                              I know this has been posted earlier, but the code was buried in the thread and you couldn't just copy it out b/c it didn't use code tags and got all garbled. Hope you guys get some use out of it!
                              Why do you write: Make sure that the speed slider is on the 6th notch. ?

                              I want to have mouse speed in wîndows like I am used to. Do I really have to set it to 6th notch whenever I start ut3?? Sounds strange.... please reply I need to add this fix

                              Comment

                              Working...
                              X