Announcement

Collapse
No announcement yet.

ut3 editor crashes on startup

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    ut3 editor crashes on startup

    the editor worked fine when i started to build map .... spent countless hours that day going in and out making more rooms and texturing. things were great.then i went to bed woke up to go at it agn and thing wont load. says ut3.exe has stopped working????? i reinstalled but same prob. i can play the game just not use editor help.

    #2
    I've never found a real solution to th is ive search the forums try pretty much everything that was suggested but no luck. It worked after I reformmated.

    Comment


      #3
      Have you tried deleting the preference file for unrealed?

      Comment


        #4
        I'm having the same problem at the moment, does the format solve the problem indefinitely? I really don't have the time to do a format, my map is for a uni project so any other solutions you might have would be much appreciated!

        Comment


          #5
          More than likely you modified a stock package that ships with UT3 and it doesn't like that. The editor will crash every time if you have done this. Usually it will save this modified version of the original package somewhere outside of the Enviroments folder.

          I wish i could give you more direction than this, but from my expierience with this, it saves anywhere it wants to. Look in" MyDocuments/Mygames/Unrealtournament3/ and also C:/Programfiles/Unrealtournament3/ " and all the folders there in to find the modified package.

          If you find the package and your sure it's a copy and modified file just delete it and you will be fine.

          Comment


            #6
            Mojonick, you are an absolute legend my friend, thank you!!! :-)

            Comment


              #7
              If you have a corrupted package and cook the map, and it crashes ut3 sometimes the editor wont work untill you delete the published files ive experienced that one personally this week after UED crashed while cooking my map which corrupted the package (well i think it did, something did) you could also try the level editing thread in user maps and mods. Good luck [EDIT] Mojonick I just use "save as" instead of "save" unless im 100% certain of where its going, then your in control. My problem is I need a way to quickly reinstall backed up packages without redoing all surfaces/meshes/emitters again as you cant modify packages once theyve been cooked. Im probably not going to release another beta for my map for this reason. Just windows and emitters is 52 things to resurface before i get to floor/walls etc. :/

              Comment


                #8
                OK, I'm having the same problem. I've installed UT3, when I try to play I get the UT3.exe has stopped working message before the game has even laoded. I'm using Windows Vista, so could anyone tell a simpilton like me what I need to do, without totally confusing me :P

                Thanks

                Comment


                  #9
                  Can anyone help this noob in dispare? ^^

                  Comment


                    #10
                    You probably saved a modified version of one of the retail packages. Look in your Unpublished\CookedPC folder. Most likely the offending package is in Unpublished\CookedPC\Environments folder, but it could be anywhere in unpublished\cookedpc. Look for .upk files with recent modified dates.

                    This seems to be a common issue people have.

                    Comment


                      #11
                      Originally posted by woooo View Post
                      I've never found a real solution to th is ive search the forums try pretty much everything that was suggested but no luck. It worked after I reformmated.
                      Eeeeeeeeeeeek reformat, I had a similar problem recently, where i tried a "full recook" of a map in unreal frontend. This wiped all my published custom maps and made my UT3 game crash on startup every time. Uninstall/ Reinstall didnt work, untill finally, I backed up my published maps (which id just rebuilt lol) and unpublished. Wiped everything in My Games\UT3 and then uninstalled and reinstalled to a completely new directory. It worked!, even after i put published/unpublished back in. Also means you have to reinstall mutators but against a format, ill take mutator re-install anyday! Hope this helps. PS folks be careful when doing a PC full recook in unreal frontend lol

                      Comment


                        #12
                        So, is there any way to modify stock packages at all? i need to remove the box collision on a piece of cave, but if i do i encounter this problem! there MUST be a way to modify the assets that come with the engine! any one have any ideas?

                        Comment


                          #13
                          Originally posted by CaptainSnarf View Post
                          You probably saved a modified version of one of the retail packages. Look in your Unpublished\CookedPC folder. Most likely the offending package is in Unpublished\CookedPC\Environments folder, but it could be anywhere in unpublished\cookedpc. Look for .upk files with recent modified dates.

                          This seems to be a common issue people have.
                          Thanks for this! This is exactly what happened to me. I even reinstalled the whole thing, but it didn't help. Only deleting a certain upk did the magic trick of getting it to work again.

                          Comment


                            #14
                            hmm, i had this the other day, i ended up reistalling and that didnt fix it, in the end i deleted the entire config folder from mydocuments/mygames/unrealtournament3/utgame and that fixed it?

                            Comment


                              #15
                              Originally posted by CaptainSnarf View Post
                              You probably saved a modified version of one of the retail packages. Look in your Unpublished\CookedPC folder. Most likely the offending package is in Unpublished\CookedPC\Environments folder, but it could be anywhere in unpublished\cookedpc. Look for .upk files with recent modified dates.

                              This seems to be a common issue people have.
                              This is the best bit of advice I have seen on here (for me anyways)

                              the Ed has stopped working for me twice now and each time this bit of advice has sorted it out.


                              Thanks alot CaptainSnarf.

                              Comment

                              Working...
                              X