Announcement

Collapse
No announcement yet.

Enabling anti-aliasing in Unreal Tournament 3 via nHancer,

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Here, try this, one is with coverage-sampling, one is without. As you can see, it does improve image quality, but as I said earlier, it isn't as nice as BF2, and it's apparently just blurring the aliasing, but not "badly" like some other games.
    http://i271.photobucket.com/albums/j...UT3AAtest2.png
    http://i271.photobucket.com/albums/j...T3AAtest2a.png

    Leave a comment:


  • replied
    Originally posted by btcomm View Post
    Perhaps you could fix the links? You are linking to thumbnails right now.
    Ooops, my Fault. Fixed.

    Leave a comment:


  • replied
    Originally posted by AnubanUT2 View Post
    No you cannot force AA ... I have read enough technical articles on the web so I know what I am talking about ... believe what you want to but maybe you should read more and learn to listen to people who have a much better grasp on technology than you (and no I am not talking about me ... I am talking the numerous number of technical folks who write articles that cover this online).

    Why not read what I pointed to instead of taking offense so quickly and telling people things that are not true ...
    You're a ******.

    With an NVIDIA graphics card you can set AA right in the control panel. The performance hit is a little worse than it would be if directly supported, but I can still run 8x CSAA (default 8x on any 8-series card) with decent performance. It looks absolutely beautiful.

    Leave a comment:


  • replied
    Originally posted by Scheibenwischer View Post
    Ok,
    Here are 3 Pics, taken on the Tower on Torlan, once without AA, once with 4x Multisampling, and one with 2x2 FSAA, i marked a few Spots.

    2x2 FSAA (that means the Picure is renderet in twice their real height and width, thats the reason why the Shaders dont ruin that ones):


    4x Multisampling:


    And for Compare, nothing:
    Special notice the white Trail of the Orb, thats the Real problem. On the normal Geometric edges, Multisampling works fine, but that is an Shader-effect.
    Perhaps you could fix the links? You are linking to thumbnails right now.

    Leave a comment:


  • replied
    Ok,
    Here are 3 Pics, taken on the Tower on Torlan, once without AA, once with 4x Multisampling, and one with 2x2 FSAA, i marked a few Spots.

    2x2 FSAA (that means the Picure is renderet in twice their real height and width, thats the reason why the Shaders dont ruin that ones):
    http://img156.imageshack.us/img156/8...amplingwp1.jpg

    4x Multisampling:
    http://img246.imageshack.us/img246/3...amplingfd8.jpg

    And for Compare, nothing:
    Special notice the white Trail of the Orb, thats the Real problem. On the normal Geometric edges, Multisampling works fine, but that is an Shader-effect.
    http://img214.imageshack.us/img214/8200/nothingco1.jpg

    //edit: fixed the Links. Stupid Imageshack.

    Leave a comment:


  • replied
    Also instead of posting how it works why not show people that it does truly work by posting pics where you don't have to point out where it is working. If 4xFSAA is working correctly then the improvements will be immediately obvious. Haven't any of you ever wondered why there have never been any pictures shown by ANY technical site of DX9 UT3 or Gears running AA when that is usually standard for any major graphically feature laden game? But please show us all that FSAA works correctly when you force it. Prove even the person who wrote the tweak guide wrong. Let's clear the issue up once and for all with visible proof of properly working AA with UT3 using either XP or Vista ... according to the tweakguide and other info on DX9 I have read it isn't possible due to the way UE3 handles shaders basically and there is no DX10 code in UT3 atm so I am really dying to see someone do the impossible.

    Leave a comment:


  • replied
    Epic has done a lot of Statements in the Past, and not all of them are true...
    SSAA works pretty well under DX9, but as i said, it eats up Frames like nothing.

    Leave a comment:


  • replied
    Originally posted by Spoudazo View Post
    No, actually you can force anti-aliasing in Gears of War without DX10, *and* it runs better than DX10/anti-aliasing. It's not as good as anti-aliasing in BF2, but it still works quite well.

    Next time don't come in here with condescending comments if you don't know what you're talking about.
    No you cannot force AA ... I have read enough technical articles on the web so I know what I am talking about ... believe what you want to but maybe you should read more and learn to listen to people who have a much better grasp on technology than you (and no I am not talking about me ... I am talking the numerous number of technical folks who write articles that cover this online).

    Why not read what I pointed to instead of taking offense so quickly and telling people things that are not true ...

    Leave a comment:


  • replied
    "MaxMultisamples=1

    This setting appears to control the use of Multisampling, which is a common form of Anti-Aliasing, used to reduce jaggedness. However at the moment altering this setting has no impact (either in DX9 or DX10 mode) since UT3 does not properly support AA - see Anti-Aliasing under the In-Game Settings section for more details of how you can force AA in UT3. In the future, Epic has stated that an AA option is possible for DX10 mode in Vista."

    UT3 Tweakguide

    Leave a comment:


  • replied
    Multi-Sampling only handles the Polygon-edges, that saves a hughe amount of Resources, but it does not work on that blurry effects.

    Leave a comment:


  • replied
    No, actually you can force anti-aliasing in Gears of War without DX10, *and* it runs better than DX10/anti-aliasing. It's not as good as anti-aliasing in BF2, but it still works quite well.

    Next time don't come in here with condescending comments if you don't know what you're talking about.

    Leave a comment:


  • replied
    Originally posted by Spoudazo View Post
    Try multi-sampling, or coverage sampling.
    Multi sampling doesn't work *sigh* ... please read my post above if you want the actual truth of the matter.

    Leave a comment:


  • replied
    Wow .. people really refuse to learn the truth about AA and this game .. it is getting ridiculous.

    Let me attempt to assist you:

    http://gearsforums.epicgames.com/sho...d.php?t=595035

    And this:

    "Antialiasing Support: UT3 uses a technique called Deferred Lighting, which doesn't allow for the use of normal Anti-Aliasing, at least in DX9 mode. Epic has stated that when running in DX10 mode in Vista, the game will allow the use of AA in the future. For the moment there are two ways to force Anti-Aliasing in the game:

    # If you run a GeForce 8 series card you can force AA through the Nvidia Forceware Control Panel using the UT3 game profile in the latest Forceware, or rename the UT3.exe file found under the \Program Files\Unreal Tournament 3\Binaries\ directory to BioShock.exe, and use the BioShock profile.
    # You can apply a brute force method called Supersampling - which works on pretty much any game - using a utility such as nHancer to set 'AA Compatibility mode 45' for the game profile. This is not recommended, as it has a major performance impact and can also cause visual glitches.

    A better alternative to either of the above is simply to adjust your Post Processing setting to something like Vivid, which helps cover up aliasing extremely well at a minimal cost in performance."

    Hopefully people will understand that any AA they get now is marginal at best and doesn't look nearly as good as it would if the AA support were native like in Gears of War. Just take a look at the two titles (after you force your "AA" of course in UT3 .... forcing DOES NOT WORK AT ALL in Gears so you have to have Vista to set the 4xFSAA ... which is how it will be when the DX10 code for UT3 is released ) and the difference is huge.

    Leave a comment:


  • replied
    System:
    AMD Anthlon 64 3500+ 2.2GHz
    2gb DDR2 Ram
    Geforce 8600 GT 256mb DDR3
    Windows XP SP2


    And Latest Nvidia Drivers.

    Leave a comment:


  • replied
    Originally posted by Scheibenwischer View Post
    Only SSAA works proper with that amount of Pixel-shaders and stuff, but it eats up Frames like nothing.
    Yesterday i tried 4x4 SSAA at All to High, with 1280x1024, and my GF8800GTS 640 MB will be drop down to only 8 or 10 FPS.
    Try multi-sampling, or coverage sampling.

    Leave a comment:

Working...
X