Announcement

Collapse
No announcement yet.

Somebody please help me with mouse sensitivity...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Somebody please help me with mouse sensitivity...

    Right so I followed this helpful guide on how to get UT3 sensitivity back to "normal" (like in UT2004):
    Here are the settings that need to be changed;

    in UTInput.ini:

    [Engine.PlayerInput]
    LookRightScale=0.000000
    LookUpScale=0.000000
    bEnableMouseSmoothing=False
    ...
    Bindings=(Name="MouseX",Command="Count bXAxis | Axis aMouseX Speed=2.0",Control=False,Shift=False,Alt=False)
    Bindings=(Name="MouseY",Command="Count bYAxis | Axis aMouseY Speed=2.0",Control=False,Shift=False,Alt=False)
    ...
    Bindings=(Name="LookUp",Command="Axis aLookUp Speed=+25.0 AbsoluteAxis=0",Control=False,Shift=False,Alt=Fals e)
    Bindings=(Name="LookDown",Command="Axis aLookUp Speed=-25.0 AbsoluteAxis=0",Control=False,Shift=False,Alt=Fals e)
    ...
    Bindings=(Name="GBA_TurnLeft",Command="Axis aBaseX Speed=-40.0 AbsoluteAxis=0",Control=False,Shift=False,Alt=Fals e)
    Bindings=(Name="GBA_TurnRight",Command="Axis aBaseX Speed=+40.0 AbsoluteAxis=0",Control=False,Shift=False,Alt=Fals e)



    [UTGame.UTPlayerInput] <- same thing in this section as playerinput.
    LookRightScale=0.000000
    LookUpScale=0.000000
    ...
    Bindings=(Name="MouseX",Command="Count bXAxis | Axis aMouseX Speed=2.0",Control=False,Shift=False,Alt=False)
    Bindings=(Name="MouseY",Command="Count bYAxis | Axis aMouseY Speed=2.0",Control=False,Shift=False,Alt=False)
    ...
    Bindings=(Name="LookUp",Command="Axis aLookUp Speed=+25.0 AbsoluteAxis=0",Control=False,Shift=False,Alt=Fals e)
    Bindings=(Name="LookDown",Command="Axis aLookUp Speed=-25.0 AbsoluteAxis=0",Control=False,Shift=False,Alt=Fals e)
    ...
    Bindings=(Name="GBA_TurnLeft",Command="Axis aBaseX Speed=-40.0 AbsoluteAxis=0",Control=False,Shift=False,Alt=Fals e)
    Bindings=(Name="GBA_TurnRight",Command="Axis aBaseX Speed=+40.0 AbsoluteAxis=0",Control=False,Shift=False,Alt=Fals e)





    Adjust your MouseSensitivity according to your preference and what feels right in game with this console command;

    set Engine.PlayerInput MouseSensitivity <x>


    where <x> = a number
    And it works, well sort of... The actual ini changes that I made seem to stick. But setting your sensitivity in the final step with the "set" command is giving me lots of problems. It works if you do it offline, but it does not work online. And if you do it offline and then try to go online it says that console commands have been used and I must restart the game before I can play online. When I do restart the game, the sensitivity setting I made is lost, and I am not able to use it online anyway.

    What I need to know, is how the heck can I get it to work online and how can I make it stick every time the game is closed and opened so I don't have to enter it every time?

    Is there an ini setting I need to change? I really can't find one. In the UTInput.ini there is a setting called "MouseSensitivity=", but apparently they only put it there to look pretty: it dosen't actually do anything.

    The sensitivity I like is 2.325, can anyone help me get it to stick and work online? Preferably I want to know how to set it in the ini file.

    #2
    It's so bad that theses settings can't be set in the menus...
    A multiplayer fps game where it's impossible to get a decent mouse sensitivity without editing your ini's.
    Unpolished, unfinished and plain bad.

    I'm sorry I can't help you. Had the same problems myself. After messing with the ini's and not getting it work I gave up.. I'll wait for the full version and see if they fix this issue + a lot of others before I decide if I'm gonna buy this game.

    Comment


      #3
      @ martinblank
      I've been having the same problem but I can get the ini file to stay set at mouse speed 1. To get the lower speed I adjust this line from above even lower.
      Bindings=(Name="MouseX",Command="Count bXAxis | Axis aMouseX Speed=2.0")
      Bindings=(Name="MouseY",Command="Count bYAxis | Axis aMouseY Speed=2.0")
      Decimals seem to work fine, mine are set like this:
      Bindings=(Name="MouseX",Command="Count bXAxis | Axis aMouseX Speed=0.5")
      Bindings=(Name="MouseY",Command="Count bYAxis | Axis aMouseY Speed=0.5")
      It's still kind an awkward way to set the mouse speed, but it has worked ok for me.

      Comment


        #4
        but the default speed of 2.0 that it has is extremely fast, way faster than when I do the console command for 2.325, so it must be using a different scale, and I don't know what 2.325 would translate to.

        I found a temporary solution. Instead of the command "set Engine.PlayerInput MouseSensitivity 2.325", I use "setsensitivity 2.325". This seems to do the same thing and it works online. Only downside is that now instead of having to do it every time you start the game, you have to do it at the beginning of each match. I will make a key bound to the command to help with this though.

        Comment

        Working...
        X