Announcement

Collapse
No announcement yet.

Do you plan on playing UT3 in DX9, DX10, or OpenGL?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Do you plan on playing UT3 in DX9, DX10, or OpenGL?

    Just curious whatever API you're hoping (or already have the hardware for) to be playing on regarding graphics API?

    I'm planning on playing in DirectX 10, but it will be interesting to see how OpenGL goes.

    #2
    Were still don't know if UT3 supports OpenGL under Windows platform, but I go with DX9 & XP.

    Comment


      #3
      A poll perhaps. DX9

      Comment


        #4
        Originally posted by bazzwano View Post
        A poll perhaps. DX9
        Yeah, I was working on the poll while you two were posting.

        Comment


          #5
          SDL/OpenGL

          Comment


            #6
            i don't want to switch to vista until microsoft releases a service pack so me playing on dx10 depends on that.

            i'll be contempt with xp and dx9 till then.

            Comment


              #7
              Too early

              I've no idea whether it will be DX9 or OpenGL 3.0. If OpenGL 3 is supported, looks better and provides better performance (fps) then I'd go with it over DX9. DX10 is not my menu hardware, nor software wise. (for as long as I can)

              Intentsly
              (UT99~ [--]Torturia)

              Comment


                #8
                The thing is, for OpenGL 3.0, as far as we know (check the official OpenGL site), the hardware required for OpenGL 3.0 is basically going to be hardware for DirectX 10 as well, so no 7950gx2 or x1950xt, etc. is going to run OpenGL, but rather, hardware released in Q4 '06 or later.

                Comment


                  #9
                  Yawn Dx11 or open GL4.0. LL

                  Comment


                    #10
                    Originally posted by Spoudazo View Post
                    The thing is, for OpenGL 3.0, as far as we know (check the official OpenGL site), the hardware required for OpenGL 3.0 is basically going to be hardware for DirectX 10 as well, so no 7950gx2 or x1950xt, etc. is going to run OpenGL, but rather, hardware released in Q4 '06 or later.
                    A note by Open GL 3.0 stating that it would require a DX10 compatible card would be nice....*in your poll listing.

                    Comment


                      #11
                      I'm referring to this,
                      Longs Peak and Mount Evans represent major API upgrade. What is going on with OpenGL right now is very exciting. This year will see two new versions of this venerable API. The first version due in July 2007 is Longs Peak (OpenGL 2.x). This is a major clean-up of the code after almost a decade and a half. Approximately three months after that we will see the release of Mount Evans (OpenGL 3.0) which will run specifically on hardware born after November 8th, 2006. We are talking about DirectX 10-class hardware, bringing all the features of unified 3D architecture to the world of OpenGL. Mount Evans is compatible with Longs Peak, but you will require OpenGL 3.0 class hardware to run everything.

                      OpenGL 3.0 will offer features such as instanced rendering, stream out of vertex data to a buffer, texture buffer objects, numerous new texture formats and so on. Most importantly the Khronos Group is linking OpenGL and OpenGL ES, a mobile 3D graphics API via COLLADA and glFX, so what is supported in OpenGL 3.0 will see the light of the day in ES version as well.
                      http://www.opengl.org/news/permalink...ive_this_year/

                      Comment


                        #12
                        DX9 most likely, but I'm always open to OpenGL.

                        Comment


                          #13
                          Originally posted by koopa View Post
                          i don't want to switch to vista until microsoft releases a service pack so me playing on dx10 depends on that.

                          i'll be contempt with xp and dx9 till then.
                          Sorry to dissapoint but vista is not going to do a service pack. They will release updates in small incriments only.

                          And also the problem with people sticking with XP is that they can't use DX10 in it if they buy an 8800 GTS / GTX.

                          Comment


                            #14
                            Originally posted by Vendetta View Post
                            sticking with XP is that they can't use DX10 in it if they buy an 8800 GTS / GTX.
                            I can live with that. I'd rather keep XP as long as I can...

                            In any case I plan to play in my birthday suit...

                            I'll take screenshots...

                            Comment


                              #15
                              Originally posted by Vendetta View Post
                              Sorry to dissapoint but vista is not going to do a service pack. They will release updates in small incriments only.

                              And also the problem with people sticking with XP is that they can't use DX10 in it if they buy an 8800 GTS / GTX.

                              i don't know, i don't like that idea with vista. i'll decide what i will do when the time comes.


                              i do have a 8800gts so can i use opengl 3.0 with xp? anyone?

                              Comment

                              Working...
                              X