Announcement

Collapse
No announcement yet.

Strange Error Showing Up in UT3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Strange Error Showing Up in UT3

    I'm migrating to Windows 7 64 and all seemingly was fine, until I started copying maps that I'd downloaded previously. Now I get this error:

    "failed to find default engine .ini file to retrieve My Documents subdirectory to use."

    This only comes up when I use the Unpublished launch to test my personal maps. I get the splash screen, then the black screen, but the legal mumbo jumbo screen never comes up. The regular UT3 doesn't do anything at all, not even try to launch. Not sure where to start looking for this problem. Of course, trying to avoid re-installing as it took FOREVER. Thanks.

    P.S. Curiously, I can still launch, use and play my levels in the editor window no problems.

    P.P.S. Rebooted W7 and now I can play UT3, but the unpublished deal still doesn't work. This is my path in the shortcut: << "C:\Program Files (x86)\Unreal Tournament 3\Binaries\UT3.exe" unpublished >>
    I'm assuming this hasn't changed in Windows 7. As I keep trying to launch the unpublished deal, I found that if I hit ESC, during the black screen it makes the legal info come up then it crashes.

    #2
    Originally posted by BigAl444 View Post
    I'm migrating to Windows 7 64 and all seemingly was fine, until I started copying maps that I'd downloaded previously. Now I get this error:

    "failed to find default engine .ini file to retrieve My Documents subdirectory to use."
    That's an uncommon error message. Not sure how you modified the structure, but basically the engine folder structure is missing the BaseEngine.ini, DefaultEngine.ini or the UTEngine.ini is corrupt.

    Originally posted by BigAl444 View Post
    P.P.S. Rebooted W7 and now I can play UT3, but the unpublished deal still doesn't work. This is my path in the shortcut: << "C:\Program Files (x86)\Unreal Tournament 3\Binaries\UT3.exe" unpublished >>
    I'm assuming this hasn't changed in Windows 7. As I keep trying to launch the unpublished deal, I found that if I hit ESC, during the black screen it makes the legal info come up then it crashes.
    The command line for starting the game using unpublished content would be:
    Code:
    "C:\Program Files (x86)\Unreal Tournament 3\Binaries\UT3.exe" -useunpublished



    Just a hint:
    Never touch the installation folder except for official patches or custom content which directly says so (for instance UT3Dom). If you install patches into the installation folder, you won't need to reinstall the game by installing the game from the Disc/Installer. Basically deleting the profile folder (%userprofile%\Documents\My Games\Unreal Tournament 3) would reset all settings, remove all custom content etc. UT3 doesn't store anything important into the registry (only for uninstalling purpose).

    Comment


      #3
      Hey SN4k3:

      Sorry, forgot to reply to your message. I had previously tried that -useunpublished and it didn't work. For whatever reason, it works now. In fact, everything works perfectly now. I didn't do anything to any of the files you mentioned. Whatever, as long as it's working who cares, right?

      Comment


        #4
        If "-useunpublished" is not working, you might have a bad folder structure. Maps should be installed into this folder (or any subfolder there):
        Code:
        %userprofile%\Documents\My Games\Unreal Tournament 3\UTGame\Unpublished\CookedPC\CustomMaps

        Comment

        Working...
        X