Announcement

Collapse
No announcement yet.

Triggers, Sound Cues and No Attenuation.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Triggers, Sound Cues and No Attenuation.

    I've seen these kind of questions asked a few times around this forum, unfortunately, they almost always end it "Oh I figured it out! Thanks anyway!" without bothering to post the solution. So here goes...

    I have a trigger setup, when touched/walked through it changes the music on the radio. It works all fine. You walk through the trigger, the music changes, and triggers back to the original sample when that's finished. However, there is absolutely no attenuation. I've added the attenuation node in the SoundCue editor, but to no avail, the music still plays full throughout the entire level. I tried to ad the node in Kismet. No avail. Any ideas? Thanks fellas.

    #2
    Off the top of my head: Use an AmbientSoundToggleable actor in the level with all the attenuation done through that actor's properties. Then set it to disabled. Enable / Disable it through Kismet using Toggle.

    [edit] Also make sure bAttenuate is enabled on the AmbientSoundToggleable.

    Comment


      #3
      For the record: This worked. I tried this before and it didn't work at all and I received a kismet error there was no object or something. I'm not entirely sure what was done differently from that time to this. I did connect as an Object Variable in Kismet (Graphically, through the target path), as well as in the actual kismet toggle properties (Sequence Action -> Target -> SoundNode'MySound'). Although to test what had happened, I erased the toggle properties sequence action target, and tried it with just the Object Variable target, it worked, tried it with the toggle properties sequence action targeting the Node, and no Object Variable, and it failed. I hope this can help someone out, and thanks TarnationSauce2!

      Comment


        #4
        Glad it worked for you.

        Comment

        Working...
        X