Announcement

Collapse
No announcement yet.

Stairs problem :(

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Stairs problem :(

    Hi everyone!

    I'm new to UE3, but i have some experience with map editing. I've encountered a problem lately: I want to make some straight stairs leading to a door. I use "StaticMesh'LT_Stairs.SM.Mesh.LT_Stairs_SM_Stairs0 1_OneStep' " converted into movers for each step. I made all the kishmet stuff, ect. it works just fine. I use drag grid 16. The problem is, that I can walk up the stairs on both of it's sides , but not in the middle. If I want to go up the stairs in the middle, i just bump into them. I don't want to place them 8 units from each other (vertically), 'cause it looks lame with that mesh. Anyone knows what the hell is going on?

    Oh, and the mesh is completely flat, not bent, before anyone asks
    Please help
    Greetings from Hungary

    #2
    How about using grid size 4 to place them with 12 units difference?

    And why are you using movers for the stairs?

    Comment


      #3
      Originally posted by Wormbo View Post
      How about using grid size 4 to place them with 12 units difference?

      And why are you using movers for the stairs?
      1; I use size 16 because the shape of the mesh requires it.

      2;This is why:
      http://img237.imagevenue.com/img.php..._122_572lo.jpg

      Comment


        #4
        I would find the mesh that has multiple steps to it, place it in the map and take a look at the spacing. Match your stairs to it as the collision box probably requires it to be a certain height from each other.

        Take a look at the mesh in the static mesh editor and view it's collision to see if there is something about it that's causing the blocking issue.

        Comment


          #5
          I think it's the collision. It is slightly leaning backwards in the middle (forms a slope). In UT3 characters can climb on a slopes of certain height and pitch. Obviously, collision of the stairs is too complex to consider as climbable . If stairs are static, I suggest setting collision type to COLLIDE_BlockWeapons in static mesh Collision properties for each step, then wrap all the stairs in a single blockind volume.

          Edit: oh... they're moving. Well, the easiest way would be to replace them with meshes that have strict rectangular parallelepiped collision... By doing this: read http://stevelois.wordpress.com/ut-ga...licate-assets/. After Step 8:
          1. Make sure processed mesh fits the grid as much as possible.
          2. Use builder brush to sketch out new collision: 90 degrees walls, no slopes. Make sure Brush correctly wraps the mesh.
          3. Right click on a step mesh, search 'Save Brush As Collision', click it, accept if asked to replace default collision model.
          4. Check how it looks in collision preview and save your map.
          5. Replace the ones you were using with new ones and test out!

          Comment


            #6
            If i remember correctly, the "step" of that mesh is not a straight plank. If so, the collision of each consecutive step just may not be reached in the middle, and you can supplement by attaching invisible straight plank kactors in order to provide the pawn a place to step. The visual will not be perfect (floaty feets.), but this is not usually noticed in fast fps game-play (look at stairs blocking in stock DM maps.)
            Remember also that the mesh can be scaled, instead.


            edit: Doh! I should have refreshed, heh.

            Comment


              #7
              Thx guys! I've tried Hayrack's solution, and it works just fine! Hayrack, You're the man!Thx goes to the other competitors too!

              Comment

              Working...
              X