Announcement

Collapse
No announcement yet.

Releasing a map, setting player number

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Releasing a map, setting player number

    Hey guys I'm just about finished with my first map ever for UT3. it's a DM map. I was wondering how to set the max number of players before releasing it. My map is a bit small and I don't think it's suitable for 16 players. Thanks!

    #2
    Check the LevelProperties. There you should be able to set the min and max number of players if they didn't change it after UE2.5 (you could always set it in the LevelProperties before).

    Comment


      #3
      Originally posted by Sly. View Post
      Check the LevelProperties. There you should be able to set the min and max number of players if they didn't change it after UE2.5 (you could always set it in the LevelProperties before).
      You can do this, but I don't think it's used by the game (thought I do it anyways).

      You can add this line to your .ini files, which is used by the game.

      NumPlayers=6 to 14 players Author: Odedge

      Comment


        #4
        like Odedge said... filling out the world property info does nothing, the game only uses the info given in the ini.

        you should take a look at this guide if you haven't already:
        Preparing your map for publishing and distribution

        Comment


          #5
          Thanks I'm following that guide now.

          Comment


            #6
            When I tried to save my package and publish the map, I got an error message saying "graph is linked to an external object".
            Anyone know whats causing that or how to fix it?

            Comment


              #7
              You're using data that aren't stored in your map.
              You have to save all your map in it, and never use an external package/map.
              In the Generic Browser, you have the name of the map, for example : DM-deathcube.
              Search for it, load all the package, and use only that one.

              Comment


                #8
                Originally posted by Foufoune_Rose View Post
                You're using data that aren't stored in your map.
                You have to save all your map in it, and never use an external package/map.
                In the Generic Browser, you have the name of the map, for example : DM-deathcube.
                Search for it, load all the package, and use only that one.
                Sounds like I have some work to do.
                If I used external data, is there a way to find it in the editor?

                Also if anyones interested I could post the data log.

                Comment


                  #9
                  right click on any custom content in your map and choose sync generic browser... it will load the external upk in the browser. you will need to rename everything so the package name = the map name.

                  Comment


                    #10
                    Originally posted by [GOW] K1lla View Post
                    right click on any custom content in your map and choose sync generic browser... it will load the external upk in the browser. you will need to rename everything so the package name = the map name.
                    The only problem with that is I haven't used any custom content. Only objects straight from the editor.

                    Comment


                      #11
                      Originally posted by mudcrab View Post
                      The only problem with that is I haven't used any custom content. Only objects straight from the editor.
                      2 questions.

                      1. What "graph" could you be using?
                      2. Is it possible you accidentally duplicated a stock .upk file? This can happen if you copy and paste the nodes in a material or duplicate a static mesh.

                      Comment


                        #12
                        Originally posted by Odedge View Post
                        2 questions.

                        1. What "graph" could you be using?
                        2. Is it possible you accidentally duplicated a stock .upk file? This can happen if you copy and paste the nodes in a material or duplicate a static mesh.
                        I'm not sure what the graph is Haha. I just remember a message the first time I tried saying something like "try to find the external object, (may take a while)". What a pain!
                        I don't think I could have duplicated a stock .upk file either.

                        Comment


                          #13
                          Originally posted by mudcrab View Post
                          I just remember a message the first time I tried saying something like "try to find the external object, (may take a while)"
                          this means something in your map is referencing an external upk.

                          i would check in your CookedPC/Environments folders to see if there's any duplicate upks.

                          Originally posted by mudcrab View Post
                          Also if anyones interested I could post the data log.
                          that might help..

                          Comment


                            #14
                            Originally posted by [GOW] K1lla View Post
                            this means something in your map is referencing an external upk.

                            i would check in your CookedPC/Environments folders to see if there's any duplicate upks.



                            that might help..
                            I'll try that.

                            Heres a photo of the error.

                            http://www.flickr.com/photos/57057925@N08/5442992095/

                            I know I'll figure this out eventually...

                            Comment


                              #15
                              Originally posted by [GOW] K1lla View Post


                              that might help..

                              I can't seem to find a way to have the entire log of the map from start to finish. I'd also have to send it as a private message due to it's size.

                              Comment

                              Working...
                              X