Announcement

Collapse
No announcement yet.

Custom rig crashing UT3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Custom rig crashing UT3

    Right my current setup is a single mesh character (GeoDav's tutorial) with a custom skeleton.

    The last thing I changed before it started crashing was this line in my custom family file

    MasterSkeleton=SkeletalMesh'CH_creature.Meshes.SK_ creature_Master'

    Obviously replaced the default with my custom master skeleton. My master skeleton is pretty much setup like Epic's, mesh bones with the root at Origin

    This is the last few lines of the log file when UT3 crashes when I go to the character selection screen. It's clearly throwing up some problems about the Master Skeleton but I wouldn't know what they mean. =/


    Code:
    ScriptLog: Current Faction: Mutants
    ScriptLog: Current CharacterID: A
    ScriptWarning: UTUIFrontEnd_CharacterCustomization Transient.CharacterCustomization_0 (Function UTGame.UTUIFrontEnd_CharacterCustomization:SetupButtonBar:006E) Accessed None 'LoadingPanel'
    ScriptLog: UTUIFrontEnd_CharacterCustomization::LoadCharacterData() - Loaded Profile Data, Value string: 
    ScriptLog: UTUIFrontEnd_CharacterCustomization::LoadCharacterData() - Unable to load profile data, using default.
    ScriptLog: UTUIFrontEnd_CharacterCustomization::StartLoadingPackage() - Starting to load character part package (Mutant)
    Log: Begin Async loading packages for Family 'Mutant':
    Log: - CH_creature
    Log: Family Asset Package Loaded: CH_creature
    Error: Character creation package 'CH_creature' doesn't have ServerSideOnly flag set. Set this using the 'SetPackageFlags' commandlet.
    Log: CONSTRUCTIONING: LoadFamilyAsset (Mutant) Took: -0.12 secs
    ScriptLog: UTUIFrontEnd_CharacterCustomization::UpdateLoadingPackage() - Pending character part package done loading (Mutant)
    Critical: appError called:
    Critical: Assertion failed: FamilyInfo->MasterSkeleton [File:.\Src\UTCustomChar.cpp] [Line: 500]
    
    Stack: 
    Critical: Windows GetLastError: The operation completed successfully. (0)
    Log: === Critical error: ===
    Assertion failed: FamilyInfo->MasterSkeleton [File:.\Src\UTCustomChar.cpp] [Line: 500]
    
    Stack: 
    
    RaiseException() Address = 0x75f9f328 (filename not found) [in C:\Windows\syswow64\kernel32.dll]
    CxxThrowException() Address = 0x75118e89 (filename not found) [in C:\Windows\WinSxS\x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.4053_none_d08d7da0442a985d\MSVCR80.dll]
    Address = 0xbb4c52   (filename not found) [in C:\Program Files (x86)\Unreal Tournament 3\Binaries\UT3.exe]
    Address = 0xe875174c (filename not found) 
    Address = 0xe875174c (filename not found)
    Anyone got any ideas?


    Ignore: Oh and the one AnimSequence I've got in my custom AnimSet plays correctly on the mesh in the SkeletalMesh browser but doesn't seem to play on the mesh when I put it through the AnimTree browser, even when I plug that one animation into the "Animation" slot of the AnimTree node.

    Answer to stupid question: Make sure you have "bplaying" and "blooping" ticked on your AnimNodeSequences. Though my first problem is still there, still crashing.

    #2
    Anyone have anything at all?

    Comment

    Working...
    X