No announcement yet.

cooking error

  • Filter
  • Time
  • Show
Clear All
new posts

    cooking error

    Hey there, folks! Having a huge problem.

    Can't seem to cook my map. It'll get 9 seconds into the cooking process and then it just seems to give me the red error "can't cook /utgame/etc. /; can't cook utgame/etc/map.upk.

    I can't seem to find the log file, since I can't open .dmp files to determine what the real problem is.

    I think it may have a problem with the fact that instead of exporting data from one map into this one, I simply copy/pasted some buildings I made in another project. After deleting these, rebuilding, etc. The problem doesn't seem to go away.

    Any suggestions? I've been working on this map for months now, and I'm about ready to throw in the towel completely on mapping, since I always seems to run into crippling problems like this when I get months/years into a map.

    Very frustrating.....

    I have accidentally saved the map file into the "CookedPC' folder and when I went to cook it, it gave me errors.

    On the copying/pasting theory. It could cause problems if your map is try to reference something that isn't there. So if you copy and pasted from any custom content, then deleted the source file, it could still be trying to reference something.


      Yeah, that sounds about right. You think if maybe I exported everything after deleting the problematic reference material into a new map it would wipe out the problem? hmmmm.... I'll give it a shot.

      The only problem is that there is no custom material yet. I'm still dumping meshes from epic.


        select all actors (alt-strg-shift + drag) and copy-paste them into a new map. Then retry it^^(if you don't have any custom content in your map it should work)


          Originally posted by Sp4der View Post
          select all actors (alt-strg-shift + drag) and copy-paste them into a new map. Then retry it^^(if you don't have any custom content in your map it should work)
          Yeah, I'm going back at it tonight. I'm going to play it safe and select all and actually export the data and re-import it just to rule the problem out completely. It drives me nuts that I have to go to these extremes just to continue with my map. I'll let you all know how it turns out.

          Thanks for the replies, by the way! You guys kick *****! I love this forum.


            Nope. Nadda. I'm starting to have another theory, however. I tried a rinky-dink map which consisted of a hollow cube, and tried to cook that. Same issue.

            I'm running Windows 7 64-bit. (uhgh...) As of a month ago. Is there some kind of issue with Win7 and ut3? If so, I can hop back and forth between that and xp. Or, I'm kind of thinking about blowing 7 out completely, since this isn't the only issue with complatibility.

            Anyone know? Also, how do I find my logs for cooking?


              I have Win 7 64-bit also and haven't had any issues with it. I forgot why I did this, but on the shortcut to launch the editor, I did enable the "Windows XP (Service Pack 3) mode.

              I think the log is in...

              ...My Games\Unreal Tournament 3\UTGame\Logs

              it's the Launch file?

              Also, you might want to try moving any "LocalShaderCache..." files in your My Games\Unreal Tournament 3\UTGame\Unpublished\CookedPC folder. They will be recreated when needed.


                Yeah, I've completely removed my "my games" folder so the game can start from scratch. Maybe I'll try the compatibility mode, and see where that gets me.

                Well worse comes to worse, It wouldn't be the first time this game has caused me to re-install windows to MAYBE solve a glitch. .....ugh....

                Hopefully a re-install of the game might help. Just hate the idle time....

                I'll let you guys know if it works.


                  Well, a quick update:

                  I re-installed UT3. Nothing. I can cook on an XP system, but not the one I have now. I'm not sure if a full format will fix it, so since my other computer can do the job, I might wait to do the re-install, since I do other programs and it can be a huge hassle.

                  If I decide to go through with it, I'll post if it works or not.

                  Anyway, Thanks for the replies!


                    try running the editor as an administrator, and make sure to have the map file in the administrators unpublished custommaps folder

                    hope that helps