Announcement

Collapse
No announcement yet.

Dynamic Lighting does not appear in Game :(

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Dynamic Lighting does not appear in Game :(

    Hi Epic Forums

    I am making a map, and its going great.
    But i have a problem.

    1. Whenever i place a light, and make it look really cool with shadows etc. the shadows disappear everytime i build lighting. But as soon as i move the light 1 pixel again, all the shadows come back.

    2. I tried to place a Directional Light, and tried all sorts of settings for the light, and somehow managed to get Shadows from the light even when i click build light. And when i test the map in the Editor, the shadows are there (A bit hard shadows though, like in Doom 3 - no softshadows in the UE3 demos from 2004).

    My problem here is, that when i then play the map in UT3, the shadows are gone. I can still see great texture detail, bumpmapping etc.
    But no dynamic shadows.

    So my question is:

    How do i get dynamic soft shadows from a light, and also make them appear when i lauch the map in the game?

    Thanks in advance!, and sorry if its a stupid question. im still pretty new to this

    #2
    basically, when you work on the editor, the lighting is dynamic until you make a light or full rebuild. Then the lighting (and shadow) are backed on texture to help performance. (ut3 not really optimised for dynamic light and shadow like Doom3 for example)

    So if you want increase the shadow render, you have to tweak the bsp surfaces properties (with the key F5) and set the lightmap resolution.
    32 by default, you can lower this value to obtain better shadow (remember, lower value, lower performance...)

    Comment


      #3
      In addition to what Sebastien said, the skylight actor will effect your shadows as well. This light can be used in "additive" style maps and will cast a light in the entire map. So, use it with a very low brightness and a color that matches the majority of the lighting in the map.

      You can also set a light that shines from the bottom of the map up to the top with in the same properties. With the lighting system in UT 3, it's impractical to try and get rid of all of the dark areas with the other lights.

      One more think, if you are going to use dynamic lights, use them only when "needed" and not in places that have a lot to render. These lights can really drain the FPS down the toliet.

      Comment


        #4
        I tried what sebastian said, but its not working

        I selected all surfaces and changed all lightmaps from 32 to 2.

        But the game still only shows great bumpmaps, and detail, but no dynamic shadows.

        i have attached screenshots:

        http://www.meny-graphics.dk/Editor.jpg

        http://www.meny-graphics.dk/Game.jpg

        Comment


          #5
          Be sure to have the "bCastShadow" option checked on both light and mesh.

          Comment


            #6
            Originally posted by fresch View Post
            I tried what sebastian said, but its not working

            I selected all surfaces and changed all lightmaps from 32 to 2.

            But the game still only shows great bumpmaps, and detail, but no dynamic shadows.
            Granted I don't mess with dynamic lighting much because of it's performance issues, I beleive in order to make it work, you need to enable the dynamic light channel on both the light and the mesh.

            Also keep in mind that depending on your light placement, a shadow might be be cast because it's being washed out with other lights. spot lights tend to work best to create shadows because they focus light in a general direction rather than in a sphere.

            Just a note about light maps, this will help make the shadows more "defined", but be careful. A lightmap resolution of 2 on a medium map will dramatically increase the build time as well as effect the file size and performance!

            Comment


              #7
              While we're on the subject of lights, i've got a question.

              Usually when i place a point light on a surface, and build, a quarter of the floor or cieling is pitch black if theres a light too close to it.. I've tried upping the resolution of the light map, and dropping it, but it doesn't really seem to help the editor's choice in where to put shadows.. Is there a way to avoid this?

              Comment


                #8
                Originally posted by Vicious3745 View Post
                Usually when i place a point light on a surface, and build, a quarter of the floor or cieling is pitch black if theres a light too close to it..
                Maybe the radius is too big. Select a light and you will see how big the radius is. Also, a skylight is usually needed to fill in the very dark spots. You should only have 1 of them and the brightness should be really, really low.

                Comment


                  #9
                  Originally posted by Odedge View Post
                  Maybe the radius is too big. Select a light and you will see how big the radius is. Also, a skylight is usually needed to fill in the very dark spots. You should only have 1 of them and the brightness should be really, really low.

                  No no, it's nothing that simple, i've tried.. I remember UT doing this in 2004 as well, i just don't understand why they'd do that at all.

                  Comment

                  Working...
                  X