Announcement

Collapse
No announcement yet.

Re-Import Model = Crash

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Who knows these things. I would suggest trying this on a different computer (assuming you have access to another one with UT 3 installed). I would also suggest sending it to someone else, but given it's file size, you would have to upload it to website.

    Leave a comment:


  • replied
    Originally posted by Odedge View Post
    I know you tried replacing the original mesh with the new one, but did you try just editing the text in the "StaticMesh" field (instead of selecting the mesh in the generic browser and inserting it with the "green arrow button"?
    Tested on one model at one time, Result:

    UT3 has stopped working ...

    I dont get it, how is this possible.

    Faulting application name: UT3.exe, version: 0.0.0.0, time stamp: 0x49cb0f31
    Faulting module name: UT3.exe, version: 0.0.0.0, time stamp: 0x49cb0f31
    Exception code: 0xc0000005
    Fault offset: 0x00a380f7
    Faulting process id: 0xcf0
    Faulting application start time: 0x01ca30093868ad03
    Faulting application path: C:\Games\Unreal Tournament 3\Binaries\UT3.exe
    Faulting module path: C:\Games\Unreal Tournament 3\Binaries\UT3.exe
    Report Id: cd0be7c6-9bfc-11de-9cb7-001fc6704d70

    Leave a comment:


  • replied
    To my knowledge, you would have to copy each field and then paste it, which is a lot of mouse clicks.

    I know you tried replacing the original mesh with the new one, but did you try just editing the text in the "StaticMesh" field (instead of selecting the mesh in the generic browser and inserting it with the "green arrow button"?

    Leave a comment:


  • replied
    Originally posted by Odedge View Post


    You could copy the location of each mesh, place your new mesh and enter the new coordinates (sorry for the unreasonable suggestion).
    if i open properties window, i see copy to clipboard and all copy to clipboard, how i can add this all parameters in clipboard to other Actor?

    (copying one parameter after other (Size, location X/Y/Z and Rotation (Yaw)) is crazy thing on 200-300 actors)

    So i basicly need copy just size, location and rotation parameters. is it possible?

    Leave a comment:


  • replied
    Originally posted by DukeNukemCZ View Post
    i have tryed replace only one mesh at one time (all of them = super fast crash).


    You could copy the location of each mesh, place your new mesh and enter the new coordinates (sorry for the unreasonable suggestion).

    Leave a comment:


  • replied
    Originally posted by Odedge View Post
    Maybe. Are you trying to replace all of the trees at once or can you at least replace one at a time?
    i have tryed replace only one mesh at one time (all of them = super fast crash).

    Leave a comment:


  • replied
    Originally posted by DukeNukemCZ View Post
    Maybe map is too large (185 MB map file and 132MB package file) or its something from older bugs in game in first release (i was working on map very slowly from game release (ver 1.0))
    Maybe. Are you trying to replace all of the trees at once or can you at least replace one at a time?

    Leave a comment:


  • replied
    I have tryed on my small test map and its work fine, but in my large map its rewrite new model back to old or editor crash or its write this message when try clean build and after this crash, even when i try re-write only one mesh in map.

    Code:
    MESSAGE
    
    Non-zero Active counts in UTransBuffer::Reset
    ActiveCount: 2
    SessionName:PW: Edit Properties
    Reason     :Rebuilding map
    
    Purging the undo buffer...
    Maybe map is too large (185 MB map file and 132MB package file) or its something from older bugs in game in first release (i was working on map very slowly from game release (ver 1.0))

    Leave a comment:


  • replied
    Originally posted by DukeNukemCZ View Post
    I have issue, its not allow me to replace mesh
    when i try replace it, its jump back to old mesh ...
    Uhhh, ok. Is your map possessed?

    Leave a comment:


  • replied
    Originally posted by Odedge View Post
    You could try importing it under a different name. Select one of the original meshes in the map, right click, then select "Select Matching Static mesh (this class)", which will select all of the same meshes in your map.

    Open up the properties, expand the StaticMeshActor, then StaticMeshComponent, then StaticMeshComponent again (that doesn't make much sense though ).

    Select your new static mesh in the generic browser, go back to the properties window and in the "StaticMesh" field, select the "green arrow" button to the right.
    I have issue, its not allow me to replace mesh
    when i try replace it, its jump back to old mesh ...

    Leave a comment:


  • replied
    You could try importing it under a different name. Select one of the original meshes in the map, right click, then select "Select Matching Static mesh (this class)", which will select all of the same meshes in your map.

    Open up the properties, expand the StaticMeshActor, then StaticMeshComponent, then StaticMeshComponent again (that doesn't make much sense though ).

    Select your new static mesh in the generic browser, go back to the properties window and in the "StaticMesh" field, select the "green arrow" button to the right.

    This will replace the original meshes with your new one, but keeping their place in the map (including rotation and scaling). Given that they are the "exact same mesh" (I presume), you won't be able to tell the difference.

    Granted, you may have an issue replacing 200 of them like this, which may also cause the editor to crash. So it's best to always make a different file of the map before trying this.

    If it crashes, you might want to add the original meshes (all 200) you want to replace in a group. Manually select about 20 at a time and do the above steps. Granted, it may take longer, but you shouldn't have crashing issues. You know you have replaced them all when the group gets deleted from the group browser.

    Leave a comment:


  • started a topic Re-Import Model = Crash

    Re-Import Model = Crash

    hi, i need re-import model (rewrite older version with better one) and i have around 200 times placed in map, this older model have 3 stages of LOD.

    Every time i trying to re-import (rewrite) model editor crash or half content from level dissapear and after try to save its crash.

    is there any way how re-import model without deleting 200 pieces placed around map? (its tree, no speedtree)

    If i trying delete LOD its crash too
Working...
X