Announcement

Collapse
No announcement yet.

Normal map Editor display

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Normal map Editor display

    I am currently getting a few props into Unreal and I have everything figured out except how to get normal maps displaying properly.

    I know its not really a prop but for this example, a simple head. How it looks in my 3D package:



    How it looks when I play my ‘level’ in the Editor.



    It almost looks like the normal is painted on like a diffuse map, confusing! I cant seem to get it displaying as a normal : )

    Any help would be appreciated.

    Cheers

    #2
    Anyone? Driver issue? A tick box on the material? I'm sure it's something simple.

    Comment


      #3
      Originally posted by Sevv View Post
      Anyone? Driver issue? A tick box on the material? I'm sure it's something simple.
      Assuming that you have a correct material and you've correctly imported the normal map, the first thing to check would be to see how it looks in the static mesh editor, that provides similar conditions you got it maya - it's maya, isn't it? That is: a single point light and realtime shadows - though the shadow system is different because it's application dependent.

      In the game environment (on the map), normal map depends on the shadow type: lightmap, vertex based shadows, realtime shadows. On the screen, it looks like the normal map is fine, the shadow type it's not.

      Also note that normal maps are compressed using an algorithm that wipes out all the small details. Therefore the final effect won't be the same that you got in your 3d package. You may use the ambient occlusion map as a compensation or increase normal map resolution.

      Use the ATI's Compensator program to see how the compression affects your original image, or just to get an idea compress it to JPG setting quality to something like 30%.

      Comment


        #4
        When you import you're normal map make sure you set it to the normal map import option. It's in the drop down menu that says default. Then also make sure you check compression no alpha.

        Also if it still looks funny invert you're green channel in photoshop.

        Comment


          #5
          Thank you both!

          mslaf - your right it was partly to do with the lighting and compressing the normal to show how it looks ingame is a great tip.

          apophis3d - Inverting the green channel is a fantastic tip, thank you very much. It looks great now.

          Cheers guys

          Comment


            #6
            Originally posted by Sevv View Post
            Thank you both!
            apophis3d - Inverting the green channel is a fantastic tip, thank you very much. It looks great now.
            Cheers guys
            I didn't think of that because this 'problem' (inverted vertical vector - that is stored in a green channel) - is specific to XSI and your 3d package doesn't look like one. You should consider setting this up in your rendering options so the next time it will render correctly.

            FYI: In DirectX the green channel contains the 'DOWN vector' and in OpenGL the 'UP vector'.

            Comment


              #7
              can you post what the normal map texture looks like once you flipped the green, I would think it would turn the overall blue value to something wierd and really mess up the texture, im curious to see what the texture looks like as well as what the model looks like now once you did flip the green channel.

              Comment


                #8
                My package is Maya mslaf, good idea about setting up the options.

                Heres the texture:



                And the model:

                Comment


                  #9
                  Originally posted by snake85027 View Post
                  can you post what the normal map texture looks like once you flipped the green, I would think it would turn the overall blue value to something wierd and really mess up the texture, im curious to see what the texture looks like as well as what the model looks like now once you did flip the green channel.
                  Unfortunately you won't see the difference that make you able to recognize the type: DX or OGL. Both maps are valid as textures. This may be confusing, thus it's good to set these things in the texture rendering application in the first place.

                  Comment


                    #10
                    How exactly did you flip the green channel? Is this a Maya option? If so where is it? Did you just invert the green channel in photoshop?

                    Comment


                      #11
                      Never mind.. got it..

                      Comment


                        #12
                        Originally posted by SocMonkey View Post
                        How exactly did you flip the green channel? Is this a Maya option? If so where is it? Did you just invert the green channel in photoshop?

                        Hi SocMonkey,

                        I’m really interested in finding out how it was done just in case I get the same problem. Please could you tell me how you did it in Maya.

                        Thanks

                        Comment

                        Working...
                        X