Announcement

Collapse
No announcement yet.

SOLVED! Turret help please!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    SOLVED! Turret help please!!

    I seem to have an issue with bots NOT getting into any turrets that I have placed in my map . . . they seem to go up to the turret, but do not enter it to shoot - they just stand next to it for a few seconds then move on. I am just placing the turrets in my map with bot-paths around the area. Is their something specific that needs to be done to point the bots to enter the turrets?? I cannot seem to find anything referencing this, and I have searched numerous sites for the answer . . to no avail. My assumption was that they would just enter the turret as they enter a vehicle - because it is their . . any help would be greatly appreciated . . . This map by the way is going to be a Greed/CTF map - not a VCTF, just to be clear in case that is the issue . .

    #2
    Have you built your paths lately? are the turrets too far into the ground?

    Comment


      #3
      Yes, paths have been built - about 10 times actually - even cooked it to see if that was the issue - wasn't. Turrets are not buried in the ground - a little off of the ground actually - made a static mesh to fit under the turret and when built the mesh/turret blend together nicely - though that does not seem to make a difference because the bots won't enter a turret even without the static mesh under it. They are out in the open (to test) and still no difference. They are added with all defaults - meaning I changed NO properties. Someone brought this same issue up with another one of my maps with 2 turrets in it - and I tested that one as well and they are correct - the bots don't enter it. I am at a loss as I thought this would be an automatic thing like bots getting in vehicles.

      Comment


        #4
        try laying down some turret tracks (pathways) with turret pathnodes for it. A small sectional circle or around the area in general. The only time i have scene bots in turrets is when opposing team members are near. Do vehicles have a likability scale?

        Comment


          #5
          Kinda bugged by this myself, this is the kind of thing that i've solved a couple times, and every time i solve it i forget the solution. So unless i was in front of the screen for 10 mins with everything set up, i can't fix it :P

          Worse comes to worse you could do a kismet action "enter vehicle" when NPC bots enter a volume near the turret, then reference the turret as the vehicle. Should work. If that doesn't work at least you've narrowed down the problem to the turret and not the ai.

          Not sure how familiar you are with kismet, if you have any questions just ask.

          Comment


            #6
            The help is great here folks . . . I just found out about the turret pathnodes from a friend of mine - who does some Kismet for my maps - I cannot figure kismet out (must be an old age thing - hehe) so he does what I request for my maps (he is in Kismet learning mode himself - and getting good!) Some great suggestions here to try - which will be in about an hour when I get home from work. I will post here what I get in order to save other folks a similar problem (provided it gets figured out ). Another thought someone else had was, are their too many weapon pickups that may possibly affect the bots getting in the turrets?, as they are loaded to the hilt with hand weapons they are not using the turrets?? Just another one of many thoughts as to why this isn't working. Again, thanks for the help/suggestions!!

            Comment


              #7
              What setting do you have your bot's AI on? If its too low they wont use vehicle at all most of the time. Try cranking them up to Skilled and see how they react to them. I've never had to do anything special to get them to use turrets.

              Comment


                #8
                In Instant Action bot settings are Adept, on our server they are Godlike. It seems several of my friends and myself have found that the bots do work getting in the turrets in VCTF game-type, however, when playing Greed, they do not seem to want to get into the turrets. So we are thinking it is a game-type issue and not a mapping (per se) issue. We are still working to resolve this for the game-type Greed, so I will post further results . . .

                Comment


                  #9
                  OK, after trying numerous ways to try to get the bots to work, adding turret paths, defense points, etc. turns out that when in-game - by ORDERING your bots to defend, they start jumping right in the turrets - problem solved. Thanks for the responses and all the help here folks - but we are looking good!!

                  Comment

                  Working...
                  X