Announcement

Collapse
No announcement yet.

Problems with shadows

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problems with shadows

    When I place a light in the map, point light or directional shadows for my meshes while I am moving them.

    Problem 1, I have to have the camera's face right up to the shadow for it to render, if I zoom out even a little it disappears.

    Problem 2, As soon as I build the lighting, shadows disappear for good.

    The only way I've found to make them stay is to check "bForceDynamicLight" on the directional lights, and "bCastDynamicShadow" on the mesh, however you still have to be right next to it to see it's shadow.


    This isn't my first rodeo mapping, so here are some of the basic answers. yes the sky box has "bCastShadows" turned off, all of that stuff is correct.

    Yes my meshes use Regular materials.

    Yes they all have their default lighting channels set, bCastShadow, bUsePrecomputedShadow, Static, bAcceptsLights and so on.


    I've never had this problem before. So i closed my editor opened the game and cranked up my graphics settings, then went back to the editor. It wasn't that, and this is the only map I've ever seen this bug on.




    #2
    I've found one intersting thing.

    If I crank the lightmap resultion of the floor (bsp now, was static mesh) down, not up, to 8 or 16 some of the shadows did appear for one of my larger meshes. Down to 2, they appear for most of them but look like ****. This got me thinking. So I scaled up one of the 300 meshes missing a shadow and it then cast one too.

    For an idea of scale, these objects are about the size of weapons, they are what make up the map.

    http://i163.photobucket.com/albums/t...dyourmom/1.jpg
    http://i163.photobucket.com/albums/t...m/Preview1.jpg

    Ok, so maybe UnrealEd doesn't normally make shadows for smaller meshes. But in this case I need it too.

    Ideas?

    Comment


      #3
      If you go into the object properties, not the light properties, you can enable "dynamic shadows" somewhere. But i was never satisfied with how close you had to be to get these shadows. Could never figure out how to make objects cast decent shadows from far away... maybe someone else knows.

      Comment


        #4
        You can override the lightmap resolution. If you right click on bsp and click on surface properties. Try setting it to 128 or something just gotta play around with it. You can also do this for static meshes its just way down in the object properties. So in other words you dont need to use a bunch of dynamic lights. They just lag things out and make performance bad.

        Comment

        Working...
        X