Announcement

Collapse
No announcement yet.

Kismet "Play Sound" delayed?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Kismet "Play Sound" delayed?

    I have a basic event in my level. Lets say it's an explosion.

    I have a "Play Sound" action in kismet that is set to play the sound when the explosion happens. It does this fine if I'm within the radius of the sound.

    However, if I'm away from the explosion area, and I wait until after the explosion has happened + a few seconds, and then walk to the area where the explosion was... the explosion sound plays!

    Anyone encountered that before?

    I can't see anything obviously out of place in the sound cue properties, and can't see any relevant property in the "Play Sound" node either... I've also tried using a different stock sound cue just as a test... still the same.

    #2
    Not encountered anything like that before. Id double check through out the properties of tge sound it isnt auto playing anywhere. Does it do iteach time the explosion occurs? Or is it soMething to do with the first time only.

    Comment


      #3
      Here is a test map I set up that demonstrates the problem:

      [link changed, see below post]

      It's very simple - a visible trigger starts the PlaySound, and there are two on-screen messages - one for when the PlaySound has been set off, and one for when the sound has finished playing.

      To demonstrate the problem: Run the map, walk into the trigger in front of you, wait until the message "Finished Playing Sound" appears, then walk into the lit area... and the sound will play.

      My first thought was that it was something to do with the sound cue, so I've tried various different, standard ones. Still no joy (the one in the test map is just a duplicated epic sound cue, so I could make it louder and decrease the radius for testing purposes).

      My second thought: perhaps it was because i was playing the sound using a TargetPoint actor as the source... but I also tried an ambientsound actor and an emitter, still the same.

      Comment


        #4
        Just updated the test map so it's even more obvious. This one uses a stock sound cue - "A_Movers.Doors.A_Door_Metal01_OpenStartCue".

        DM-PlaySoundTest.zip (40kb - uncooked)

        Simply run the map and keep your finger on the forward key.

        What should happen: the sound should've finished playing by the time you enter the sound radius (the lit area).

        What actually happens: the sound plays once you enter it's radius.

        ...all I want to do is play a **** sound! (one that can't be heard throughout the entire level)

        Comment


          #5
          I've worked around it for now by simply increasing the radius, meaning it's so quiet that you don't notice the bug. Still bothers me though.

          Comment


            #6
            Took a look at that map. If i walk constantly yes the sound still plays. If however i stop after it starts wait until stop message shows then walk in i get no sound played.

            Also, maybe scrap the way you are toggling sounds, here is how i've been doing it in UT3, works perfectly without issues.

            [screenshot]http://cr4zyb4st4rd.youtea.de/Screenshots/spoondog.jpg[/screenshot]

            Ignoring all the gat stuff and what not, i just have that there to generate a random time for my steam/air jet to play.

            What i use though is a toggle to turn on and off the Sound. This doesn't work on a normal sound, but using AmbientSoundSimpleToggleable it works great. Its the same as a normal sound via properties so setting radius up etc is simple.

            It's hidden under Actor>Keypoint>AmbeintSound>AmbientSoundSimple>Amb ientSoundSimpleToggleable

            If you need a look at it in a map my vCTF_Defection_SE uses it when a flag is capped, the burning hellbenders explode.

            Hope that helps you out.

            Comment


              #7
              If i walk constantly yes the sound still plays. If however i stop after it starts wait until stop message shows then walk in i get no sound played.
              Yea if you wait long enough, it won't play just because the example sound I used there is very short (but even walking constantly, it should've finished by the time you reach the radius, and kismet even says it has finished). If you replace the sound cue with a longer one (like A_Ambient_Loops.Necris_wraith_start), hit the trigger, stop, then walk in, it will still play.
              ...here is how i've been doing it in UT3...
              Ah - yes, I tried that way but unfortunately the sound I'm using is a "one-off" (i.e. doesn't loop)... so when i toggle the sound back on, it starts in the middle of the sound, or at the end of it, if you know what I mean.

              Comment


                #8
                That's interesting and cant remember having that problem in Defection which used a non looping sound if i remember right. If i get time ill see if i get the same issue :/

                Comment

                Working...
                X