Announcement

Collapse
No announcement yet.

Playing ambient sounds using Kismet: sounds getting silenced randomly.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Playing ambient sounds using Kismet: sounds getting silenced randomly.

    I'm using Kismet to play a light hum on my light meshes (which I have a lot). The sound plays fine, but is getting silenced on random meshes I apply it to using the "Play Sound" action. (I use this to make it easier for me. Placing hundreds of AmbientSound actors would be a pain in the ***...)

    Here's a screencap of my sequence:

    [shot]http://img502.imageshack.us/img502/8026/lighthumseq01.jpg[/shot]
    (Object lists, which have the amount of objects in parenthesis.)

    I tried PIE, and uncooked in the game itself, and I will see if cooking fixes it once I get to it. It's not noticeable if you do not know it's there and concetrate more on battling or something else, but I'd like it to work flawlessly for the people who love immersion and good ambience in levels.

    I tried with and without bots, and it seems that bots have something to do with it... Without bots they seem to work, but when I add some bots, some of the meshes (random, no exact meshes which don't work) stop giving a sound.

    I've increased the MaxConcurrentPlayCount in the cues I use for the sounds, so that is not the problem, unless there is a hard coded limit I don't know of.

    Another question, how hard will this setup hit the perfomance? I noticed no drop in FPS or the like, but I'm affraid too many sounds playing could slow down older computers a bit.

    Thanks in advance.

    #2
    Could it be that you're exceeding the number of simultaneous sounds that can be played by your PC's soundcard? (as in the hardware limit)

    Comment


      #3
      Hmm, I'll check how much I've got for that one. Thanks for pointing out.

      E: I've got a Realtek HD Audio card thingy. The problem is that I can't seem to find any information on what version of the card this is, and what are its limits...

      I think I need to apply the sound only to less silent areas of the level, and remove it form lights which the players can't get near to...

      Comment


        #4
        some of the sounds or cues (can't remember where the setting is) have a setting like "max number of simultaneous instances" -- which may also be affecting what you're trying to do. Does that pic show 161 instances on "smalllightmeshes" ? Also check the "play sound" action itself for such a setting.

        Comment


          #5
          Yeah, that's the MaxConcurrentPlayCount you're talking about, which I have covered already.

          I'll check if there is something hidden in the Play Sound action...

          Thanks.

          Comment


            #6
            Plug you finished output back into the play, set an active delay on the finished output to the exact run time of that sound effect or maybe a little more. That way you don't get overlapping sounds.

            Comment


              #7
              Originally posted by apophis3d View Post
              Plug you finished output back into the play, set an active delay on the finished output to the exact run time of that sound effect or maybe a little more. That way you don't get overlapping sounds.
              Do overlapping sounds kill the sounds from the source it happened in?

              I'll try this if it helps. Thanks.

              Comment


                #8
                What I meant by overlapping sounds is if you did not set any delay on the finished it would keep playing more and more of the same sound, before the first one finished. If that does not work to keep it playing there is always more complicated ways we can make it check to see if the sound is playing.

                Comment


                  #9
                  I've not been able to find precise information regarding the hardware limit on the number of concurrent sounds but the largest number I've seen is 128. You could try reducing the number of sounds to less than this (to allow for other gameplay sounds) to see (hear) if it still happens.

                  Comment


                    #10
                    Yeah, right now the number of smaller light meshes using the sound are just under 120... I'll be cutting from some of the more noisy areas.

                    Thanks for that number Oddside.

                    Comment


                      #11
                      Originally posted by apophis3d View Post
                      What I meant by overlapping sounds is if you did not set any delay on the finished it would keep playing more and more of the same sound, before the first one finished. If that does not work to keep it playing there is always more complicated ways we can make it check to see if the sound is playing.
                      Now I got what you meant. I unlooped the hum sound in the cue and used the technique you described (cue length as delay and replugged to "play"). Now the sound can stop when other sounds are playing around, and start again after its quiet and the delay time has passed.

                      Thanks! Works great now!

                      Comment

                      Working...
                      X