Announcement

Collapse
No announcement yet.

Lightmap | Maya | Stepping

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Lightmap | Maya | Stepping

    I'm getting this wierd stepping with my shadows on a simple sphere that I imported from Maya 8.5. I tried a range of different UV approaches along with re-installing Unreal and trying to do this with no patches applied to unreal (I was previously unable to automatically generate UV's from unreal with patches installed), however the generated versions give me roughly the same results as my own UV's.

    Here is the result with my own UV's:



    This is what I get with Unreal's version of approximated lighting from the viewport (which quite frankly I would love at times ) :



    I've followed various tutorials in the past but I never seem to get the same results as everyone else, sometimes the phrase "flatten UV's" is mentioned but always felt a bit embarrassed to ask what that is as it seems like something I should know by now, although it sounds a bit like 3Dmax witchcraftery to me

    I'd love to solve this annoying problem, I seem to have nothing but problems with lightmapping and quite often have to resort to subdividing my models and going with vertex lighting instead which isn't exactly ideal.

    #2
    a bizarre issue indeed, probably won't help but are you building full quality lighting?

    i've never seen this issue before.... sometimes it'll mess up as well and i find it helps when i change the lightmap uv channel in the SM editor window to 0 and back to 1... sometimes it resets it to the right place but from the looks of your lightmaps in the generic browser.... weird.

    Comment


      #3
      Hmm..

      Thanks for replying btw Kedhrin. I tried your 0 to 1 idea with the UV channels and got some odd results, firstly though I should add that my '0' channel is very different in scale to my '1' channel in that it's about an 8th of the entire UV space. This is because I eventually intend to make a large atlas texture for 16 different rocks - yes rocks, not sphere's

      The thing is when I switched the channel to '0' and rebuilt lighting I got exactly the same results as before.

      So from here I reasoned that I should go back into Maya & temporarily transfer the '1' channel over to the '0' channel and re-export into unreal to see what happens, (in my mind I figured the shadowing would finally look good leaving me a smaller problem to solve with the channel's).

      ...Same result again though.

      I'm not sure where your from but it's a bit late now where I am (05.30am), so I'm not going to think about this too much at this point but it seems to me that there's a breakdown occuring in the export process somewhere because I should get different results, either that or I have to re-patch unreal again, (at this point I even hope that it's something stupid and that I'm importing the wrong mesh over and over ).

      I don't think I am though. Still at least your suggestion has given me something new to go at 2mo.

      Incidently, you said something about building full quality lighting. Now on the old editor there was an option for build options but I can't for the life of me find anything for that, (if there is such a thing that would fix this I'd probably be able to go back to my last map and make it look better !!) - where the frig is it?

      I dunno, it'll be 3 days on the trot - assuming I fix this 2mo, just to get a bloody sphere to shadow correctly! Should I ever get a job I'd better get paid well for going through all this

      Comment


        #4
        Little Update on the above.

        1. I re-patched Unreal. Same results (incidentally patch 2 does remove UV generation in the editor for me).

        2. I was worried that A. my version of Maya (8.5), isn't exporting my meshes correctly & B. that there's something wierd about the sphere itself. So I used one of DGunreal's skysphere meshes that I have, I don't know why but I did get different/puzzling results:

        (DGunreal's mesh is on the right)


        I'm not sure what that's all about but the UV on the mesh shouldn't produce that result of course.

        3. I updated my graphics driver to the latest which is a January release. Same result.

        4. Oh, I found the lighting build quality setting (I already had it on the full quality setting though).


        Soo... I'm not sure what to do next to be honest, you know what I'll also make the above simple level available. Maybe someone on here will get a different result to me:

        http://www.alexhighland.com/DM-A_testshadowy.rar

        Extract it & bung it in the; My Documents\My Games\Unreal Tournament 3\UTGame\Unpublished\CookedPC\CustomMaps

        then open: DM-A_testshadowy.ut3 from within the editor.

        Comment


          #5
          Ureeka !!!

          I realised that DGunreal's skysphere would have the normals facing inwards so I made his sphere bigger and put a light within it & hey-presto it shadows properly!

          Now I don't know what he uses to make his meshes but I think I'll try going back to Maya 7 coz I reckon the 8.5 exporter is screwed-up somehow.

          Comment


            #6
            Incidently, that eureka moment can now be cancelled.



            I installed maya 7 and am still getting the same results. I don't really understand why one of my sphere's gets these wierd results but I'll keep hammering away until I find the answer I guess.

            Comment


              #7
              Yeah, though you can't miss the light build properties, it pops up every time you click on the build lights icon. Maybe the issues is related to your mesh properties, or maybe it is because of the actor X plugin. Either way, why have you gotten back to Maya 7 out of curiosity?

              Also, while exporting the mesh do you check the "Obey hard edge" checkbox?

              Comment


                #8
                Thanks Kantham.

                I missed those light build properties because I usually just click the 'build all' button rather than the build lighting one. Regarding the mesh properties aspect you mentioned, I pretty much leave everything on the defult settings (apart from the overidelightmap checkbox). I did at one point try upping the settings on the advanced lighting section but I think that's just for when your going with vertex lighting. I'm not really sure what else I could play with to change anything to be honest.

                I tried going back to Maya 7 because I thought maybe the 8.5 version of the ActorX plugin might not be doing its job correctly or that there was something unusual about Maya 8.5 itself that was causing this. Unfortunately both Maya 7 and also XSI 7 give the same results, I haven't tried 3Dmax but I doubt it's going to be a case of "third times the charm" on that front.

                Regarding the ActorX settings used, I've actually tried every combination recently but usually I check the following three by default: [selected items only], [triangulate] & [obey hard edges]. I've also tried different settings under Maya's normals menu, such as: soften all edges, harden all edges & set to face etc. None of which seem to stop the shadows from being blocky.

                The strange thing is I seem to get quite normal results with other meshes I've imported in recent times. I have like a sort of semi-sphere that I used for a glass skylight on a previous map which seems to shadow fine, I imagine I planar mapped that one. This might lead me to believe that sphereical type mapping doesn't work correctly but the DGunreal skysphere does work under these UV map conditions...?

                The only difference I can see between these meshes is the DG sphere was imported into mypackage a while back under a different UT3 install. That sphere still builds correct lightmapping information so maybe its something to do with Unreal's import process? Incidently I also tried importing another sphere into mypackage rather than my map file but still get the same results so it can't be a package issue.

                The whole thing is completely perplexing & frustrating. I can't very well start building my rocks until I get past this problem so I remain stuck in this 'sphere-hell'.

                I don't suppose you could help me out by trying to recreate the problem at your end?

                It's just a lightmapped sphere in a bsp-subtracted room 8192x8192x2048 with a mid-grey texture applied to everything. It might help me understand whats going on here. Pretty please

                Comment


                  #9
                  this may be something you are aware of.... but by any chance are your faces double sided on export? if you were in 3dsmax you could do an STL check, could be something on the exporter settings? i don't use maya so i don't know how their exporter works. I could see this error happening if theres double faces and the faces' UVS are stacked and its building the lighting all garglebablleeeedoope (only way i can describe it).

                  i downloaded your package and looked at everything, everything seems fine from what i can initially tell in the editor.... i'm thinking its either a mesh bug or its something on the exporter..

                  Comment


                    #10
                    Cheers Kedhrin.

                    Yea, having double-sided faces would do that I imagine but as far as I can tell there are only one face where one should be. I used maya's default sphere primitive for this but I also made a sphere from a cube at another point which also gave me blocky shadows. I also neglected to mention earlier that I did a quick Maya light bake and the shadows came out smooth, forgot about that.

                    The maya exporter doesn't have much in the way of options I'm afraid:

                    ~
                    EXPORTER - [no popup confirmations], [convert underscores to spaces], [selected items only], [use geometry names as filename].

                    MESH - [auto triangulate], [obey hard edges - convert to smoothing groups], [consolidate output geometry].
                    ~

                    I've tried various combinations of the options under 'MESH', they don't make any difference though.

                    Incidently I have noticed that other objects in a scene will cast shadows quite naturally onto one of these spheres in smooth gradients. I noticed this when I had two spheres in the scene at the same time. I'm not really sure what this means?

                    Comment


                      #11
                      Are all your UV points and verts merged/welded together. I'm not sure how they'd end up getting detached from one another, but that was the first thought that popped in my head when I saw your screens. I have no idea if that would be the problem or not though.

                      Also your lightmap resolution seems a little high, maybe trying a lower number like 128 or even 64 will blur the shadow.

                      I'm just sort of throwing ideas out here, so feel free to totally ignore them

                      Hope you can figure it out soon!

                      Comment


                        #12
                        Cheers, Madmike

                        Haha, I'm in no position to be ignoring ideas at this stage

                        I checked my uv's, verts, edges & faces now mate and there's only one of each. I also checked at some other stage different lightmap resolutions, I think I tried; 4, 16, 64, 512 & 1024. They just made the square blocky shadows more 'fluffy'. -Well the first three mentioned anyway.

                        Thanks for the suggestions though.

                        Comment


                          #13
                          Call me crazy but this problem has been bugging the heck out of me ever since you posted it Hmm... I've been trying to think of what may be causing it. One other thing I thought of is have you tried "set face to normals". I think that's what it's called? It's in the same place set normal angle and such are in Maya 7 at least, I think it may have been moved and/or changed in the releases since then.

                          I know sometimes setting normal angles in Maya can **** all the smoothing out and the only way to fix it is to run "set face to normals" to get them back to the way they should be and then reset the angles to whatever you wanted them to be.

                          Also I just thought of this too, I'm assuming you've all ready done it but running modify -> "freeze transformations" on your models can make a world of difference when it comes to the normal angles in Maya. Maybe something like this is causing this problem?

                          Comment

                          Working...
                          X