Announcement

Collapse
No announcement yet.

custom character model problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    custom character model problems

    hey everyone, im making a custom character and its not looking too good.,
    my main question is how do i get that nice smooth look on my models without
    going through the roof with the polycount, for the record im using max 9 sp2 and zbrush 3

    right now my model has a very jaggie and faceted look with no smooth modifiers, when i apply a mesmooth modifier on it with 1 iteration it looks fine , but the head alone goes up too over 7000 faces,if i lower the iterations to 0 , the poly count goes back down to 1794 but it looks horrible,better than no smoothing but still very ugly.

    now this may sound real stupid but i thought normal maps gave the illusion of a smooth model as well as the little details,now imagine how horrified i was when i applied my normals and still i have a very sharp, jaggie, faceted model,but now it got scratches, dents and detail as well, lol

    now if normal maps dont give it a smooth look, and the mesh smooth gives it too many polys, how do i make it look good?

    i have also tried turbo smooth , that gave the head like 13,000 polys,i have also messed around with the optimize modifier and it just ends up distorting my model

    the only other thing i can think of is smoothing groups in the edit poly tab ithink,,but i never botherd to learn how to use any of that....im gonna cry if thats my problem...lol

    anyways ive got screen shots of my model with different levels of mesh smooth on with the poly count for each mesh below each screen


    NO SMOOTH MODIFIER


    POLYCOUNT:HEAD 1794
    TORSO:1800
    ARMS:2731
    LEGS:1701
    BOOTS:2360

    NO SMOOTHING WITH NORMAL MAP



    SMOOTH MODIFIER WITH 0 ITERATIONS


    HEAD:1794
    TORSO:1800
    ARMS:2731
    LEGS:1701
    BOOTS:2360

    SMOOTH MODIFIER WITH 0 ITERATIONS AND NORMAL MAP




    SMOOTH MODIFIER WITH 1 ITERATION



    HEAD:7210
    TORSO:7206
    ARMS:11,162
    LEGS:6828
    BOOTS:9544





    i know this is a realy big post but i need help ive spent a few months on this character, ive already had her in game but shes just too ugly ,i hope i have given enough information and any help i can get would be great!...ps .geodave, evil engine i think u guys may be my only hope as ive seen you talkin bout characters more than any one else

    thanx

    #2
    what is the poly count for Jester?
    if Jester's poly count is > or = to your models than there shouldn't be any issues.

    I think.

    Comment


      #3
      Use smoothing groups in the mesh modifier, not a meshsmooth modifier.

      Comment


        #4
        thanx for the info dazjw.....im gonna go see what i can do with it!

        Comment


          #5
          as DazJW says use the smoothing groups in the modifier, if your not sure how to then in your "3ds max reference" search for "polygon smooth"

          ps can you do something with the eyes please

          Comment


            #6
            ok. i converted it to an editable mesh and now im getting somewhere!...she's getting smoother and the polycount aint going up! great!....now i just dont understand, if you can do this without changing the poly count, then what good are the mesh and turbo smooth modifiers for,

            ps. geodave ,when you say fix the eyes , do you mean the model or texture...just wondering.......thanx for the help everyone!

            Comment


              #7
              Meshsmooth gets better results because it's making actual geometry, if you try and use normal smoothing groups on a quite sharp angle you get ugliness.
              That's all well and good when tri counts don't matter (like when making a high poly version of a model to bake a normal map from) but obviously smoothing groups applied to the minimum possibly amount of geometry are better for ingame models.

              Comment


                #8
                she looks very wide (popped) eyed to me,
                ref smoothing, i use editable poly, you can select all the polys then click automatic smoothing (set the angle you want) and it does it for you, the draw back with this is that you got a lot of smoothing groups which is then best to merge

                Comment


                  #9
                  ok i want to thank you guys for helping me, i know i have probly been pretty anoying today,.....anyways i think its as good as its going to get, i have been able too get the smoothing groups ,and auto smooth to work,everything you guys have told me WORKS, the problem is when i set it to auto smooth, the result is the exact same as if i had a mesh smooth modifier on wth iterations set to 0, manualy setting smooth groups gives me the same result.
                  so i think its as smooth as shes gonna get, ps. geodave....i will try to make her less scared or suprised looking. i never noticed her eyes untill you told me...i might try modeling eyelids too.......im just not very good a modeling yet..as she is only my second charater.. my first was kung fu panda! so im not too good at humans yet! lol

                  Comment


                    #10
                    im almost there ...my character is in the game no problem , now i just need to get the portrait going. but when i try to import my portrait into my characters package i get the following error "CANT IMPORT NON POWER OF TWO TEXTURE HEIGHT"...ive tried multiple image sizes eg...640x480 , 800x600and i even actualy tried a non power of two on the height a few times just for the heck of it .....no luck.....does any one know the reqiured image size for a character portrait?

                    im so close to being finished , thanx for your help

                    Comment


                      #11
                      640, 480, 800, 600 are not powers of 2.

                      You want to use 2, 4, 8, 16, 32, 64, 128, 256, 512, 1024...

                      Comment


                        #12
                        thank you very much for the help, i was vey tired last night and for some reason i thought all even numbers were powers of 2............like i said i was tired ......all is good now though.........my 1 and only problem now is that my material has a lot of bloom..making the character look like she's emiiting light .......but im gonna try and figuer this one out on my own

                        thanx again folks!

                        Comment


                          #13
                          The textures need to be in the Character LOD groups, you can set this after import but when I did that it didn't fix the emissive problem. To fix it I had to reimport all my textures and assign them to the appropriate group (Character, CharacterNormal, CharacterSpecular).
                          It's one of the drop downs when you import a texture.

                          Comment


                            #14
                            thanx for the info dazjw, i do have my lod groups set right , i just have to try and tweak the actual material.....however i have previously forgetten to set lod groups, and it gave me a little more than an emisive problem.....the textures were pure white! lol...it took me a while to find out what i had done, but now im not gonna forget again.....
                            i will be releasing it in a day or two, unless i dont figure out the material ....im pretty sure i just have to change the emmisive color to a darker one....i think .....so keep ur eyes on the beta realese page ......thanx again

                            Comment


                              #15
                              for your emmisive try using 30% gray and not pure white also check your using the correct parent for your MIC's

                              Comment

                              Working...
                              X