Announcement

Collapse
No announcement yet.

Newly imported skeletal mesh

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Newly imported skeletal mesh

    Hi I'm extremely new to this - when you've imported a skeletal mesh, how do you make it so the player can't walk through it?

    #2
    You need to add either a custom collision model or a blocking volume depending on how the skeletal mesh is to be used.

    Try this : http://udn.epicgames.com/Two/CollisionTutorial.html

    it's not UE3 based but will give you an idea of where to head

    Comment


      #3
      hmmm, so for example if I set bounding boxes to the bones in AnimSetViewer, how would I get those to be treated as solid?

      Comment


        #4
        Collision for skeletal meshes should be handled by creating a PhysicsAsset for the skeletal mesh and assigning it to the SkeletalMeshActor (or other actor using a skeletal mesh). The bodies of the PhysicsAsset will be used as simplified collision meshes.

        Comment


          #5
          (Sorry for being such a nub in advance)

          I've been able to insert the created Physics Asset as a "KActor" and get the collision working, for all functional purposes it seems to work; but is this doing it incorrectly? The geometry is the same from the skeletal mesh but I'm just kind of confused if this is the accepted way to do it

          Comment


            #6
            I think it would have been a KAsset actually. That is how you would add a skeletal mesh as a physics actor (i.e. ragdoll) to a map. You want a SkeletalMeshActor or SkeletalMeshActorMAT if you want to control the animations, etc. with Matinee. Each of these actor types has a PhysicsAsset property where you can assign the PhysicsAsset. There is also a bHasPhysicsAsset property you need to check as well I believe. And of course you want to make sure collision is enabled. I "think" that will enable collisions with the player as well as other actors.

            Comment


              #7
              There is also a bHasPhysicsAsset property you need to check as well I believe

              Yes, yes there is..

              and 4 years later, your post helped me solve a super frustrating problem i was having where Skeletal Meshes would not collide with Kactors.. I had everything set up correctly EXCEPT for "HAS PHYSICS ASSET" was left unchecked in the skeletal meshes properties.. Lost.. in a world of checkboxes..

              Thank you Thank You Thank You!!!

              Comment

              Working...
              X