Announcement

Collapse
No announcement yet.

I need help with UTJumpLiftExit

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Have you tried pausing the lift at each floor for 3 seconds? Maybe the bot won't get off unless z axis motion is stopped. If 3 seconds works, you can shorten it up until you find the time cutoff.
    most likely extracost will have to adjusted. If you truly want it random, I believe a script would be required (as previously mentioned).

    Leave a comment:


  • replied
    You cannot have a jump lift exit below where the lift stops in your setup - at least, if I read and understood what you said.

    If you have three levels what you could do is this. Have the regular lift exit on the first floor; then put jump lift exits on the other two floors.

    So basically, bots don't ride the elevator all the way to the top, but to the first floor. Their second and third choices are to jump off the lift either to the second or third floor.

    Keep in mind that by default, Jump lift exits have an extra cost on them. I think as high as 200 or 300 (not sure); but anyways, this means that bots will most likely not take that route (the higher the extra cost, the less likely for bots to go that way). So you may have to edit the extra cost value. Go to properties, navigation point.

    Leave a comment:


  • replied
    I'm sure Ambershee, DGUnreal or one of hte others will be able to help more... but I didn't even think you could use that entity in that way... Thinking about it... I dunno if you'd be able to make them randomly pick between the two exits without code? I dunno.

    If it can be used that way, remember that if theres something up the top that they consider more 'valuable' they will ALWAYS go for that if its there (ie. not respawning)

    Leave a comment:


  • started a topic I need help with UTJumpLiftExit

    I need help with UTJumpLiftExit

    I can't get UTJumpLiftExit to work, can anyone help?

    I have a lift that rises past two platforms to get to the third. I want bots to be able to jump off at the first or second platforms so I tried a UTJumpLiftExit, but they always ride it to the top anyway

    There is a player spawn and a lift exit by the bottom of the lift. On the second platform is a jump lift exit and some path nodes that lead to a rocket launcher and a shock rifle. On the third platform is a regular lift exit and nothing else.

    I spawn a bot, he gets on the lift, rides it to the top, gets off, gets back on, and rides it back down again.

    Any idea what I am doing wrong? The jump lift exit is correctly attached to the lift centre.

    [shot]http://farm3.static.flickr.com/2133/2513504387_e1ed265bec_o.gif[/shot]
Working...
X