Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

UT3 editor crashes

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • UT3 editor crashes

    my editor seems to crash everytime i try and test the level. it says that UT3.exe has encountered a problem and needs to close every time i hit that button that says play from here. anyone with a solution?

  • #2
    I get that quite a lot. I just open the map file, rebuild all and then it usually works.

    Comment


    • #3
      that didn't seem to help me.

      Comment


      • #4
        Any number of things can cause this issue.

        Did you Build and save your map first?
        Did you use a valid game type prefix (DM, CTF, WAR, etc.)?
        Did you use only Alphanumeric and "-" "_" in the file name or did you use custom characters?
        Are you using any of your own custom content that may have design issues?
        Is your system specs up to launching two simulatentous copies of the engine?
        Did you use external packages for custom content (avoid doing this)?
        What happens if you copy your map to the Published folder and run it in the actual game?

        Comment


        • #5
          the only thing i can think of thats on that list is i used one of my own textures.

          Comment


          • #6
            Look in your $(My Documents)\My Games\Unreal Tournament 3\UTGame\Unpublished\CookedPC\Environments folder and make sure there aren't any packages in there. If they are there, they may need to be removed.

            Comment


            • #7
              dont even have an enviornments folder there.

              Comment


              • #8
                As I mentioned previously, what happens if you copy the map file to the published folder and run it in the game, does it still fail or throw any errors?

                Comment


                • #9
                  tryed that too, but game crashed in all together now, can't even play the game. So i uninstalled Everything. installed it again, and now everything works fine. i don't think i will install the patch. people seem to be having too many problems with it. I didn't have any problems with the patch i think because it worked for a few days after the patch was installed.

                  Comment


                  • #10
                    If it crashes when you run the game, you should have checked the log files.
                    If an uninstall/reinstall fixed it, most likely one of the UT3 files or packages got changed while you were working in the editor, or the shadercache files were corrupted.

                    Comment


                    • #11
                      This is an old thread but it comes up one of the first in google when I search for this problem.

                      What worked:
                      Go into My Documents/Unreal Tournament 3/UTGame
                      Delete the following Folders:
                      Autosaves
                      Config
                      Logs


                      Restart UT3ED and test your level. It should regenerate fresh configs. I don't suspect logs had anything to do with it but I'm not sure if it was the Autosaves or the Configs that gives us this problem.

                      Comment


                      • #12
                        The reason it is such a difficult thread to answer with one solution; is because their is probably more than 1 problem.

                        - it could be anything; even "deletedredirectors.upk"

                        - nevertheless i hope Venguard has provided the solution

                        Comment

                        Working...
                        X