Announcement

Collapse
No announcement yet.

Numb Q on casting shadows

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Numb Q on casting shadows

    Hi I have static mesh's casting shadow in my map but when I move a distance from them the shadows go off. Ive tried to expand the light radius but this does nothing.At the moment I stand within a radius of 256 and everything works fine but as soon as I leave this radius they go off. Anyone Know what Light setting change's the shadow on/off radius from the static mesh or light.

    #2
    Try higher falloff on the lights.

    Comment


      #3
      Build your map (click on the Build All toolbar button). You are seeing the quick dynamic shadows that are there to show you basically what the map looks like when built. These disappear when you get a certain distance from them.

      Comment


        #4
        Hi DGUnreal

        Thankyou for your reply. I take it, this means there is no way of control when they pop off, its just default seems to be set at about 256?

        Hi Hushpuppy. Thankyou for your reply. The fall off has no effect. I think shadow cast has a maximum length default but not sure if this can be controlled.

        Comment


          #5
          there is a way, that is by increasing the minimum shadow resolution
          i've got a map in which i have a dynamic shadow, at around 3000 units it popped out of existance, i then experimented with values for the minimum shadow resolution, i just entered a high number 3600 for example and it popped back and does not disappear now.


          here is an example

          Comment


            #6
            hi Xerofighter, I have had no luck changing this value, I dont know why. I copied all of your settings with no luck.... Do you know if there is any tutorial or documentation on setting shadow distance fall off ? If not I give up ......

            Comment


              #7
              don''t take over my 1100 setting, it was the minimum for the distance i was at, you may try increasing the minimum value to around 4000 and see what happens.

              i don't know any tutorial sry, i found this out with luck, if you could PM me a downloadlink to your map, i'll have a look and try to fix it for you.

              Here is the full list of settings i have on my light, maybe it helps
              (in my map the minimum shadow resolution is set to 3600, may be a bit overkill, but at least i'm sure it does not disappear)

              Comment


                #8
                Hi Xerofighter thankyou for the quick response. I am away for the weekend now... so will not be able to play around untill I get back on Tuesday.Will give you a heads up on my progress.......Will play with settings and after.If no joy give you my map. Thanx till Tuesday....

                Comment


                  #9
                  I recommend not using dynamic shadows at all except in those rare instances when they are required such as for InterpActors (Movers), etc.
                  In all other cases, keep your lights in the Static channel, don't force them to Dynamic, and control the lightmap quality by setting the lightmap resolution on the StaticMeshes and CSG surfaces.
                  Most mappers and most maps do not require dynamic shadows, and not only do they render slower, but there are a number of other issues to keep in mind such as people with lower systems/settings may not see the shadows at all.
                  Only use dynamic if you can't get away with using static.

                  Comment


                    #10
                    Thanx DGUnreal for your advice. I think you are correct I dont really need to use Dynamic shadows I will revamp my map and ditch the problems I have encountered.With a little rework it will look the same.Thankyou for the feed back.

                    Comment


                      #11
                      There are also a few tricks for getting high quality shadows at grates or windows if you are using CSG Brushes, so if you are using any of those, post back and I'll cover it.

                      Comment

                      Working...
                      X