Announcement

Collapse
No announcement yet.

*.obj Smoothing Group Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    *.obj Smoothing Group Problems

    Hey guys,

    im creating a mesh, and using Zbrush want to create normal maps. as you probably know, Zbrush only accepts *.obj's or *.ztl's. anyway, when i export my *.obj from 3DS Max 9 the smoothing groups dont appear to go with the mesh, even though it is ticked to export with smoothing groups.

    its a pain in ths a$$ because when the normal maps come out, they look like $h1t because i can never get the smoothing to match up with the actual mesh, and everything is dumbed right down.

    it would be great if there is a solution to this, it would save me a lot of time and my work would look far better.

    thanks

    #2
    First, I am a maya user with limited Max experience, so I may mix up the terminology that is used in Max.

    Zbrush is going to ignore your edge normals anyway(akin to setting the smoothing angle to 180, soft or whatnot in your smoothing groups). This doesn't matter though because you are using a high poly mesh to push out a normal map, basically negating the low poly's normals anyways. To fix the problems it sounds like you are having you should just need to import the base mesh(the mesh which will receive the normal) back into 3dsMax and smooth/soften it's edge normals(smooth group). Otherwise you are going to to get, what I assume you are getting now, an overlap of the hardened edges.

    The *other* problem you may have is the normal map giving you a faceted(more so than the error explained above) look. This is actually a problem with the defaults in zmapper, not the export process. I think the proper setting is around the blend mode, but I cannot check now, I will look into it later.

    Comment


      #3
      thanks mate, will be awaiting the extra info

      Comment

      Working...
      X