Announcement

Collapse
No announcement yet.

setting mapstingers (killsounds) in UTMapMusicInfo

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    setting mapstingers (killsounds) in UTMapMusicInfo

    Hey all Just wondering if someone with some experience in setting kill sounds can help me, I have set the map music and this works okay but under "mapstingers" I wanted to set a killsound so I browsed to gong.gong01.cue and then set it as killsound by "using current selection in generic browser" it all looks good but when i cook the map and play it I have map music but no killsound. Did I have to import this file and follow the procedure for setting custom music? I presumed not as the killsound I have selected is a standard UT3 sound. Anyone have any ideas? Im trying to get a RC1 out and need these little polishing touches, please help. [EDIT] Sound for kills has come from A_Ambient_NonLoops.upk is that the problem?

    #2
    something to check - after cooking, and you open your map back up in the editor, then check the map music setup for your map and see if the CUE you selected is set.

    I think this is what's going on...

    If you use a current Map Music setup from a package, I don't think you can swap the stingers out. You'd have to create a new Map Music Setup, then assign it to your map in the WorldInfo - then you can copy the exact setup of the Map Music you want, expcept the Stingers you want to be different, then set those. Save - and you should be ready to go.

    Here is a tutorial on adding Custom Map Music - you should be able to look this over and see how to do the same, except not importing your own WAVs.

    http://www.sonicwallpaper.com/unreal...omMapMusic.htm

    hope that helps.

    Comment


      #3
      cue file stays affixed in world properties under kills in the stingers section. Thank you I checked out the tutorial. Its just the looping bit i dont get im sorry I know I did this for the last lot of music (following lord striders Tutorial) This is the part i dont get from your tutorial (under stingers " What you may want to do, is loop at a Map Music setup from one of the stock maps, and copy the MapStingers there - or just browse the pkgs in the /Sounds directory, located in the same location as the /Environments directory." <--- Mine looks like all that in fact now that ive lowered the game music a little ive even noticed the sound plays the first time you get a kill, but then nothing. Its the looping bit I dont get im sorry, do I create a new sound material of some sort and set up a new looping cue? Or is it because ive used a sound ambient_nonloop package?

      Comment


        #4
        okay I didnt follow the whole way down whoops thank you the 2nd half of your tutorial fixed something coz it works now w00t sonic wallpaper thank you. [EDIT] Hmmm it seemed to be working but now im back to square one. works once and then no more :S Anyone have any ideas

        Comment

        Working...
        X