No announcement yet.

Editor hangs forever if I try to import a custom mesh

  • Filter
  • Time
  • Show
Clear All
new posts

    Editor hangs forever if I try to import a custom mesh

    I tried importing 5 different meshes into the editor so far. The first one worked great.


    After that, even if I reboot and try to import a mesh, even into a new map, the editor starts loading and stays there forever. I can't do anything with it at all except move my mouse around on the screen. I can't even force the program to end, it's like it just ignores the End Process even from the Task Manager (which is the only thing that works, my Start menu doesn't come up at all, so I can't shut down) and I am eventually forced to do a hard reboot.

    This sucks, any clue why it's doing this to me all of the sudden?

    I can't even import a simple plane mesh with 2 tris and 4 vertex....

    Can you import this mesh:

    Tree mesh

    I just checked it and it works fine in UT3 for me. This could at least rule out, or narrow it down to, a problem with your exported meshes.


      That actually didn't work at first, but I rebooted again and it worked.... Maybe my mesh is just too complex.... I'm not 100% sure about the exact poly count, but its at least 5000... I'll have to go back and try to take out some polys and see if I can make it work.

      Weird that it was causing even simple meshes to screw up even after several reboots.

      I got another one of my meshes to import, so I pretty much narrowed it down to that one mesh.

      Thanks ffejnosliw.


        IIRC it will import meshes up to 32768 triangles (or vertices?). So I doubt that is your problem.
        Since it is a random problem even on the same mesh .ase file I would guess it to be system related.
        I have not encountered any time that meshes didn't export in two years of using UE3.


          Well, I managed to get the mesh to import finally, but I think something in that particular mesh got borked upon exporting from Blender.

          Why? Cuz there are now a few vertex that are in weird locations, effectively stretching the polys that they are attached to in weird ways. On top of that, some polys have been flipped.... Add to that, all UV Mapping was completely omitted from the mesh, I just have a very ugly Planar map that looks like it's projecting from the top.


            Yes, that does sound like an export glitch.