Announcement

Collapse
No announcement yet.

random solid black triangle in one of my brush surfaces

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    bye cleaning them I mean: snap all brushes to 32 or 64 grid. Make your CSG geometry "Clean".

    Leave a comment:


  • replied
    how do i clean CSG brushes?? i cleaned BSP materials and it said cleared 0 refrences. i know theres no whole in my geometry because i applied another material on accident before and changed it back just fine. when i go to brush wire frame all i see is a few yellow boxs that i used to subtract out doorways

    Leave a comment:


  • replied
    I see there are 2 possibilities:

    You applied wrong material - select another surface on SAME CSG brush. press Shift+B (to select all surfeces on thet brush) and apply normal rock or stone material.

    or you have CSG/BSP hole. This is a bit more complicated, because it requires you to clean CSG brushes, make them all snap to at least 32 grid.

    But to see exactly what it is going on, i need to see wireframe view of brushes, not CSG cuts view. (need one vie to the left from that).

    Best way to avoid CSG holes is to create basic map geometry in grid of 64, then fill up detail in 16 or as static meshes.

    Leave a comment:


  • replied
    for some reason that one triangle isnt getting any light on it because i can see the thexture just fine in unit view

    Leave a comment:


  • replied

    here is lighting only

    real time

    the material i accidently applied

    and wire fram without static meshes or terrain

    Leave a comment:


  • replied
    Picture of it may tell us much more. OR rather 2 pictures: one unlit 3dview one wireframe.

    Leave a comment:


  • random solid black triangle in one of my brush surfaces

    i was adding materials to some of the brushes in the level im making and i guess i accidently changed one to something i didnt want it to be, so when i changed it back and rebuilt the lighting it left me with a solid black triangle and i cant see the material. when i right click and select matching textures it says its the right material i wanted it to be but all i see is the solid black triangle

    im sorry i always post random problems like this but im basicly teaching myself to use this editor. as always i appreciate any help and feed back. thank you
Working...
X