Announcement

Collapse
No announcement yet.

Brushes not appearing in editor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Brushes not appearing in editor

    In Unreal Ed, the brushes have all of a sudden disappeared. They are there in the view that is 3D, but in the top view and in the front and side views they are not appearing anymore in brush wireframe view and I can't select them in other views. I believe this started happening after I saved it a few times ago. When I build geometry the brushes in the 3D view don't go away. What can be the problem?

    #2
    Sometimes the view flags mess up. Click on the Toggle Show Flags toolbar menu drop down and choose the "Default Show Flags". See if that helps.

    Comment


      #3
      Still not working =/
      It shows all new lighting/brushes I make, but none of the old ones... hm...
      Sorry. I am kinda a newb at this. It's my first map I've made for any game, the first time I've ever even used any editor.

      Comment


        #4
        I would be guessing without seeing the map file.
        If the brush order is incorrect and a large subtraction is inserted, that will build and remove anything inside of it.
        However, all of the brushes will usually still be visible in Brush Wireframe view.

        Start a new map and see if it does the same thing?
        It is also possible to select and copy all of the brushes from one map and paste them into another, or export/import the map as t3d.

        Comment


          #5
          I tried select all, I got nothing
          I tried exporting and Importing, I got nothing
          =/

          I see the map in all other modes, I mean it appears in normal wireframe mode
          I really don't wanna lose this map, it's my first plus I spent a good amount of time on it

          Comment


            #6
            http://s192.photobucket.com/albums/z...=screwedup.jpg
            here is a picture... wtf?
            (btw what is a better way to post pictures)

            Comment


              #7
              Click on the Brush Wireframe button to the left of what you have selected for the viewport. You are in "Wireframe" and not "Brush Wireframe" mode. There is a difference.
              Wireframe mode shows the actual final CSG geometry and not the source Add/Subtract brushes. You must be in Brush Wireframe to see the brushes.

              You can insert links to thumbnails images using the forum editor Insert Image button.

              Comment


                #8
                no but in the other 2 windows on the left I have it in brush wireframe, where you don't see anything
                I only had it in lit and normal wireframe mode to show you that it appears in all other modes but you cannot select them

                Comment


                  #9
                  Did you reset the Default Show Flags on those other viewports? Each viewport has its own independant flag settings.
                  Have you pressed the G "game mode" key at any time? That sometimes messes up the drawing setup.
                  Are you using a Shader Model 2 video card? They have issues with the editor.
                  Does a Build All work ok or is there any errors?
                  Can you add new brushes or are they invisible also?
                  What happens if you exit, restart and create a new map, are the brushes invisible there also?
                  You didn't by chance select all brushes and do a bHiddenEd on them did you?

                  Comment


                    #10
                    I did default show flags on all, no luck
                    I dunno about pressin G...
                    I am using a nvidia 8600gts, so I dont think it is shader 2...
                    I can add new brushes...
                    The other Demo maps still have their brushes
                    New maps the brushes show
                    I dunno, I don't *THINK* I did a bHiddenEd on them, I dunno what that even is

                    Comment


                      #11
                      OMG
                      I CLICKED SHOW ALL ACTORS AND THERE IT ALL IS!
                      Thanks soooo much!
                      I feel like an idiot and I'm gonna go hide now

                      Comment

                      Working...
                      X