Announcement

Collapse
No announcement yet.

Blurry Custom Textures when re-loading level

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Blurry Custom Textures when re-loading level

    Hi
    I working on a level with some custom textures
    1024X1024 DXT5

    The problem is that when i close the editor after importing them into a package and saving both the package and the level, when i reload the editor and the level, the textures are all blurry in both the editor and the game. Is their any way to stop this from happening?

    Thanks for your help!

    #2
    you can reimport the texture and it will be good temporarily untill you do the same sequence that done it in the first place... It happened to me also. This is kinda a workaround for that. Also, make sure it's not just the default thing going on here; all materials and textures are blurry until you actually click inside the generic browser.

    Comment


      #3
      Yeah refreshing them by going into the texture viewer and changing an option works for me but its such a chore every time i load up my level,

      Comment


        #4
        Its because the texture is streamed. It saves memory by loading the LODs as they are needed.

        Comment


          #5
          anyway to force it to load in fully? because it looks terrible ingame.
          NOTE: I'm applying this texture to a static mesh that already has a texture (through the materials property of the static mesh)

          Comment


            #6
            1. bForceMipStreaming

            You should not be selecting all of your map StaticMeshes and setting the bForceMipStreaming to True. The occurrence of the blurry StaticMeshes is an issue with user maps and the current game version. Setting bForceMipStreaming to True on all of the map content may have a negative impact as that function forces all texture mips to be loaded when the level is loaded, bypassing the dynamic mip streaming. On systems with smaller texture memory pools the result may be running out of pool space.
            Until Epic releases the first patch to fix this I don't recommend you do this. People experiencing blurry textures should just set the Texture Quality to 5. On systems with video adapters as old as ATI X800's you should see no performance loss at a Texture Quality setting of 5.

            i think that explains it then.

            Comment

            Working...
            X