Announcement

Collapse
No announcement yet.

Adding music and Speedtree

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Hey LordStrider,
    I made it exactly that way but always when i wanna set the music cues to the different channels (action, ambient, intro, etc.) it cant do it, says "cross package reference error!"

    Also when i would want to close the editor, it then says "sound.upk" must be safed and it wants me to choose a directory, although I safed every package of course under the map's name! Really dont see what I've done wrong!

    Leave a comment:


  • replied
    Originally posted by Làámßø View Post
    Bad news for clans who were use to having there clan tag in the map name as many were made back in 2k3/4.

    What I found is that these characters.... (), [], {}, =, ><, /\, ... just to name the more common ones used, will not be able to use for importing music using the UTMapMusic process that embeds the song into World properties as discussed above in this thread.

    So for example, these maps from my 04 map folder would not work in UT3 as of now;

    DM-(GU)-Detention_Cell-2K6
    DM-(GU)-Square_Pants_Style-2K6
    DM-(Ani)-Halloween-A-do-Over-2K6
    DM-(***)-Looking_For_Saddam-2k6
    DM-(ReZ)-@@'s-2k6
    DM-[DaTs]BackYard-2K6
    DM-Laambo's_BadMoonRising-[IG-2k6]
    DM-Laambo's_JailBreak_[IG]_-2k6
    DM-{GOD}-Bedroom

    Anyway, I think you get the point here.

    Thanks for everyone who added some good posts on this subject. We all learned little more about our new editor and some "Do's" & "Don'ts" along the way. I'm sure we'll discover more in the future as we dive deeper into this awsome program.

    Good Luck to Everyone!

    Làámßø
    Turns out this is also true for spaces (had one accidentally and didnt get to add mapinfo untill after i saved it with a underscore instead ... )

    Thanks for all the help!

    Leave a comment:


  • replied
    http://forums.epicgames.com/showthread.php?t=615033
    http://zynthetic.ambientcollapse.com...d=34&Itemid=26
    No you can't/shouldn't alter retail content. If you play the audio from the Cue it will be heard at the proper volume. You can play back from the USound but it's going to be much quieter.

    Leave a comment:


  • replied
    ok HELP. I'm trying to just get a stock music cue to work in my map - its in the info spot OK, builds with no errors and is just barely audible when played by the editor but I can't hear it at all after cooking it and I can't alter stock content?? How do they get it to work in the stock maps???

    Leave a comment:


  • replied
    Help please?
    I read the whole thread and it seems nobody had any problem with making the music volume adjustable... i can't get through this. Got a custom song and no matter what its the same volume, even if i turn of music in the ingame-options.

    Please help i'm in quite a hurry, thx in advance

    ----EDIT1----

    I think i got it. Stupid little thing
    Didn't notice this one:
    "In addition right click your Cue file and select "Sound Groups>Music". This will set your Cue as a music track."
    I'll post if it'll work

    ----EDIT2----

    OK it works
    Nevermind

    Leave a comment:


  • replied
    Read post 52 in this thread, it explains why blue triangle won't work. The editor isn't liking your map name, I'd take a wild guess that it is the space just before the word beta.

    Leave a comment:


  • replied
    bumpin this up for further discussion.

    Leave a comment:


  • replied
    DM-Facility beta
    Original wav. name: Goldeneye (OST)-4-Chemical Warfare Facility. I changed it to "mymusic".
    UTMapMusic name : facility

    Now as far as the map name is concerned, in order for the editor to except the wav. file I had to get rid of the space between Facility and beta.

    Leave a comment:


  • replied
    Originally posted by Law View Post
    yea I know I did all that. What I'm saying is the same options that you showed on the first page dont appear at all after the fact.
    Ok, copy/past your Map name, your music file .WAV name and your UTMapMusic name so we can take a look. I'm sure it's something simple.

    Leave a comment:


  • replied
    Originally posted by Làámßø View Post
    Under the main menu View > World Properties > WorldInfo look for MyMapInfo. There is a little blue triangle to the right. Click it and select UTMapInfo. It will dump a bunch of stuff in the map info area.

    The other option is UTOnslaughtMapInfo...don't pick that one.

    Once you get that to drop down your new options..go 4 down to the UTMapInfo section and click that to get to where you need to add your MapMusicInfo there.

    Go back to page 1 of this thread and follow the instruction slowly 1 by 1....you'll get it.

    Once you do it once, it's a piece of cake from there on!

    Does that help any?
    yea I know I did all that. What I'm saying is the same options that you showed on the first page dont appear at all after the fact.

    Leave a comment:


  • replied
    Originally posted by Law View Post
    Ok I got it now. But heres a new issue. When I got to world properties and press the blue triangle on mymapinfo, none of the menus appear.
    Under the main menu View > World Properties > WorldInfo look for MyMapInfo. There is a little blue triangle to the right. Click it and select UTMapInfo. It will dump a bunch of stuff in the map info area.

    The other option is UTOnslaughtMapInfo...don't pick that one.

    Once you get that to drop down your new options..go 4 down to the UTMapInfo section and click that to get to where you need to add your MapMusicInfo there.

    Go back to page 1 of this thread and follow the instruction slowly 1 by 1....you'll get it.

    Once you do it once, it's a piece of cake from there on!

    Does that help any?

    Leave a comment:


  • replied
    I'm having the completely opposite problem of what this thread has covered so far. My music won't STOP looping. I'm trying to get the dynamic music working so I split my song into 5 loop clips for the 6 dynamic fields (Intro, Ambient, Action, Tension, Suspense, & Victory)
    If I have a loop node in the cue set to indefinite, thats exactly what it does and will never switch past the intro no matter whats happening to the player.
    If the loop node is not set to indefinite, it will loop so many times then stop without switching to ambient, etc.
    The farthest I've gotten to getting this working is
    Intro - no loop node - plays once then switches to ambient.
    Ambient - loop node - doesn't switch to action when it should but will eventually.
    Action - NEVER stops looping no matter what.
    Tension - Never plays
    Suspense - Never plays
    Victory - Never plays
    I'm not even sure what situation the player is supposed to be in to trigger tension and suspense music, but I assumed that victory would play when you won the match but it never does.
    Anyway, if anyone knows how this is supposed to work let me know.
    I spent all that time cutting the song up into perfect loops and now it looks like I'm just going to have to use the uncut song which I could have done in the first place.

    Leave a comment:


  • replied
    Ok I got it now. But heres a new issue. When I got to world properties and press the blue triangle on mymapinfo, none of the menus appear.

    Leave a comment:


  • replied
    Originally posted by Law View Post
    When I try to import music in my package, I keep getting a message saying: Import failed for "map name": Name contains an invalid character:[].

    What am I doing wrong.
    You have an invalid character!

    Take a look at your file name, you must have a space? or a non-alpha/numeric character....a,b,c,d....1,2,3.....only use those to be safe.

    Dashes "-" or underscores "_" will work if your looking to "space" words.

    Leave a comment:


  • replied
    When I try to import music in my package, I keep getting a message saying: Import failed for "map name": Name contains an invalid character:[].

    What am I doing wrong.

    Leave a comment:

Working...
X