Announcement

Collapse
No announcement yet.

Adding music and Speedtree

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #61
    I figured it out. It saves and compresses the upk file seperately so I upload them both. Karma you have any troubles with the {AW} map package? Ever since beta 4 it quit, so I moved the upk for that into the folder above CustomMaps and it works fine now. But I could have sworn it was working where it was before beta 4.

    Comment


      #62
      The speedtree thing I'm trying to workout myself and will post here once i do. Unreal 2.x used .spt files generated from speedtree CAD so at the very least you'd need to have a legit speedtree file to use and I haven't seen any in the UT3 directory's. For the guy who keeps asking what it is try

      http://www.speedtree.com

      The demo of speedtree integration with the Unreal runtime engine found here

      http://download.beyondunreal.com/fil...tree_unreal_de
      moinstaller.zip

      has a trees folder in the system folder that has a few example spt file and you'd need the corresponding texture packages to make it work. I've tried with no success yet in UT3.

      Comment


        #63
        Shawj, but maybe we can copy speedtree from Epic's package to our package and edit it there?

        I've tried everything, but when I want to save my map and package I have the same error :/

        Comment


          #64
          Originally posted by LordStrider View Post
          Karmatized are you sure it will play once? I sat through at least three iterations of my song looping....I did not care to wait 16 times as 4 minutes times 16 was well over an hour and I doubt a map would run that long. If it did I might fall asleep.

          I'm not doubting you, just inquiring that the concurrent count will not work...I suppose it could be upped from 16 to 32. Then you would be at about two hours a map for 4 minute track. Although I could see a 1 minute track would not work well under this instance.

          It would probably make more sense to loop it forever.
          The MaxConcurrentPlayCount has nothing to do with looping. It simply determines the number of times this specific sound can be playing at the same time. Using a Looping node in the SoundCue is the correct way to loop a sound.

          Comment


            #65
            When I try to import music in my package, I keep getting a message saying: Import failed for "map name": Name contains an invalid character:[].

            What am I doing wrong.

            Comment


              #66
              Originally posted by Law View Post
              When I try to import music in my package, I keep getting a message saying: Import failed for "map name": Name contains an invalid character:[].

              What am I doing wrong.
              You have an invalid character!

              Take a look at your file name, you must have a space? or a non-alpha/numeric character....a,b,c,d....1,2,3.....only use those to be safe.

              Dashes "-" or underscores "_" will work if your looking to "space" words.

              Comment


                #67
                Ok I got it now. But heres a new issue. When I got to world properties and press the blue triangle on mymapinfo, none of the menus appear.

                Comment


                  #68
                  I'm having the completely opposite problem of what this thread has covered so far. My music won't STOP looping. I'm trying to get the dynamic music working so I split my song into 5 loop clips for the 6 dynamic fields (Intro, Ambient, Action, Tension, Suspense, & Victory)
                  If I have a loop node in the cue set to indefinite, thats exactly what it does and will never switch past the intro no matter whats happening to the player.
                  If the loop node is not set to indefinite, it will loop so many times then stop without switching to ambient, etc.
                  The farthest I've gotten to getting this working is
                  Intro - no loop node - plays once then switches to ambient.
                  Ambient - loop node - doesn't switch to action when it should but will eventually.
                  Action - NEVER stops looping no matter what.
                  Tension - Never plays
                  Suspense - Never plays
                  Victory - Never plays
                  I'm not even sure what situation the player is supposed to be in to trigger tension and suspense music, but I assumed that victory would play when you won the match but it never does.
                  Anyway, if anyone knows how this is supposed to work let me know.
                  I spent all that time cutting the song up into perfect loops and now it looks like I'm just going to have to use the uncut song which I could have done in the first place.

                  Comment


                    #69
                    Originally posted by Law View Post
                    Ok I got it now. But heres a new issue. When I got to world properties and press the blue triangle on mymapinfo, none of the menus appear.
                    Under the main menu View > World Properties > WorldInfo look for MyMapInfo. There is a little blue triangle to the right. Click it and select UTMapInfo. It will dump a bunch of stuff in the map info area.

                    The other option is UTOnslaughtMapInfo...don't pick that one.

                    Once you get that to drop down your new options..go 4 down to the UTMapInfo section and click that to get to where you need to add your MapMusicInfo there.

                    Go back to page 1 of this thread and follow the instruction slowly 1 by 1....you'll get it.

                    Once you do it once, it's a piece of cake from there on!

                    Does that help any?

                    Comment


                      #70
                      Originally posted by Làámßø View Post
                      Under the main menu View > World Properties > WorldInfo look for MyMapInfo. There is a little blue triangle to the right. Click it and select UTMapInfo. It will dump a bunch of stuff in the map info area.

                      The other option is UTOnslaughtMapInfo...don't pick that one.

                      Once you get that to drop down your new options..go 4 down to the UTMapInfo section and click that to get to where you need to add your MapMusicInfo there.

                      Go back to page 1 of this thread and follow the instruction slowly 1 by 1....you'll get it.

                      Once you do it once, it's a piece of cake from there on!

                      Does that help any?
                      yea I know I did all that. What I'm saying is the same options that you showed on the first page dont appear at all after the fact.

                      Comment


                        #71
                        Originally posted by Law View Post
                        yea I know I did all that. What I'm saying is the same options that you showed on the first page dont appear at all after the fact.
                        Ok, copy/past your Map name, your music file .WAV name and your UTMapMusic name so we can take a look. I'm sure it's something simple.

                        Comment


                          #72
                          DM-Facility beta
                          Original wav. name: Goldeneye (OST)-4-Chemical Warfare Facility. I changed it to "mymusic".
                          UTMapMusic name : facility

                          Now as far as the map name is concerned, in order for the editor to except the wav. file I had to get rid of the space between Facility and beta.

                          Comment


                            #73
                            bumpin this up for further discussion.

                            Comment


                              #74
                              Read post 52 in this thread, it explains why blue triangle won't work. The editor isn't liking your map name, I'd take a wild guess that it is the space just before the word beta.

                              Comment


                                #75
                                Help please?
                                I read the whole thread and it seems nobody had any problem with making the music volume adjustable... i can't get through this. Got a custom song and no matter what its the same volume, even if i turn of music in the ingame-options.

                                Please help i'm in quite a hurry, thx in advance

                                ----EDIT1----

                                I think i got it. Stupid little thing
                                Didn't notice this one:
                                "In addition right click your Cue file and select "Sound Groups>Music". This will set your Cue as a music track."
                                I'll post if it'll work

                                ----EDIT2----

                                OK it works
                                Nevermind

                                Comment

                                Working...
                                X