Announcement

Collapse
No announcement yet.

Special meshes not getting lit

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Special meshes not getting lit

    I'm trying to place a static mesh in my map as an InterpActor to make an elevator with, and even when the map is lit the mesh shows up as solid black in the editor and game. It also does this when I place it as a UTTeamStaticMesh or Mover as well, but it displays properly as a regular static mesh. I've opened other maps to see if the same thing happens in them, and it does it on some of them as well, including ShangriLa and probably other retail maps, but not on certain others, like Deck. I'm baffled as to what could be causing this and would appreciate the help, thanks.

    #2
    The problem is in the engines capability to light the object correctly by vertex.... you might know this by "vertex lighting" all it is is pretty much if your object has a large planar surface (i.e. a large piece of wall) and it does not have the functionality of static lighting (such as an ambient oclussion map) then the light source will use a vertice in the mesh to bounce off light to its surface and other vertices ans so on.

    Ergo, if you do NOT have an ambient occlusion map (static lighting) the engine will relly on "vertex Ligthing" (Dynamic Lighting) to light any given mesh or mesh section. This will result in your mesh looking completly black, because not enough vertices are in the mesh.

    Now a very simple solution to this is to fix yout 3D model by Tesselating it more the it is on its large planar surfaces.. import back with your collision model and boom. However, if this is happening to an already existing mesh, try to re apply its corresponding mterial.... also check the nodes... make sure things are were they are supposed to be if not you might need to make a new material just for that mesh, using its existing texture.

    Comment


      #3
      if its a dynamic object, try making the lights that surround it emit light to the dynamic light channel (just select the light, open they're properties and check the ambient lighting checkbox.) that should light your InterPactors

      Comment


        #4
        Originally posted by Hyperforce View Post
        if its a dynamic object, try making the lights that surround it emit light to the dynamic light channel (just select the light, open they're properties and check the ambient lighting checkbox.) that should light your InterPactors
        That fixed it up instantly. Thank you very much!

        Comment

        Working...
        X