Announcement

Collapse
No announcement yet.

XS Vehicles

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    Originally posted by 2B=M View Post
    There still don't seem to be plans for any scorpion/manta replacement vehicles. Small fast disposable things, you know?
    We're fighting a natural tendency to produce big vehicles... We made them as small as we could already.

    I had plans for a small monowheel with layz0r grappling hooks and a self-destruct mechanism. Some patch broke it, and I didn't have time to get it into shape. Maybe later. It would make a good Scorpion replacement.

    Comment


      #47
      Originally posted by iced-fang View Post
      ok i tested out the vehicles finally but i can only select the harpy and the basilisk what happened here
      Did you install the prototypes?

      Comment


        #48
        Originally posted by Dark_Slayer View Post
        No muts at all and I tried to summon it without success.
        Originally posted by ElfjeTwaalfje View Post
        Same problems here. As soon as I start a map I have a crash to the desktop. I run with the -nohomedir option.
        Originally posted by Tombot View Post
        I'm having the crashing problem that others are having
        Am I correct in that you all have some sort of nonstandard installation? Not that that should be a problem... it should work for everyone, of course. Just wondering if that could be related to the problem.

        Comment


          #49
          Hi Xyx, I am aware that using -nohomedir demands caution when installing mods etc. Tell me what you need and maybe I can provide the info. What is different between Harpy 1.0 and this MSU4 release. The 1.0 works without a problem. To prefent problem with a custom map I test on Avalanche.

          Comment


            #50
            Again I wish to state that my version of UT3 has been downloaded from steam. and that the previous version worked fine.

            Comment


              #51
              Originally posted by 2B=M View Post
              Superb work! These look amazing!

              On a side note. There still don't seem to be plans for any scorpion/manta replacement vehicles. Small fast disposable things, you know?
              Yeah, the vehicles you currently have are great, but are kind of slow and hard to drive. I'd like to see some vehicles that are fast and/or so absurd (like a scavenger) that you can just mess around with for fun (like a scorpion).

              Comment


                #52
                Hey Xyx,
                I have the retail version of UT3 and didnt change anything in important files at all.
                What do you mean with a "nonstandard installation" ? please be more specific.
                I just installed the game with the install setup like any other game and patched it.

                Comment


                  #53
                  When I get more time I'll try to upload some simplified versions of the mod. Maybe that way we can figure out what the showstopper is. If any of you gentlemen are available on MSN, ICQ or AIM, please PM me your contact info.

                  Originally posted by ElfjeTwaalfje View Post
                  What is different between Harpy 1.0 and this MSU4 release.
                  Many small tweaks, mostly the visual effects.

                  Do you experience any weirdness if you don't enable any of the mutators and summon the Behemoth?

                  summon xs_behemoth.behemoth

                  Originally posted by Dark_Slayer View Post
                  I have the retail version of UT3 and didnt change anything in important files at all.
                  If other mods work for you then you probably didn't do anything wrong.

                  Comment


                    #54
                    Originally posted by Superking17 View Post
                    the vehicles you currently have are great, but are kind of slow and hard to drive. I'd like to see some vehicles that are fast and/or so absurd (like a scavenger) that you can just mess around with for fun (like a scorpion).
                    I'd really love these vehicles to be "just fun to mess around with", so please tell me what you think is needed for that.

                    Here's my reasoning for why they are what they are:

                    They'd be pretty uber if they were heavily armed, heavily armored and fast. They're not Mantas; they're bigger and stronger, so they should also be slower. I kept firepower to the bare minimum required for the concept to work (bombs that don't kill people are no fun), limited armor to the minimum appropriate for their size and gave each vehicle the maneuverability that fits with its role and appearance.

                    Comment


                      #55
                      Originally posted by Xyx View Post
                      Do you experience any weirdness if you don't enable any of the mutators and summon the Behemoth?

                      summon xs_behemoth.behemoth

                      If other mods work for you then you probably didn't do anything wrong.
                      Well the point is I can't start a map. This is what I do: I select the XS vehicle mutator, select a profile, start the map and then UT3 crashes to desktop. So no time to summon anything.

                      Comment


                        #56
                        Try NOT selecting the mutators. You should be able to summon the vehicles anyway. If you use the mutators, and the problem is in a specific mutator or vehicle, you will always crash. But if you do not use the mutators, you might be able to summon some of the vehicles without crashes. For instance, the Cyclops does not use any custom art at all. It is all Epic's art with just custom code. It is probably the art that is causing the crashes, since code is pretty much the same for everyone.

                        Comment


                          #57
                          Ok, yesterday I did some major cleaning of all ini files because I found some out-of-the ordinary launch.log entries, mainly for custom characters. Once these were out of the way, the XS vehicles loaded Thanks for sticking with me.

                          Comment


                            #58
                            Originally posted by ElfjeTwaalfje View Post
                            Ok, yesterday I did some major cleaning of all ini files because I found some out-of-the ordinary launch.log entries, mainly for custom characters. Once these were out of the way, the XS vehicles loaded Thanks for sticking with me.
                            Could you give a more specific explanation ? Maybe your solution could help me ^^

                            What should I check in my Launch.log ? I have also some customchars, muts and gametypes, maybe something is not right with it and causes problems.

                            Comment


                              #59
                              Originally posted by Dark_Slayer View Post
                              Could you give a more specific explanation ? Maybe your solution could help me ^^

                              What should I check in my Launch.log ? I have also some customchars, muts and gametypes, maybe something is not right with it and causes problems.
                              Long post ahead .
                              This is what I could retrace, can't tell if it mattered, all I know some of it did somehow. And a clean system is worth something right?
                              Allways backup your ini files prior to changing them.

                              In launch.log in UTGame\Logs I found this:
                              Init: Machine detected compatibility level: Composite: 4. CPU: 5. GPU: 4.
                              Init: Previous detected compatibility level: Composite: 4. CPU: 4. GPU: 4.

                              I changed UTEngine.ini in UTGame\Config accordingly
                              [AppCompat]
                              MeasuredCPUScore=446.728333
                              CompatLevelComposite=4
                              CompatLevelCPU=5
                              CompatLevelGPU=4

                              Found this one in launch.log:
                              Log: - CH_DHGargoyle_Male
                              Log: Flushing async loaders.
                              Critical: appError called:
                              Critical: Couldn't find file for package CH_DHGargoyle_Male requested by async loading code.
                              Critical: Windows GetLastError: Het systeem kan het opgegeven bestand niet vinden. (2)
                              Log: === Critical error: ===
                              Couldn't find file for package CH_DHGargoyle_Male requested by async loading code.
                              RaiseException() Address = 0x7c7e2afb (filename not found)
                              CxxThrowException() Address = 0x78158e89 (filename not found)
                              Address = 0xbb4f92 (filename not found)
                              Address = 0xe8781b4c (filename not found)

                              Deleted all lines with CH_DHGargoyle_Male from CustomChar.ini in UTGame\Config because the files of the Gargoyle were deleted earlier.

                              Found this:
                              Log: Part Texture: 'Ch_Demon.Materials.Torso_Normal' (MIC: 'Ch_Demon.Materials.M_Torso') in incorrect TEXTUREGROUP (1)
                              Log: Part Texture: 'Ch_Demon.Materials.Torso_Normal' (MIC: 'Ch_Demon.Materials.M_Torso') in incorrect TEXTUREGROUP (1)
                              Log: Part Texture: 'Ch_Demon.Materials.Torso_Normal' (MIC: 'Ch_Demon.Materials.M_Torso') in incorrect TEXTUREGROUP (1)
                              Log: Part Texture: 'Ch_Demon.Materials.Torso_Normal' (MIC: 'Ch_Demon.Materials.M_Torso') in incorrect TEXTUREGROUP (1)
                              Log: No Textures Found For: BODY Texture: 1

                              Uninstalled Demogorgon Beta 1 accordingly. Tip for character removal: goto the character folder (example Fate) UTGame\Published\CookedPC\CustomChars\Fate. There is a file named UTCustomChar.ini. Open it and replace all + by -. Save the file, start up UT3 and all Fate entries are removed from UTCustomChar.ini, the UTGame\Config one. Delete the other Fate files, I don't know if this is required. I did it for the Demogorgon.

                              Thats it. Then I removed the old Harpy 1.0, installed the new XS vehicles, used the proper mutator, all worked.

                              Comment


                                #60
                                Originally posted by Xyx View Post
                                Did you install the prototypes?
                                nope im guessing that is why none of the other are showing up.
                                By the way when i was testing them i found out it was really annoying that every time u get out of a vehicle and get back in it later or when u die and get in it later a tutorial shows up over and over and OVER AGAIN!!!
                                i get it the first time why do i need to see it again.

                                Comment

                                Working...
                                X