Announcement

Collapse
No announcement yet.

MutatorLoader v1.5[RC]

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by JD8 View Post
    Well I thought I had it figured out but there's a snag. I added BomingRun as a gametype and added this to the UTMapLoader.ini

    Code:
    [BombingRun.UTBRGame MLConfigProfile]
    Mutators=SpectatorMutev02.SpecMute
    Mutators=ServerAdverts.ServerAdverts
    Mutators=utcomp3v031.UTMutator_utcomp3v031
    Mutators=TalkingIcon.TalkingIconMut
    Mutators=AWInstagib.AWInstagib
    Mutators=MutDodgeJump.MutDodgeJump
    ;DelayedMutators=
    bSimulateInitMutator=False
    However it doesn't seem to use my mutators from this gametype. The only way I can get the mutators to load for BR is to add them in the UTMapLists.ini. That will get BR running ok but when I vote back to another gametype I lose the mutators for the gametype I voted for. This only happens after I first vote for BR, after that gametypes all have stock setup. Now I do know Warhead will be coming out with a new version of BR this weekend and maybe that's the problem but I was wondering if adding that gametype to the UTMapLoader.ini just won't work?
    Have you made a Gameprofile for BR in the Webadmin and selected MutatorLoader to load?

    once done it will add it to the Utmaplist.ini

    Leave a comment:


  • replied
    Well I thought I had it figured out but there's a snag. I added BomingRun as a gametype and added this to the UTMapLoader.ini

    Code:
    [BombingRun.UTBRGame MLConfigProfile]
    Mutators=SpectatorMutev02.SpecMute
    Mutators=ServerAdverts.ServerAdverts
    Mutators=utcomp3v031.UTMutator_utcomp3v031
    Mutators=TalkingIcon.TalkingIconMut
    Mutators=AWInstagib.AWInstagib
    Mutators=MutDodgeJump.MutDodgeJump
    ;DelayedMutators=
    bSimulateInitMutator=False
    However it doesn't seem to use my mutators from this gametype. The only way I can get the mutators to load for BR is to add them in the UTMapLists.ini. That will get BR running ok but when I vote back to another gametype I lose the mutators for the gametype I voted for. This only happens after I first vote for BR, after that gametypes all have stock setup. Now I do know Warhead will be coming out with a new version of BR this weekend and maybe that's the problem but I was wondering if adding that gametype to the UTMapLoader.ini just won't work?

    Leave a comment:


  • replied
    Got it all sorted out. Woot!

    Leave a comment:


  • replied
    Originally posted by dave neun View Post
    can you post your ini?
    have only set it up for Warfare and Greed ATM


    UTMutatorLoader.ini
    Code:
    [MLMut UTUIDataProvider_Mutator]
    ClassName=MutatorLoader.MLMut
    FriendlyName=
    Description=.ini based mutator loader
    GroupNames=
    UIConfigScene=
    bStandaloneOnly=False
    bRemoveOn360=False
    bRemoveOnPC=False
    bRemoveOnPS3=False
    BitValue=0
    
    [MutatorLoader.MLMut]
    bPerGameTypeConfig=true
    bAutoCreateGameTypeConfig=True
    bDontAdvertiseMutator=False
    
    [default MLConfigProfile]
    ;Mutators=UTGame.UTMutator_Instagib
    ;DelayedMutators=UTGame.UTMutator_LowGrav
    bSimulateInitMutator=True
    
    [UTDeathmatch MLConfigProfile]
    ;Mutators=UTGame.UTMutator_Instagib
    ;DelayedMutators=UTGame.UTMutator_LowGrav
    bSimulateInitMutator=True
    
    [UTTeamGame MLConfigProfile]
    ;Mutators=UTGame.UTMutator_Instagib
    ;DelayedMutators=UTGame.UTMutator_LowGrav
    bSimulateInitMutator=True
    
    [UTCTFGame_Content MLConfigProfile]
    ;Mutators=UTGame.UTMutator_Instagib
    ;DelayedMutators=UTGame.UTMutator_LowGrav
    bSimulateInitMutator=True
    
    [UTVehicleCTFGame_Content MLConfigProfile]
    ;Mutators=UTGame.UTMutator_Instagib
    ;DelayedMutators=UTGame.UTMutator_LowGrav
    bSimulateInitMutator=True
    
    [UTOnslaughtGame_Content MLConfigProfile]
    Mutators=ServerAdvertsInt.UTMutator_ServerAdvertsInt
    Mutators=SpectatorMutev03.SpecMute
    Mutators=TitanTeamFixUT3.TTeamFixMut
    bSimulateInitMutator=True
    
    [UTDuelGame MLConfigProfile]
    ;Mutators=UTGame.UTMutator_Instagib
    ;DelayedMutators=UTGame.UTMutator_LowGrav
    bSimulateInitMutator=True
    
    [UTBetrayalGame MLConfigProfile]
    ;Mutators=UTGame.UTMutator_Instagib
    ;DelayedMutators=UTGame.UTMutator_LowGrav
    bSimulateInitMutator=True
    
    [UTGreedGame_Content MLConfigProfile]
    Mutators=ServerAdvertsInt.UTMutator_ServerAdvertsInt
    Mutators=SpectatorMutev03.SpecMute
    Mutators=TitanTeamFixUT3.TTeamFixMut
    bSimulateInitMutator=True

    Leave a comment:


  • replied
    Originally posted by JD8 View Post
    Is there a way to keep mutators from carrying over from one gametype to the next? I notice the new maplists.ini has a section in the gametype configs to exclude mutators but with mutatorloader running that doesn't seem to work. Without mutatorloader I don't show up in the browser lists. Damned if I do and if I don't. Arrrg.
    Mutators which aren't on (or added to, e.g. by the maplist manager) the commandline shouldn't carry over; do you have mutators (other than MutatorLoader) set in UTMapLists.ini?

    Leave a comment:


  • replied
    can you post your ini?

    Leave a comment:


  • replied
    Originally posted by dave neun View Post
    do you have any mutes listed in this section of the ini

    Code:
    [default MLConfigProfile]
    ;Mutators=UTGame.UTMutator_Instagib
    ;DelayedMutators=UTGame.UTMutator_LowGrav
    bSimulateInitMutator=True
    just fishin is all but maybe it is overriding others if so?

    I thought of that already but it's good to know we're on the same track. Yes I have the same mutators there as my DM. Our default gametype is DM and if I take the default mutators out of the mutatorloader.ini I get only stock settings in the game. I thought maybe that was ok cause the first time I voted for DM the DM mutators would kick in but they didn't. So long story short the default mutators have to be there or I get nothing at all.

    Leave a comment:


  • replied
    do you have any mutes listed in this section of the ini

    Code:
    [default MLConfigProfile]
    ;Mutators=UTGame.UTMutator_Instagib
    ;DelayedMutators=UTGame.UTMutator_LowGrav
    bSimulateInitMutator=True
    just fishin is all but maybe it is overriding others if so?

    Leave a comment:


  • replied
    Originally posted by dave neun View Post
    Could have sworn I read something in the MutatorLoader readme addressing individual gametypes.. it was late though I'll look again.. lol second glance Looks like a no go. at least v1




    this is for v1.5
    I have all the mutators setup per gametype in the mutatorloader.ini but when I switch to another gametype in-game, mutators from the last played gametype travel over into the next gametype. I thought the mutator exclusion section in the maplists.ini would correct the situation but it seems to have no effect.

    Leave a comment:


  • replied
    Originally posted by JD8 View Post
    Is there a way to keep mutators from carrying over from one gametype to the next? I notice the new maplists.ini has a section in the gametype configs to exclude mutators but with mutatorloader running that doesn't seem to work. Without mutatorloader I don't show up in the browser lists. Damned if I do and if I don't. Arrrg.
    Could have sworn I read something in the MutatorLoader readme addressing individual gametypes.. it was late though I'll look again.. lol second glance Looks like a no go. at least v1

    Originally posted by Shambler
    Can also load different sets of mutators per-gametype

    this is for v1.5 - actually looking at it it is set up very nicely try 1.5.. I need to update lol

    Leave a comment:


  • replied
    Is there a way to keep mutators from carrying over from one gametype to the next? I notice the new maplists.ini has a section in the gametype configs to exclude mutators but with mutatorloader running that doesn't seem to work. Without mutatorloader I don't show up in the browser lists. Damned if I do and if I don't. Arrrg.

    Leave a comment:


  • replied
    Well what can I say - Great work yet again Shambler

    Epic should have you working for them full time

    and

    <Zofo> takes an irishman to sort out epics xxxx

    Leave a comment:


  • replied
    Shambler I have been pulling my hair out for a few days now trying to get my server back into the browser. I have tried a million things and a friend suggested I try this mute which I honestly did not think I would need but it has gotten my server back in the browser.

    see thread: http://forums.epicgames.com/showthread.php?t=664731

    This has only been an issue since 2.0 and my mutes have all been compiled on 2.0 but still just wasn't showing up.

    anyways thanks for this... you gotta new fan..lol

    d9

    Leave a comment:


  • replied
    Originally posted by Xyx View Post
    That sounds great, and I wish I had it a year ago. However, isn't the Titan patch supposed to make this obsolete?
    Yep it does; though not it's original purpose, this is only useful if you have so many mutators running, that the server doesn't show up.
    That's caused by GameSpy limiting the total size of the server details; any mutators loaded through this mutator, don't show up in the server details.

    I should've added that info the the original post

    Leave a comment:


  • replied
    That sounds great, and I wish I had it a year ago. However, isn't the Titan patch supposed to make this obsolete?

    Leave a comment:

Working...
X