Announcement

Collapse
No announcement yet.

Utility to allow hosting UT3 games with simple (or no) router,firewall, NAT config

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    I have the same problem

    Leave a comment:


  • replied
    Originally posted by questionman View Post
    Go to www.pcconfig.com, They have a port forwarding program that you can try.
    Not really, your link doesn't work!

    Leave a comment:


  • replied
    Go to www.pcconfig.com, They have a port forwarding program that you can try.

    Leave a comment:


  • replied
    I have been trying to get ut3 to host games for hours and still no luck, I port forwarded all the required ports, running this utility. But still nothing...

    Still thx for the effort Benfica.

    Too Bad a million dollar company like Epic can't even figure out how to make a decent client/server solution for UT3.

    UT3 should have been huge, but thx to crappy client/server code for UT3 the game dies an ungratefull death...

    Shame on you Epic!

    Leave a comment:


  • replied
    I've got this error;


    And problably this is why i'm not getting this working. =/

    I'm not able to host a campaign/mp server...

    Leave a comment:


  • replied
    It says "Could not find utengine.ini path".
    Looks like it does not work with the "-nohomedir" parameter. If only I could tell it that the files are in the UT folder...

    Leave a comment:


  • replied
    No luck here. All the the right ports forwarded.
    Looks like pingfreak's pic. Friend can't join game on invite.
    Linksys WAG200G

    Leave a comment:


  • replied


    I've opened all ports mentioned ... Still no go. It looks like it's running fine.. but
    I can't see it advertised.

    Here is a simple enough command line I'm using..

    Code:
    @echo off
    :SERVER
    UT3.exe Server 
    DM-HeatRay?bShouldAdvertise=True?bIsLanMatch=False?bIsDedicated=True?GoalScore=35?TimeLimit=20?game=UTGame.UTDeathmatch -Login=***** -Password=*****
    goto SERVER

    Leave a comment:


  • replied
    Originally posted by Sincreator View Post
    I am definitly going to try this out. So if something goes wrong, I just delete the ini, and let the game remake it? Will this affect anyone else on the network, or will it just happen on my computer? Cab you open the nessesary ports, with this program? Or do I have to do it from the router myself?
    Hey The utility does this only once:
    * Searches for your utengine.ini and creates a copy called utengine_bkspun.ini (a typo here)
    * Appends this text:
    [OnlineSubsystemGameSpy.OnlineSubsystemGameSpy]
    StunServerAddress=localhost


    Everytime you start ut3personalserver.exe, it creates a proper commandline to invoke stunserver.exe and leaves it running.

    It doesn't affect anybody else on the network, except that you must redirect these particular ports to the PC where you want to host

    On my case, I still needed to open UDP ports 7777,6500,13000 and 27900 on my router. My utility just recreated the tutorial, and stunserver.exe takes care of the communication.
    Just take a look at the screenshot of my router page included on the zip, open those ports and start the exe.

    Good luck and post feedback. Very important: describe how far you can go. I'll see what needs to be fixed

    Leave a comment:


  • replied
    I am definitly going to try this out. So if something goes wrong, I just delete the ini, and let the game remake it? Will this affect anyone else on the network, or will it just happen on my computer? Cab you open the nessesary ports, with this program? Or do I have to do it from the router myself?

    Leave a comment:


  • replied
    Yeah I cant start a internet server for the life of me, I mean I tried enabling every port listed on every site and its still a no go. Its just not getting the signal out of my local network, would help if gamespy would stay up...

    http://portforward.com/english/route...urnament_3.htm

    Gone over guides like this many times, searched about the modem and used this thingo. Still 0 luck, maybe its just in the commandline settings or somethin, I dunno hey Im about ready to call it quits and not even bother wasting my time anymore. I swear its cause Im probably routing all the ports in one direction, is that inbound/outbound or what?

    Leave a comment:


  • replied
    nope no luck yet those ports didnt do anything

    Leave a comment:


  • replied
    to fix server not showing in the browser you need to open ports 41920 - 67553 upd i belive, works for me.

    Leave a comment:


  • replied
    weird thing this still hasnt fix my issue with players seeing the server on the list

    Leave a comment:


  • replied
    Small fix. And to mention that I don't have the game ports open on my router, so I really didn't need to change any configuration

    Leave a comment:

Working...
X