Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

UT3 Converter2 - 0.25c / UT4 Converter 0.4.1

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    this doesnt work for UT99, i just get alot of errors after importing the converted t3d file, and UE3 just freezes.

    Comment


      Originally posted by Andeh View Post
      this doesnt work for UT99, i just get alot of errors after importing the converted t3d file, and UE3 just freezes.
      Maybe not but you can always port UT99 to UT2004 by hand, and then use this tool to bring it to UT3. Although I doubt any tool would be able to replicate the results of porting by hand with a fine tooth comb. For example, here is my port of Pressure from UT99 for UT2004:
      http://www.unrealplayground.com/foru...o=file&id=6682

      All original meshes, sounds, BSP, textures (the highres S3TC ones), working triggered pressure volume and everything. Only thing that I was unable to do was the little smoke chimney on top of the pressure chamber, but I'm sure it's an easy addition and you don't need my permission to go ahead and do what you want with this map.

      Comment


        I get an error when I try to download:

        Forbidden
        You don't have permission to access /forum/index.php on this server.

        Apache/1.3.39 Server at www.ut3x.com Port 80


        Wth? Really wanna try this!

        Comment


          Its down, you'll need a new link.

          Anyway I'm trying to use the latest .22 version and I get this error when I try to run it:
          Code:
          Exception in thread "main" java.lang.NoClassDefFoundError: C:\Documents and Sett
          ings\Andrew\Desktop\UT3Converter-v0/22\UT3Converter/jar
          Caused by: java.lang.ClassNotFoundException: C:\Documents and Settings\Andrew\De
          sktop\UT3Converter-v0.22\UT3Converter.jar
                  at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
                  at java.security.AccessController.doPrivileged(Native Method)
                  at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
                  at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
                  at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:276)
                  at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
                  at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
          Anybody know what the problem is? I have the latest JDK, 1.6u5 x64 version on XP x64.

          Comment


            could someone plz upload version 0.22 to filefront and post the link here? website of the author is down since a few days now and i need to port some staticmeshes from ut2004 to ut3
            i havent found any alternativ download but there should be no reason against any alternative download-mirrors...

            [edit]
            @ martinblank
            you need to create a batchfile to start this program...
            go to the directory of ut3converter, rightklick-> new->Textfile and enter
            Code:
            java -jar "UT3Converter.jar"
            .. and save file as ut3converter.bat, then start it

            Comment


              OH MY GOD
              is really possible something like this?

              Comment


                Originally posted by aLeX View Post
                could someone plz upload version 0.22 to filefront and post the link here? website of the author is down since a few days now and i need to port some staticmeshes from ut2004 to ut3
                i havent found any alternativ download but there should be no reason against any alternative download-mirrors...

                [edit]
                @ martinblank
                you need to create a batchfile to start this program...
                go to the directory of ut3converter, rightklick-> new->Textfile and enter
                Code:
                java -jar "UT3Converter.jar"
                .. and save file as ut3converter.bat, then start it
                Thank you, that worked! Here, I uploaded it:
                http://www.mediafire.com/?j00pjp9x11h

                Comment


                  I'm having the same problems as someone else here before. When i have ported the map (after properly importing all textures, converted them to materials and importing the static meshes) the static meshes don't show up in the map. I've read the entire topic and was unable to find a solution. My exact steps:

                  1. Port with program to UT3Maps.
                  2. Open UT3 editor.
                  3. Create substractive map.
                  4. Save it as CTF-FaceClassic (that's the map i wanna port).
                  5. Import all textures from UT3Maps/Textures to a package called CTF-FaceClassic.
                  6. Create materials out of all textures and activated the, so that you can see a sphere with the texture around it.
                  7. Import all static meshes from UT3Maps/Static Meshes (they show up in the generic browser with the correct texture).
                  8. Import the map into existing map.

                  And everything works, except the static meshes. And when i press play from here in the level the editor closes itself after an error. What's my problem.

                  Comment


                    Is a new update coming anytime soon?

                    Comment


                      You can also find it here, http://hosted.filefront.com/aCruceSalus/

                      Comment


                        Originally posted by [NBS]KnightHawk View Post
                        Is a new update coming anytime soon?
                        Development of the program is on hold for the moment (paused).

                        Originally posted by R420R View Post
                        I'm having the same problems as someone else here before. When i have ported the map (after properly importing all textures, converted them to materials and importing the static meshes) the static meshes don't show up in the map. I've read the entire topic and was unable to find a solution. My exact steps:

                        1. Port with program to UT3Maps.
                        2. Open UT3 editor.
                        3. Create substractive map.
                        4. Save it as CTF-FaceClassic (that's the map i wanna port).
                        5. Import all textures from UT3Maps/Textures to a package called CTF-FaceClassic.
                        6. Create materials out of all textures and activated the, so that you can see a sphere with the texture around it.
                        7. Import all static meshes from UT3Maps/Static Meshes (they show up in the generic browser with the correct texture).
                        8. Import the map into existing map.

                        And everything works, except the static meshes. And when i press play from here in the level the editor closes itself after an error. What's my problem.
                        It seems to be correct. No idea for the moment why it doesn't work (will have to look into this map by myself)

                        Originally posted by Andeh View Post
                        this doesnt work for UT99, i just get alot of errors after importing the converted t3d file, and UE3 just freezes.
                        Which errors do you get?

                        Originally posted by thalos View Post
                        1.) That the .ase files are in dos text format not windows which I must convert to using office 2003
                        i'll look into file format for java but just hope changing the format won't cause problem for the UT3 editor
                        Originally posted by thalos View Post
                        2.) The converters refuse to convert the .ase files with the headers you have placed at the beginning. I have to remove all the headers spaces and line breaks to convert. You can place them all in the comments
                        Which head do you remove?
                        Originally posted by thalos View Post
                        3.) The last is MATERIAL_COUNT is set to “0” and should be set to 1
                        Otherwise it reverts to the default material in max on inport and I loose all the Multi/Sub-Object materials that were assigned to the model.
                        Will be fixed this for the next version

                        Originally posted by TheRalfZer0 View Post
                        is there a way of putting a option where we can select what static meshes we want, sometime i only want to use a single static insted of everything?
                        Yes i have thought about that, as well as for the textures. Main problem is that there are no way for the moment to visualize the staticmeshes used so people would have to know which staticmeshes names to keep or not.

                        Comment


                          I'm still having trouble. I saw that a few others had expressed the same sentiment, but I'm using WinXP and the editor crashes when I go to import the map. I followed the step by step instructions (same as the ones R420R mentioned), but after several minutes of setting that up, I still ended up with a crash. I encountered no problems during the conversion process and had no problems that others mentioned with file size.

                          My map is made up of custom-made static meshes and textures. I did notice that while the conversion process collected textures from several texture packages, it missed some of the others that pertained to some water related objects. I have no clue why this is, because some names might be too long in length, but others TX_WaterFoam for example, should be fine.

                          The options I had selected during the conversion were Brushes, Lights, Textures, and StaticMeshes.

                          Any help would be appreciated. I would like to utilize this tool for my portfolio that I'll be finishing over the next month. Take care,

                          -Sentientv2

                          p.s. I did try to convert the DM 1-on-1 albatross map, without going through the step by step process (importing textures and such) and still encountered a crash. It seems as though some data would still be transferred, with error messages that it couldn't locate some of the textures or something like that.

                          Comment


                            I also found out that -in some cases- renaming the Map into something simple (DM-Surrealistic[SE] to Surrealistic) can avoid errors. If you convert StaticMeshes and some fail, this could be a solution. For me it worked.

                            Comment


                              it seems it can't handle custom textures?

                              becasue i tried one of my downloaded maps from UT with this and it failed.

                              Comment


                                The light color / brightness is still messed up.

                                Comment

                                Working...
                                X