Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

UT3 Converter2 - 0.25c / UT4 Converter 0.4.1

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by DemoMan2 View Post
    Stuff in mylevel.utx and Bpo-Materials.utx has an interesting problem. The converter log file appears to be converting textures but the program seems to not be building an output directory for these textures. Net effect is I can't seem to locate these converted textures so map and static meshes have problems with their materials.
    All textures are exported to /UT3Map/Textures even the myLevel package.

    Originally posted by DemoMan2 View Post
    Note: Just an aside but mylevel.utx might contain a material sequence for UT2004 maps. This is usually used to create a map PREVIEW animation that you see when you when you select your levels. This is nothing more than a series of textures with some information about time delays and fading information between pictures. I don't know if this will cause you some trouble so you might want to watch out for this one.
    These kind of textures/materials (shaders,...)are not exported by the UCC.exe program. So UT3Converter cannot and won't be able to convert them. They have to be recreated manually.
    Static Meshes

    Originally posted by DemoMan2 View Post
    This seems to be working pretty well. I still have some meshes that don't have proper translation (i.e. in my case it appears to be on the z axis. Height came in as zero when it should have been say +768 or something like that.
    Tell me which map u convert and the number of the staticmesh which have this problem (once converted).

    Originally posted by DemoMan2 View Post
    Mesh texturing not correct. Probably do to the fact that the mesh uses textures from my custom texture package Bpo-Materials.utx
    Same problem as before, UT3Converter can't convert materials.

    Originally posted by DemoMan2 View Post
    [I]Note: Another aside issue, and its a funny one. My level uses meshes for city streets, billboards, fire escapes and ladders to name a few. When I fired up the level in the UT3 editor I had bots and people walking thru the streets since there was no collision models for these meshes. hehe, that gave me a good laugh.

    You want want to include a short description on how to create a collision mesh in UT3 with you converter. It's pretty simple. Go to the package and click on the mesh. Select mesh editor (i.e. I think this is a right click item). Once in the editor I found that for most things you can use the first option (i.e. 6 DOP Simplified Collision) and things work well for box like shapes. Interesting enough, I had a street ramp that climbs +256 units and that mesh required the Auto convex collision option with the automatic settings used. This took about 5-10 minutes to build collision meshes for about 30 custom meshes in the DM-Bpo-Fragtown-Hillsdale package (i.e. My map package)
    Yes UT3Converter cannot port collision volume because when the staticmeshes are exported to .t3d format it does not contain any data about colission (only shapes).
    I ever know about how to make this collision. I just should make a good manual now for UT3Converter.

    Originally posted by DemoMan2 View Post
    Some thoughts for future versions of converter
    When you have some time you might want to add the conversion of flag bases for red and blue teams and teamplayer start positions. This will allow people to begin to try converting over CTF maps.
    Thanks again for a wonderful tool. Great Job! You are the Java Master!!
    Yes currently all converted maps are set as DM maps. For future versions, it will determine which gametype to set (if it's not UT2004 default gametype, then it will set to DM as default)
    Thx for support!

    Comment


      I just found out some interesting point. I duplicated the Big Tower Static Mesh from Torlan and put it in my Level with a different name (myBigTorlanTower). Then I exported that mesh with your tool. After I got this one.

      Code:
      13.02.2008 22:59:25 org.jdesktop.application.SessionStorage restoreTree
      WARNUNG: No saved state for javax.swing.JTable[jTable1,0,0,363x0,alignmentX=0.0,alignmentY=0.0,border=,flags=251658568,maximumSize=,minimumSize=,preferredSize=,autoCreateColumnsFromModel=true,autoResizeMode=AUTO_RESIZE_SUBSEQUENT_COLUMNS,cellSelectionEnabled=false,editingColumn=-1,editingRow=-1,gridColor=javax.swing.plaf.ColorUIResource[r=128,g=128,b=128],preferredViewportSize=java.awt.Dimension[width=450,height=400],rowHeight=16,rowMargin=1,rowSelectionAllowed=true,selectionBackground=javax.swing.plaf.ColorUIResource[r=49,g=106,b=197],selectionForeground=javax.swing.plaf.ColorUIResource[r=255,g=255,b=255],showHorizontalLines=true,showVerticalLines=true]
      ========= UT3 Converter ==========
      Converting E:\DOWNLOADS\test2.ut2
      Exporting map to .t3d file ....Done (0.953 s)
      Getting StaticMeshes packages names used ....Done (0.0 s)
      Exporting StaticMeshes files to .t3d files ...
      0/4----->test2.ut2....Done!
      1/3----->,ScaleMultiplier=(X=(Min=2....Error: Some meshes couldn't be exported.
      2/3----->,ScaleMultiplier=(X=(Min=0....Error: Some meshes couldn't be exported.
      3/3----->test2....Error: Some meshes couldn't be exported.
      Deleting unused files...9.0Kb have been saved!
      
      2057.0Kb of StaticMeshes have been exported
      Analyzing unexported StaticMeshes ...Done.
      These staticmeshes were not exported:
      0 :500000,Max=2.500000),Y=(Min=2
      1 :200000,Max=0.400000),Y=(Min=0
      [500000,Max=2.500000),Y=(Min=2, 200000,Max=0.400000),Y=(Min=0]
      Converting StaticMeshes to 3D Studio Max Ascii Export Format (.ase)...
      0/1--->myBigTorlanTower.t3d...(Est. Time:210.67 s)..Skipped (Filesize>1Mb)
      Estimated conversion rate: 2.1474836E7 Kb/sec
      Done
      Getting Map Title ...Done (Map Title: Torlan )
      Converting .t3d file to UT3 .t3d format ....Done (0.016 s)
      0 Textures info changed
      Total Conversion Time:4.141 s)
      E:\DOWNLOADS\test2.ut2 has been succesfully ported!
      ===========  END  =============
      This Line irritated me:
      "0/1--->myBigTorlanTower.t3d...(Est. Time:210.67 s)..Skipped (Filesize>1Mb)"

      Is it possible that Static Meshes above 1Mb are skipped by UCC and that's why there is no export?

      Comment


        Originally posted by Cosmix View Post
        I just found out some interesting point. I duplicated the Big Tower Static Mesh from Torlan and put it in my Level with a different name (myBigTorlanTower). Then I exported that mesh with your tool. After I got this one.

        This Line irritated me:
        "0/1--->myBigTorlanTower.t3d...(Est. Time:210.67 s)..Skipped (Filesize>1Mb)"
        Is it possible that Static Meshes above 1Mb are skipped by UCC and that's why there is no export?
        My fault, when testing some maps didn't want to wait too much time for it to be converted to added this limit.
        It's removed now download new version:
        V0.2k:
        Now staticmeshes with filesize>1Mb are converted
        Added partial sounds conversion / AmbientSound actors (ut2004)

        Didn't want to release it so early but you seems to be impatient about converting your mesh .
        Also note if you want the mesh to be textured, you'll have to select "Textures" at conversion panel.
        Also, check your PM, i sent you one.

        Comment


          Thx for removing this limit. I sent you some example multimaterial ASE meshes.

          Comment


            Wow, V0.22 is still out!
            I just checked the pathnode conversion and it worked with pathnodes() but roadpathnodes and flyingpathnodes didnt convert. Is it possible to add them too?

            Comment


              Originally posted by Cosmix View Post
              Wow, V0.22 is still out!
              I just checked the pathnode conversion and it worked with pathnodes() but roadpathnodes didnt converted. Is it possible to add them too?
              yeah haven't included roadpathnodes yet.
              I'm currently working on terrain.
              The heightmap texture format is different as the UT2004 heightmap ones.
              Also the only thing i will be able to do is extract which textures terrain is using as well as alpha layer (for texturing), people will have to create Texture layer Setup as well as Terrain Material

              Comment


                how do i get static meshes to show after i rebuild??

                Comment


                  Originally posted by theadvanced1 View Post
                  how do i get static meshes to show after i rebuild??
                  did u import textures (.psd) and staticmeshes (.ase) before importing the converted map? (.t3d)

                  Comment


                    Originally posted by xtremexp View Post
                    did u import textures (.psd) and staticmeshes (.ase) before importing the converted map? (.t3d)
                    yea. the first thing i did was made a new subtractive level. then i imported all texture psds to a package with the name for the map then i didnt the same with the static meshes. then i imported the t3d file, rebuilt the level and i see and the correct textures are in place and the right size but there are no static meshes in the level i see them in the genric browser (some with textures and some without) but just none in the actual level but i do see the pink outlines for them

                    am i doing something wrong or missing a step??

                    Comment


                      XtremeXP: I upgraded my machine, everything is new
                      I'm running: Windows Vista Ultimate 32bit
                      CPU: C2D 2.33GHZ 4Mb
                      RAM: 2049MB DDRII 800Mhz
                      GPU: Nvida Geforce 7950 512MB x 2

                      And I'm still ketting that "black walls"???

                      Comment


                        is it even suposed to place the static meshes in the map? because i cant figure out why there are only showing in the generic browser

                        Comment


                          Originally posted by theadvanced1 View Post
                          is it even suposed to place the static meshes in the map? because i cant figure out why there are only showing in the generic browser
                          did u save the staticmeshes with these settings?
                          packagename: filename (e.g: "CTF-Face.ut2" would give "CTF-Face")
                          Group: (none)

                          Comment


                            can you give me like a detailed list of steps in order becuase im saving both textures and meshes in the same package named correctly and im still only seeing textures placed in the map after i rebuild

                            Comment


                              when i rebuild i have in my map check "staticMeshActor_0: static mesh actor has NULL Static Mesh property"

                              and it basically has that same error for all 1000+ meshes in the level ???????

                              Comment


                                Make a new substracted enviroment and save with your choosen map name.
                                (Dont close editor now or load a different map.)
                                After that import all textures into your map package and make a material out of the red bordered textures.
                                Then you have to import static meshes into same package like the name of your map and textures. Before import choose the package within the generic browser.
                                After that dont close the editor! Also if you save the map in this state, everything will be lost! Only referenced materials and in map placed static meshes will be saved.
                                Your last step is to import the map itself (not with generic browser). After rebuild all you can save the map and everything should work.

                                Comment

                                Working...
                                X