Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Preparing your map for publishing and distribution

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by MrCobra View Post
    How do you cook just an external textures package? The original was only 40 megs. The new one is now 122+. Why such a big size difference for the exact same content?
    You should keep everything in the map file, especially if the textures are specific to that map. There is no reason not to do that, it's just more files and more housekeeping. If you plan on using that same texture package for other maps, you can't update it once the first is released or you can run into versioning problems.

    ut3.exe cookpackages <package_name>

    Original what? Original UT3 package?
    Textures retain the source .tga/.bmp until cooked, so the package is always large when uncooked.

    Comment


    • #17
      Originally posted by jureidinim View Post
      Thanks for the tutorial.
      However, I am having trouble adding music.

      I open the UTINFO and see the MapMusicInfo selection - but when I click on the arrow to "Use Current Selction in Browser".. nothing happens.

      I have the browser open with (example) A_Music_Strident selected and A_Music_Strident_Supense01 highlighted.

      Am I missing something?

      Thanks

      PS - Your tutorial mentioned a "Tracks" group, but i only see "Sound", "Sound Waves" and "Sound Cues". I do get the music playing in "Sound Wave" by right clicking an play on th individual objects in thebrowser.
      Actually DG should add in that you need to sort with 'UTMusic" not "Sound" for the generic Browser.

      load the package he asks you to load, then click "UTMusic" filter box in the generic browser. The tracks then all show up in that package. click one (highlight), then choose "use from source" in the world properties, UTmapinfo menu.

      Comment


      • #18
        Originally posted by DGUnreal View Post
        You should keep everything in the map file, especially if the textures are specific to that map. There is no reason not to do that, it's just more files and more housekeeping.
        Not a problem there. It's a shared textures and materials library.

        If you plan on using that same texture package for other maps, you can't update it once the first is released or you can run into versioning problems.
        It will never be updated once the materials are good to go.

        ut3.exe cookpackages <package_name>
        Thanks!!

        Original what? Original UT3 package?
        UT2K4 texture package. I created normal maps for everything & speculars for the things that needed them.

        Textures retain the source .tga/.bmp until cooked, so the package is always large when uncooked.
        I didn't know that. I had assumed that since they were listed as DXT1 & DXT5 in the generic browser that they were already compressed. It just seemed strange that the same content (well, just a bit more added) would take so much room as compared to the original UTX package.


        Anyway, thanks for your time to answer my question and for giving the feedback. It's appreciated.

        Comment


        • #19
          Originally posted by SKYFURNACE View Post
          Actually DG should add in that you need to sort with 'UTMusic" not "Sound" for the generic Browser.

          load the package he asks you to load, then click "UTMusic" filter box in the generic browser. The tracks then all show up in that package. click one (highlight), then choose "use from source" in the world properties, UTmapinfo menu.
          The A_Music_Arrangements package only contains UTMapMusicInfo objects, so there is no need to filter. Simply open this package, select the MusicInfo you want, and assign it to the appropriate World property.

          It is only if you start looking in the other music packages that you see the Sound objects. You only need to go there if you want to preview the song snippets, as mentioned in my post.

          Comment


          • #20
            i had to filter sort mine, i had both showing up in the browser.

            Comment


            • #21
              That is odd. My A_Music_Arrangements package only contains UTMapMusicInfo objects.

              Comment


              • #22
                Dangit. No matter how many times I've tried to get a preview picture to work, success still eludes me..

                Is there anyone here who has successfully implement a preview picture that can take a look at my map & ini and see what I'm doing wrong?

                Comment


                • #23
                  Originally posted by DGUnreal View Post
                  That is odd. My A_Music_Arrangements package only contains UTMapMusicInfo objects.
                  Yes, but when i load the editor, it autoloads "sounds" and even after i load the package, i must manually check the "UT Map Music" Filter to see them in the browser.... Maybe i am just using the browser wrong or in a different way.

                  Comment


                  • #24
                    I don't see this stickied yet, it need to be stickied, it's just what any mapper wants to read all in 1 place.

                    Comment


                    • #25
                      Hmm, I have some trouble adding the map description. The preview pic works fine, but the description just doesn't show up. (You are supposed to see the description in the in-game menu under "Game", am I right there?)

                      This is what I put into my ini file for testing purposes:
                      [DM-Xaero UTUIDataProvider_MapInfo]
                      MapName=DM-Xaero
                      FriendlyName=Xaero
                      NumPlayers=4 to 12 players
                      PreviewImageMarkup=<Images:resources_xaero.Preview >
                      Description=My 1337 description

                      Comment


                      • #26
                        *edit*

                        It appears that the Description entry works for some but not for others.
                        I am trying to determine why it does this.

                        Comment


                        • #27
                          Originally posted by Jagnot View Post
                          Dangit. No matter how many times I've tried to get a preview picture to work, success still eludes me..

                          Is there anyone here who has successfully implement a preview picture that can take a look at my map & ini and see what I'm doing wrong?
                          What occurs when you try to add the screenshot?
                          Can you successfully import the Texture, create the Material, apply it to a surface in your map, etc?
                          Make sure that you use the Texture name in the .ini and not the Material name.
                          You can also open the cooked map up in the editor and verify that the Texture has remained in the map file.


                          Originally posted by SKYFURNACE View Post
                          Yes, but when i load the editor, it autoloads "sounds" and even after i load the package, i must manually check the "UT Map Music" Filter to see them in the browser.... Maybe i am just using the browser wrong or in a different way.
                          Do you have the A_Music_Arrangements package selected by itself in the Generic Browser?
                          If you select multiple packages in the browser, it shows all of the content from all of them.

                          Comment


                          • #28
                            Originally posted by DGUnreal View Post
                            What occurs when you try to add the screenshot?
                            Can you successfully import the Texture, create the Material, apply it to a surface in your map, etc?
                            Make sure that you use the Texture name in the .ini and not the Material name.
                            You can also open the cooked map up in the editor and verify that the Texture has remained in the map file.
                            I have a feeling no-one will take me seriously after this, but, I accidently forgot the "P" in "Preview" in the INI.. Everything is working fine now..

                            Comment


                            • #29
                              Bump. Mods don't like me I guess...

                              Comment


                              • #30
                                Thanks for this! it really helped me figure that level preview out.

                                One thing that I would add in distribution part(or maybe someone can explain to why people do this) is to NOT create a .rar/.zip with folders inside folders in it. It's really a hassle when you are uncompressing multiple files that all go to the same place and 2 or 3 are like that.

                                Comment

                                Working...
                                X