Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Publishing and Cooking UT3 Community Maps

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by stephen_wq View Post
    What about if the -nohomedir parameter is used when starting the game? Can the content then be placed in the program folder?
    Yes, I'm using it and it works

    Comment


    • #17
      After cooking my map it works and everything but I get the following extras....

      uxc_first_level.upk (this is what I described my custom package as...) this is ok but this is on top of my .upk file and my .ut3 file...

      I thought after cooking there should only be one .upk file?

      Also the following are created:

      GlobalPersistentCookerData.upk
      RefShaderCache-PC-D3D-SM3.upk
      RefShaderCache-PC-D3D-SM2.upk
      RefShaderCache-PC-D3D-SM4.upk

      I can't figure out why my level is creating two .upk files. I did however bring in custom content but I thought that would be saved in the regular .upk... LOST

      Comment


      • #18
        So what should you actually distribute when you for example want to test a map with a m8.
        Which files should i send him ?
        Cause when i send him the ut3 file (cooked)when he joins he still has to download the map.

        Comment


        • #19
          alright, so after a few wasteful hours, this is where am at:

          i work on a level and save it 2 the unpublished folder, thought i mite as well check out how its goin, i use the -useunpublished flag and run the game, but is my map in the list? OF COURSE NOT!!

          so i say, oh wat the hell, who wants 2 play unpublished, go for the gold!! so i cook it...wait forever...and then its done, i go into the game without using the flag this time, is my level in the list? again...NO! so at this point am willing 2 try anythin so i run the game one last time WITH the flag, mayb smthn interesting will happen this time, but .... u no!

          SO! wat now? i mean i love testin the level in the editor but u no? i really miss the flawless simple button back in 2004 which says play level and u immediately run the game INSIDE the level...without any cooking or cleaning or what have you....]

          anyone else got the same problem?!

          Comment


          • #20
            just curious, why did they put the publish thing in?

            Comment


            • #21
              to make life easier, no doubt!

              Comment


              • #22
                Ok, so I've made a map in the editor and its ready for some in-game testing so I figured I'd cook the map and test it, however when I press the 'Publsih/Cook' button I end up getting this:

                Init: Version: 3487
                Init: Epic Internal: 0
                Init: Compiled: Oct 21 2007 03:17:32
                Init: Command line: -platform=PC CTF-Test -AlwaysRecookMaps -UpdateInisAuto
                Init: Base directory: D:\Spel\Program\Unreal Tournament 3\Binaries\
                Init: Character set: Unicode
                Log: Executing Class Editor.CookPackagesCommandlet
                Log: GConfig::Find has loaded file: ..\Engine\Localization\int\Editor.int
                UserModeType: <0>
                ..\UTGame\Published\CookedPC\GlobalPersistentCooke rData.upk is out of date. Forcing a full recook.

                Error, Failed to load base level CTF-Test

                Warning/Error Summary
                ----------------------

                Error, Failed to load base level CTF-Test

                Commandlet->Main return this error code: 1
                With 1 error<s>, warning<s>


                Execution of commandlet took: 1.38

                I have no clue of what I'm supposed to do here, it also deleted the maps I allready had in the Published/CookedPC/CustomMaps folder.

                EDIT: Apparently my downloaded mutators had been deleted aswell as the maps.

                Comment


                • #23
                  Originally posted by Reverse View Post
                  Ok, so I've made a map in the editor and its ready for some in-game testing so I figured I'd cook the map and test it, however when I press the 'Publsih/Cook' button I end up getting this:

                  Init: Version: 3487
                  Init: Epic Internal: 0
                  Init: Compiled: Oct 21 2007 03:17:32
                  Init: Command line: -platform=PC CTF-Test -AlwaysRecookMaps -UpdateInisAuto
                  Init: Base directory: D:\Spel\Program\Unreal Tournament 3\Binaries\
                  Init: Character set: Unicode
                  Log: Executing Class Editor.CookPackagesCommandlet
                  Log: GConfig::Find has loaded file: ..\Engine\Localization\int\Editor.int
                  UserModeType: <0>
                  ..\UTGame\Published\CookedPC\GlobalPersistentCooke rData.upk is out of date. Forcing a full recook.

                  Error, Failed to load base level CTF-Test

                  Warning/Error Summary
                  ----------------------

                  Error, Failed to load base level CTF-Test

                  Commandlet->Main return this error code: 1
                  With 1 error<s>, warning<s>


                  Execution of commandlet took: 1.38

                  I have no clue of what I'm supposed to do here, it also deleted the maps I allready had in the Published/CookedPC/CustomMaps folder.

                  EDIT: Apparently my downloaded mutators had been deleted aswell as the maps.
                  I am looking for the same answer.

                  Comment


                  • #24
                    this is just ridiculous!

                    Comment


                    • #25
                      Originally posted by Reverse View Post
                      Ok, so I've made a map in the editor and its ready for some in-game testing so I figured I'd cook the map and test it, however when I press the 'Publsih/Cook' button I end up getting this:

                      Init: Version: 3487
                      Init: Epic Internal: 0
                      Init: Compiled: Oct 21 2007 03:17:32
                      Init: Command line: -platform=PC CTF-Test -AlwaysRecookMaps -UpdateInisAuto
                      Init: Base directory: D:\Spel\Program\Unreal Tournament 3\Binaries\
                      Init: Character set: Unicode
                      Log: Executing Class Editor.CookPackagesCommandlet
                      Log: GConfig::Find has loaded file: ..\Engine\Localization\int\Editor.int
                      UserModeType: <0>
                      ..\UTGame\Published\CookedPC\GlobalPersistentCooke rData.upk is out of date. Forcing a full recook.

                      Error, Failed to load base level CTF-Test

                      Warning/Error Summary
                      ----------------------

                      Error, Failed to load base level CTF-Test

                      Commandlet->Main return this error code: 1
                      With 1 error<s>, warning<s>


                      Execution of commandlet took: 1.38

                      I have no clue of what I'm supposed to do here, it also deleted the maps I allready had in the Published/CookedPC/CustomMaps folder.

                      EDIT: Apparently my downloaded mutators had been deleted aswell as the maps.
                      I have the exact same problem. I have no idea what I did, but one time I did get it to let me cook but then the map would never show up as playable, the game loaded with an "ambiguous package" error, and when I loaded it manually through the console the graphics were completely screwed up. Everything was the absolute minimum detail and textures would only show up once you got near the object's center.

                      I bought UT3 for the custom content and development aspects. I could really care less about the built in stuff. I am not a happy customer.

                      EDIT: I even tried creating a simple box map to test the editor, and it won't cook either. Everything builds, no errors, and it plays. When I go to cook it fails to work. It's always the same error.

                      Comment


                      • #26
                        Originally posted by BigDragon View Post
                        the console the graphics were completely screwed up. Everything was the absolute minimum detail and textures would only show up once you got near the object's center.
                        I belive you can fix this by selecting the StaticMeshActor, open up the properties and enable 'bForceMipStreaming'.

                        Comment


                        • #27


                          Huh?
                          Whats up with the double \\?

                          Comment


                          • #28
                            Originally posted by Reverse View Post
                            Ok, so I've made a map in the editor and its ready for some in-game testing so I figured I'd cook the map and test it, however when I press the 'Publsih/Cook' button I end up getting this:

                            Init: Version: 3487
                            Init: Epic Internal: 0
                            Init: Compiled: Oct 21 2007 03:17:32
                            Init: Command line: -platform=PC CTF-Test -AlwaysRecookMaps -UpdateInisAuto
                            Init: Base directory: D:\Spel\Program\Unreal Tournament 3\Binaries\
                            Init: Character set: Unicode
                            Log: Executing Class Editor.CookPackagesCommandlet
                            Log: GConfig::Find has loaded file: ..\Engine\Localization\int\Editor.int
                            UserModeType: <0>
                            ..\UTGame\Published\CookedPC\GlobalPersistentCooke rData.upk is out of date. Forcing a full recook.

                            Error, Failed to load base level CTF-Test

                            Warning/Error Summary
                            ----------------------

                            Error, Failed to load base level CTF-Test

                            Commandlet->Main return this error code: 1
                            With 1 error<s>, warning<s>


                            Execution of commandlet took: 1.38

                            I have no clue of what I'm supposed to do here, it also deleted the maps I allready had in the Published/CookedPC/CustomMaps folder.

                            EDIT: Apparently my downloaded mutators had been deleted aswell as the maps.

                            Anyone have a solution to this issue? Without being able to playtest my map design, it is useless for me to proceed .

                            Comment


                            • #29
                              Do we have a geek here who can make a program to install the custom-maps correctly (some sort of cache manager)? Would be really nice

                              Gr Fragger

                              Comment


                              • #30



                                *sigh*

                                Comment

                                Working...
                                X