Announcement

Collapse
No announcement yet.

how to open a .U file to examine contents?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    how to open a .U file to examine contents?

    hey guys

    i'm just getting started learning unrealscript and am totally at noob stage. i want to open some of the compiled .U files that came with some custom characters (like Malcolm, Samus, Evangelions) to learn how others coded stuff. how are compiled .U files opened and examined?

    thanks
    jag

    #2
    its pretty much readable, but if you want to extract it cleanly you can just export all scripts, they will be exported, but some packages might have their source stripped.

    Comment


      #3
      If you are wanting to read the .u files of the engine for modding then you are going to want to export the scripts to get the .uc files. (.uc files are the recompiled version of UnrealScript)

      To do this you just open the UT3 Editor and it should default by opening up what is called the Generic Browser. If not then go up to View -> Browser Windows -> Generic Browser. Anyhow there are tabs across the top of this window. Click on the Actor Classes tab. Now go to File -> Export All Scripts. This will give the scripts provided by Epic.

      If you are wanting to get the .uc files of other peoples .u files then you are wanting to do what is called decompiling the code. Some frown on this but I see it as a way to look at what they have done to learn from it.

      You can see how it is done in this video.
      http://www.youtube.com/watch?v=DT0RJkPGdTU

      Hope this helps, we all have to start somewhere. Good luck.

      Comment


        #4
        I suggest browsing one of the many online UnCodeX hypertext source code documents.

        Comment


          #5
          Decompiling scripts using the UnrealEd is only a scholarly affair as it pretty much "guesses" for the values of the defaultproperties of the code. It does alright for floats, ints, and the like, but the objects defined in the defaultproperties will throw up compiling errors. If you are intent on using the code, you will need to fix these manually.

          This is true for custom scripts, I'm not sure if its true for epic's scripts. I have never tested it.

          Comment


            #6
            thanks guys for the advice. i went from zero skills with unrealscript last week to now being able to build custom factions/families, etc.

            notepad++ rocks too!

            thx

            Comment


              #7
              anyone know a way to edit a .u file?

              Comment


                #8
                you have to decompile it in order to edit it

                Comment


                  #9
                  OK, did that. done, accept i cant recompile it!!!

                  Could you please help me here?
                  http://forums.epicgames.com/showthre...0#post28063180

                  Comment


                    #10
                    Originally posted by idnewton View Post
                    anyone know a way to edit a .u file?
                    You don't, period.

                    Unreal Engine editing simply doesn't work that way. Look up modding tutorials for UT3 if you want to learn the real way of doing it.

                    Comment


                      #11
                      this is super helpful for a current issue i have-

                      After obtaining expressed permission from people who have created maps/ mods etc - this can be a good way to learn.

                      + all those maps and mods etc that people made and have since deleted from their HDD can now be restored.
                      - example- fixing the numerous issues with demolition2 mod etc// understanding destructibles by Remus etc and other awesome mods that the authors no longer have...etc
                      - Tis a bit hax though.

                      Compile:
                      as for your Compiling issue, simply add the word ... make
                      to the end of your ut3 shortcut- following your forum link i can see :
                      - you have a "full" command in your shortcut that i have never used. - just "make" is fine
                      - and make sure you have modpackages=mymod etc in your editor.ini

                      Comment


                        #12
                        At the request of TKBS (i think this is the thread he wanted me to post this in)

                        OK, you do the batch file and the -full right? and it still doesnt work. NOW, the last step is this. search your computer for the UTEditor.ini. at almost the very bottom of the file you see the catagory called [ModPackages]. now, you make a new line in that catagory which is this:

                        ModPackages=[whatever your mod name is that you used in the src folder]

                        done. to compile, either use the compiler batch file, or just boot up the editor (booting up the game didnt work for me oddly. it even ask to update outdated scripts)

                        make sure that your batch file says 'make -full' at the end of the url NOT 'make'

                        that should do it!!

                        Now can someone tell me how to fix my issue?!!?
                        its here:
                        http://forums.epicgames.com/showthre...0#post28063180

                        edit: sorry i got compiling stuff and uncompiling stuff mixed up. the youtube vid explains it i think. idk. btw, i did do make AND make -full. that fixed it not seeing it BUT, check out link above. theres my prob

                        Comment


                          #13
                          LOL- 2 THREADS GOING!
                          IDnewton i am trying my best for you - i will PM you if i get success for you
                          Many Thanks for your replies

                          edit-
                          nope i totally do not understand you.
                          IDNEWTON QUOTE
                          "do the batch file and the -full"
                          This is me trying to decompile
                          - ok i make a '.bat' file
                          Then i drag my Published Cooked ".u " file into it- and nothing happens
                          -make a shortcut to UT3 with 'make-full' at the end [this is not a decompile process btw = make = compile]
                          so straight away i am totally confused.
                          - change your editor.ini - to modpackages=?? again this is for a compilingc step-

                          if we are using published files- they will not be in the Source folder- do you understand?

                          - okay now you say this:
                          "to compile, either use the compiler batch file, or editor"
                          - if you use the editor- im sorry- but why have i created batch export file if u say you can use editor-
                          *This which will not work because you do not have the source files -lmao


                          then you say
                          "it even ask to update outdated scripts" LMAO
                          of course it says that -- you just told it to using the editor.ini - lolwtf-
                          again why did i even bother creating a batch export if you/ i am not using it?

                          P.S.
                          IN MY PREVIOUS POST I SAID THIS
                          - and make sure you have modpackages=mymod etc in your editor.ini

                          then you ask me to try the same thing lol -
                          funny stuff
                          i think you need to provide a little more information - for example
                          what files are you using-
                          - are you currently trying to decompile or recompile?
                          - if u are using compile- what is it you are trying to make- a weapon a gametype a mutator - etc?- specify and i can help you more hopefully
                          what files did you put in the source folder???
                          this really confused me --
                          - because i gurantee they are not source files -
                          source files are UC lol

                          - unless you have already decomipled a ".u" if so- what ".u " did u decompile-
                          if i do everything you have done we can help eeach other easily-
                          i hope this does not sound retarded
                          sorry if it does
                          lol
                          Many Thanks again

                          Comment


                            #14
                            yeah im getting really confused about all this compiling and uncompiling stuff. so i help you out then u help me out k? so i'll TRY to make more sense this time (and not get confused with compiling). This is all i did i think:

                            Make a new document in something like notepad (is what i used). type in this:

                            "[The location of your ut3.exe. for me it was: C:\Program Files (x86)\Unreal Tournament 3\Binaries\UT3.exe]" batchexport %1 class .uc "[now put the output directory. i just chose a folder on the desktop i had made for this]"

                            Save the file as this:

                            UT3_BatchExport.bat

                            make sure that when you save it, right below the name you set it to 'all files' not '.txt'

                            now take your .u file and drag it on top of that batch file. once it's done, check in the output folder. this KINDA worked for me til i realized it wasn't exporting any WP_ files. thats probably my problem not the method's problem. you should have a bit more success with this method than my previous explaination failure!

                            Comment


                              #15
                              yep-
                              what you have there is a perfect description of the video-
                              nice-
                              but this does not work-i get no output
                              and now i cannot even start UT3 - service is temp unavail.lol.
                              sorry bro -

                              Comment

                              Working...
                              X