Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

UnrealScript Studio: IDE for UnrealScript 3

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • hey, just installed the latest version of nFringe - it's bad ass! The class view is now working for me, and a lot more code warnings are appearing. great job!

    Comment


    • LOL those warnings are wrong. I'm getting rid of them on Tuesday, and I'll put them back in when it's actually correct.

      Comment


      • Possible bug? My build output shows the following location for my .u file, however when I browse to that location, the .u file does not exist:

        ------ Build started: Project: VehicleTest, Configuration: Debug Win32 ------
        VehicleTest -> C:\Documents and Settings\jskaggs\My Documents\Visual Studio 2008\Projects\VehicleTest\VehicleTest\Unpublished\ CookedPC\Script\VehicleTest.u
        ========== Build: 1 succeeded or up-to-date, 0 failed, 0 skipped ==========


        The file is actually located in:
        C:\Documents and Settings\jskaggs\My Documents\My Games\Unreal Tournament 3\UTGame\Unpublished\CookedPC\Script


        Also, I notice that the build just fails if the .u file is loaded into the Unreal Editor and the editor is still open. Closing the Unreal Editor will allow the build to succeed, so I assume its a file locking issue. I think it would be nice if nFringe could report the reason for failure in this case (e.g. "Unable to delete file ....").

        Comment


        • Originally posted by 280Z28 View Post
          LOL those warnings are wrong. I'm getting rid of them on Tuesday, and I'll put them back in when it's actually correct.
          LMAO well at least the class view works

          Comment


          • I'm having real trouble with intellisense. Been all over your forums, but it just refuses to work.

            I was working with notepad ++ before, and defaulted .uc to be opened by that, if that helps?

            Comment


            • Originally posted by BeastRules222 View Post
              I'm having real trouble with intellisense. Been all over your forums, but it just refuses to work.

              I was working with notepad ++ before, and defaulted .uc to be opened by that, if that helps?
              Does syntax highlighting for .uc files work in Visual Studio?

              If syntax highlighting works, does the word "config" highlight as a keyword (by default blue). If not, check Tools > Options > Text Editor > File Extension, and make sure you do not have .uc files set to open in the Microsoft Visual C++ editor.

              Do you have the Reference Source path configured, where the reference sources show in the Solution Explorer?

              Do errors show in the Errors window when you have UnrealScript files open? Certain errors cause IntelliSense to fail, in which case you should send me one of the failing files so I can fix it.

              Let me know!

              Thanks,
              Sam

              Comment


              • Thanks for quick reply,

                Yes, the highlighting works, and i also have the reference source (scriptsource 1.4)

                I don't think it's giving me any errors, when i load VS the only thing that seems to be remotely related to intellisense is the ANTLR intellisense engine, which says parsing 2000 files etc.

                Possibly a symptom; while most classes will show as a greeny blue when I type them in, the PlayerController class doesn't.

                EDIT:

                Just to note: I have VS 2008 shell.

                Comment


                • Originally posted by BeastRules222 View Post
                  Thanks for quick reply,

                  Yes, the highlighting works, and i also have the reference source (scriptsource 1.4)

                  I don't think it's giving me any errors, when i load VS the only thing that seems to be remotely related to intellisense is the ANTLR intellisense engine, which says parsing 2000 files etc.

                  Possibly a symptom; while most classes will show as a greeny blue when I type them in, the PlayerController class doesn't.

                  EDIT:

                  Just to note: I have VS 2008 shell.
                  The parse error is occurring in the PlayerController class, resulting in it not being adding to the IntelliSense database. I believe a new function modifier keyword was added that nFringe doesn't recognize. You can add it in the Function Modifiers category in Tools > Options > nFringe Options > Keywords.

                  Comment


                  • Originally posted by 280Z28 View Post
                    The parse error is occurring in the PlayerController class, resulting in it not being adding to the IntelliSense database. I believe a new function modifier keyword was added that nFringe doesn't recognize. You can add it in the Function Modifiers category in Tools > Options > nFringe Options > Keywords.
                    Umm... I don't have a clue what keyword that would be...

                    And where can I see this parse error?

                    EDIT: I found how to get parse errors up:

                    I get this:

                    Code:
                    C:\Users\Dave\Documents\My Games\Unreal Tournament 3\UTGame\Src\Engine\Classes\PlayerController.uc(0,0): UnrealScript: Errors occurred during a pre-parse operation.

                    Comment


                    • Originally posted by BeastRules222 View Post
                      Umm... I don't have a clue what keyword that would be...

                      And where can I see this parse error?

                      EDIT: I found how to get parse errors up:

                      I get this:

                      Code:
                      C:\Users\Dave\Documents\My Games\Unreal Tournament 3\UTGame\Src\Engine\Classes\PlayerController.uc(0,0): UnrealScript: Errors occurred during a pre-parse operation.
                      Double click it, and it'll open PlayerController.uc. Once that file is open, you'll get the detailed errors listed in the Errors window.

                      Comment


                      • Originally posted by 280Z28 View Post
                        Double click it, and it'll open PlayerController.uc. Once that file is open, you'll get the detailed errors listed in the Errors window.
                        Thanks for your patience...

                        I don't see any errors when I open it up though. I assumed u meant the error list window?

                        EDIT:

                        I'VE FIXED INTELLISENSE! TO all: make sure .NetFramework SDK 2.0 is installed (might be worth adding this to wiki).

                        Comment


                        • Hello
                          I get an error if i try to build anything. I have made the very good tutorials at http://www.jadeskaggs.com/category/tutorials/ but if i click on start debuging i get a error saying error at building do you want to continue with the last working build.
                          i even get thes error if i try to run a unedited default unreal script game mod template.
                          Please help somebody

                          Comment


                          • nvm.. thanks for the help.

                            Comment

                            Working...
                            X